Find the answer to your Linux question:
Results 1 to 3 of 3
Hi everyone, I own a Dell Latitude D800, Ive recently installed Fedora core 2. Ive got 3 problems, here they are by order of annoyance: 1. I cant get my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    2

    wide screen issues


    Hi everyone,

    I own a Dell Latitude D800, Ive recently installed Fedora core 2. Ive got 3 problems, here they are by order of annoyance:

    1. I cant get my resolution (1280x800) to work, ive tried every single configuration i found online. (modes section, or a modeline line in the monitor section).
    I did manage to get a 1280x960 after I set the modeline to the one I got using the command gtf 1280 800 60. But itś not what im looking for...

    2. My mozilla gets stuck for a few seconds every once in a while (too often) , very odd.

    3. I need to click twice for several characters in order for them to print, such as: ` ^ (and they come out wierd)

    as for 1, here is my xorg.conf:

    # Xorg configuration created by system-config-display

    Section "ServerLayout"
    Identifier "single head configuration"
    Screen 0 "Screen0" 0 0
    InputDevice "Mouse0" "CorePointer"
    InputDevice "Keyboard0" "CoreKeyboard"
    EndSection

    Section "Files"

    # RgbPath is the location of the RGB database. Note, this is the name of the
    # file minus the extension (like ".txt" or ".db"). There is normally
    # no need to change the default.
    # Multiple FontPath entries are allowed (they are concatenated together)
    # By default, Red Hat 6.0 and later now use a font server independent of
    # the X server to render fonts.
    RgbPath "/usr/X11R6/lib/X11/rgb"
    FontPath "unix/:7100"
    EndSection

    Section "Module"
    Load "dbe"
    Load "extmod"
    Load "fbdevhw"
    Load "glx"
    Load "record"
    Load "freetype"
    Load "type1"
    Load "dri"
    EndSection

    Section "InputDevice"

    # Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
    # Option "Xleds" "1 2 3"
    # To disable the XKEYBOARD extension, uncomment XkbDisable.
    # Option "XkbDisable"
    # To customise the XKB settings to suit your keyboard, modify the
    # lines below (which are the defaults). For example, for a non-U.S.
    # keyboard, you will probably want to use:
    # Option "XkbModel" "pc102"
    # If you have a US Microsoft Natural keyboard, you can use:
    # Option "XkbModel" "microsoft"
    #
    # Then to change the language, change the Layout setting.
    # For example, a german layout can be obtained with:
    # Option "XkbLayout" "de"
    # or:
    # Option "XkbLayout" "de"
    # Option "XkbVariant" "nodeadkeys"
    #
    # If you'd like to switch the positions of your capslock and
    # control keys, use:
    # Option "XkbOptions" "ctrl:swapcaps"
    # Or if you just want both to be control, use:
    # Option "XkbOptions" "ctrl:nocaps"
    #
    Identifier "Keyboard0"
    Driver "keyboard"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us_intl"
    EndSection

    Section "InputDevice"
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "IMPS/2"
    Option "Device" "/dev/input/mice"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "yes"
    EndSection

    Section "Modes"
    Identifier "16:10"
    ModeLine "1280x800" 83.5 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
    EndSection

    Section "Monitor"

    #ModeLine "1280x800@60" 83.5 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
    Identifier "Monitor0"
    VendorName "Monitor Vendor"
    ModelName "LCD Panel 1280x800"
    UseModes "16:10"
    HorizSync 30.0 - 60.0
    VertRefresh 50.0 - 100.0
    Option "dpms"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "nv"
    VendorName "Videocard vendor"
    BoardName "NVIDIA GeForce 4 (generic)"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 16
    Modes "1280x800" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    EndSection

    Section "DRI"
    Group 0
    Mode 0666
    EndSection

    hoping to hear some advice,
    Tal.

  2. #2
    Linux User
    Join Date
    Jul 2004
    Posts
    256

    Re: wide screen issues

    I have an nvidia card So I can help you out

    1) You're config should look like this:
    Code:
    Section "Device"
        #nave of your graphics card, use this ID for the Screen section
        Identifier  "nvidia geForce FX 5600"
        Driver      "nvidia"
        VideoRam    262144 #optional, measured in KB
    EndSection
    
    Section "Screen"
        Identifier  "Screen 1"
        Device      "nvidia geForce FX 5600"
        Monitor     "DellM781S"
    	#set depth to whatever you want the default
        DefaultDepth 24
    
    	#modes is a list, first is tried, until it gets one that works
        Subsection "Display"
            Depth       8
            Modes       "1280x1024" "1024x768" "800x600" "640x480"
            ViewPort    0 0
        EndSubsection
        Subsection "Display"
            Depth       16
            Modes       "1280x1024" "1024x768" "800x600" "640x480"
            ViewPort    0 0
        EndSubsection
        Subsection "Display"
            Depth       24
            Modes       "1280x1024" "1024x768" "800x600" "640x480"
            ViewPort    0 0
        EndSubsection
    EndSection
    2) might have to do with not using hardware acceleration. the driver nv uses software mode. Go get the hardware accelerated driver http://www.nvidia.com/object/linux.html (get the IA32 one)

    3) It looks like you are using an international keyboar layout. Is your keyboard a US keyboard? If so, in your X config, replace
    Code:
    Option "XkbLayout" "us_intl"
    with
    Code:
    Option "XkbLayout"  "us"
    good luck!
    --monkey

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Posts
    2
    Alright!

    (1) is finally working. bellow is my final xorg.conf - after thousands of changes .
    it appears i havent been using the proper driver, as you said. This gave me the nvidia logo, and after some more tweaking I got the proper resolution. So for any Latitude D800 user with GeForce 4200 Go video card, installed with a fresh Fedora Core 2 copy - this Should work.

    about (2) Im still expriencing a lag when loading pages, meaning if a packed web site is loading, My Mozilla is kinda frozen until the web is completly onscreen. This lag is typical for other applications as well.

    and about (3) I AM using an international keyboard (Israel), so Im not sure I should change that setting - what do you think?

    heres the xorg.conf:
    Code:
    # Xorg configuration created by system-config-display
    
    Section "ServerLayout"
    	Identifier     "single head configuration"
    	Screen      0  "Screen0" 0 0
    	InputDevice    "Mouse0" "CorePointer"
    	InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
    
    # RgbPath is the location of the RGB database.  Note, this is the name of the 
    # file minus the extension (like ".txt" or ".db").  There is normally
    # no need to change the default.
    # Multiple FontPath entries are allowed (they are concatenated together)
    # By default, Red Hat 6.0 and later now use a font server independent of
    # the X server to render fonts.
    	RgbPath      "/usr/X11R6/lib/X11/rgb"
    	FontPath     "unix/:7100"
    EndSection
    
    Section "Module"
    	Load  "dbe"
    	Load  "extmod"
    	Load  "fbdevhw"
    	Load  "glx"
    	Load  "record"
    	Load  "freetype"
    	Load  "type1"
    	Load  "dri"
    EndSection
    
    Section "InputDevice"
    
    # Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
    #	Option	"Xleds"		"1 2 3"
    # To disable the XKEYBOARD extension, uncomment XkbDisable.
    #	Option	"XkbDisable"
    # To customise the XKB settings to suit your keyboard, modify the
    # lines below (which are the defaults).  For example, for a non-U.S.
    # keyboard, you will probably want to use:
    #	Option	"XkbModel"	"pc102"
    # If you have a US Microsoft Natural keyboard, you can use:
    #	Option	"XkbModel"	"microsoft"
    #
    # Then to change the language, change the Layout setting.
    # For example, a german layout can be obtained with:
    #	Option	"XkbLayout"	"de"
    # or:
    #	Option	"XkbLayout"	"de"
    #	Option	"XkbVariant"	"nodeadkeys"
    #
    # If you'd like to switch the positions of your capslock and
    # control keys, use:
    #	Option	"XkbOptions"	"ctrl:swapcaps"
    # Or if you just want both to be control, use:
    #	Option	"XkbOptions"	"ctrl:nocaps"
    #
    	Identifier  "Keyboard0"
    	Driver      "keyboard"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "us_intl"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse0"
    	Driver      "mouse"
    	Option	    "Protocol" "IMPS/2"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "ZAxisMapping" "4 5"
    	Option	    "Emulate3Buttons" "yes"
    EndSection
    
    Section "Modes"
    	Identifier     "16:10"
            # 1280x800 @ 60.00 Hz (GTF) hsync: 49.68 kHz; pclk: 83.46 MHz
    	Modeline "1280x800"  83.46  1280 1344 1480 1680  800 801 804 828  -HSync +Vsync
    EndSection
    
    Section "Monitor"
    #	ModeLine     "1280x800@60" 83.5 1280 1344 1480 1680 800 801 804 828 -HSync +Vsync
    	Identifier   "Monitor0"
    	VendorName   "Monitor Vendor"
    	ModelName    "LCD Panel 1280x800"
    	UseModes     "16:10"
    	HorizSync    30.0 - 60.0
    	VertRefresh  50.0 - 100.0
    	Option	    "dpms"
    EndSection
    
    Section "Device"
    	Identifier  "NVIDIA GeForce 4200 Go"
    	Driver      "nvidia"
    	VendorName  "NVIDIA"
    	BoardName   "NVIDIA GeForce 4200 Go"
    	VideoRam    65536
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "NVIDIA GeForce 4200 Go"
    	Monitor    "Monitor0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     16
    		Modes    "1280x800" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    		Modes    "1280x800" "1024x768" "800x600" "640x480"
    	EndSubSection
    EndSection
    
    Section "DRI"
    	Group        0
    	Mode         0666
    EndSection

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •