Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, Im running Debian (Woody) on a laptop. When i enter ifconfig i only get info on 'lo' and there is no 'eth0' or anything else. I ran dpkg-reconfigure etherconf ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    4

    pcmcia card problem on Debian


    Hi,

    Im running Debian (Woody) on a laptop. When i enter ifconfig i only get info on 'lo' and there is no 'eth0' or anything else.

    I ran dpkg-reconfigure etherconf and it could not detect my pcmcia network card.

    The led for "link" is on, and the "activity" led also flashes when i boot the system. I have networked the laptop to WinXp and there is sent and received packets on the network connection when view from XP box.

    Also when i shut down the laptop i can see this txt "Shutting down PCMCIA services: cardmgr modulescs: cb_free(bus 32) unloading PCMCIA card Services"

    Does any1 know how i detect my pcmcia network card on the laptop?

    Thanks Heapz

    blib

  2. #2
    Just Joined!
    Join Date
    Nov 2004
    Posts
    4
    I FIXED IT!!!!

    My pcmcia card was not recongnized in the /etc/pcmcia/config file, so all i had to do was add it;

    in the form of

    card "SMC EZ CardBus-II 10/100 PC Card"
    manfid 0x01bf, 0x8036
    bind "tulip_cb"

    to the end of the file.

    You can obtain ur card info using the command cardctl ident.

    After you have done this, run dpkg-reconfigure etherconf and it will detect you card.

    Sweet ay

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Posts
    20
    Hey man I got some questions for you on your PCMCIA card issue. I'm running mandrake 10.1 and also having problems getting the card to be detected. I ran the cardctl ident and edited the config file. How do you know what bind to put? I notice you put tulip_cb but that info wasn't in the ident. I think I put the wrong bind when I edited. Also, mandrake doesn't seem to recognize the command 'dpkg-reconfigure ehterconf' Do you know if there is a mandrake equal? I feel like i'm so close to getting this to work but I'm getting stumped by little things. Thanks,

    -Judd

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2005
    Posts
    1
    there's something wrong with the pcmcia-cs package that comes with the mandrake official 10.1 distro.
    I cant use cardctl or cardmgr command at all. So i reinstall the pcmcia-cs rpm package, I got it from the fedora core3 package.
    configure the pcmcia config file(/etc/sysconfig/pcmcia, or something like that) and use yenta_socket instead, reboot and it works

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •