Find the answer to your Linux question:
Results 1 to 3 of 3
I have just installed gentoo 3.0.0 kernel on an ASUS N73SV laptop. Most things are working - X.org, sound, etc. However, I'd like to get the media keys working. I've ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2010
    Posts
    9

    ASUS N73SV and kernel 3.0.0


    I have just installed gentoo 3.0.0 kernel on an ASUS N73SV laptop. Most things are working - X.org, sound, etc.

    However, I'd like to get the media keys working. I've compiled the asus_acpi.ko and asus_laptop.ko, however loading either module fails with:

    FATAL: Error inserting asus_acpi (/lib/modules/3.0.0-gentoo-jes-10/kernel/drivers/platform/x86/asus_acpi.ko): No such device

    or

    FATAL: Error inserting asus_laptop (/lib/modules/3.0.0-gentoo-jes-10/kernel/drivers/platform/x86/asus-laptop.ko): No such device

    I'd sort of like to have the media buttons working, more to the point, I'd like the LED screen backlight to shut off when xscreensaver blanks the screen

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, or in a galaxy far, far away.
    Posts
    11,158
    Well, when you are running over the bleeding edge, you have to anticipate that not every thing works as before... The 3.0 kernel is so new, that a lot of stuff has to be not working. That said, I wish you good luck. I am just about to upgrade to RHEL 6.1 (Scientific Linux) with the 2.6.38 kernel, which will be the most current I have worked with, and even then I am expecting that not everything will function as expected.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Nov 2010
    Posts
    9

    ASUS N73SV and kernel 3.0.0

    I must say that installing the 3.0.0 kernel hasn't shown many problems - I don't know if the media buttons for this particular laptop work with older kernels. As far as getting it running, all I've found so far is:

    The initial emerge rebuild - emerge -vpuD --newuse world died after bash was rebuilt to 4.2. Beyond that, things simply built and worked. Vmware-workstation was a problem, I found a post about using a portage overlay, layman, which deals with some VMware assumptions about later versions of the Linux kernel, including some of the later 2.6 releases.

    I've got most all of my apps running that were running on my previous laptop, without so far hitting any real problems.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •