Running Fedora 17, but it is an Alsa issue. Have reproduced on Ubuntu, Gentoo, openSuse.

Info:
Code:
$uname -a
Linux unqa 3.4.4-3.fc17.x86_64 #1 SMP Tue Jun 26 20:54:56 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

$aplay -l
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

$ head -n 1 /proc/asound/card0/codec*
Codec: IDT 92HD73C1X5
I have two headphone jacks, and one mic jack. All working fine.
But the internal speakers were dead. No sound at all. Tried a lot of models.
dell-m6, auto etc etc.
Finally I gave no-jd a try, without much expectation though:

My /etc/modprobe.d/snd_hda_intel.modules:
Code:
  exec /sbin/modprobe snd_hda_intel model=no-jd enable_msi=1
And it worked!

Alternatively:
/etc/modprobe.d/dist-alsa.conf
Code:
   
options snd-hda-intel model=no-jd  
options snd-hda-intel enable_msi=1
should also work.

One issue naturally comes up since there is no jack detection:
If I plug in a headphone, the laptop speakers dont switch off automatically.
Muting any stream on alsamixer mutes the Master stream.
A peaceful workaround is to go to sound settings (or pavucontrol) and switch the connector manually to "analog headphones" whenever you plug-in a jack, and back to "analog speakers" whenever you plug them out.
Have sound coming from the laptop speakers after many months. But would keep trying other models to see if I get a perfect fit.
Could someone help me please?
--
Thanks.