Find the answer to your Linux question:
Results 1 to 5 of 5
For a week now, I haven't been able to control my laptop's brightness in any way. Pressing Fn + F2/F3 DOES show the brightness gizmo in the screen, but nothing ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2013
    Posts
    3

    Can't control brightness


    For a week now, I haven't been able to control my laptop's brightness in any way. Pressing Fn + F2/F3 DOES show the brightness gizmo in the screen, but nothing happens. Doing so also changes /sys/class/samsung/brightness, but nothing happens.
    I can modify the file manually and nothing happens.
    I can try with setpci -s 00:01.1 FA.B=FF and nothing happens.
    I'm not sure it's a DE issue, I tried in KDE, Gnome, Cinnamon and nothing happened.
    I downgraded linux to a version 2-weeks prior to the day the issue started, and I don't know what's going on.
    The only time brightness gets changed is when I suspend to RAM
    It gets dimmer, but that's it, I cannot change it.
    Something I noticed is that I can only modify /sys/class/samsung/brightness when I am running without X
    I boot up in single user mode and I totally can change the brightness altering said file.
    But then, again, log in normally and it's out of my hands.
    That's a reason to suspect X, but I don't really know
    I've tried booting with and without fglrx, no difference.
    I don't really know what else to do
    I really need help here

    My system is a Samsung NP305V4A, using ArchLinux
    Last edited by NiteiaTt; 02-16-2013 at 08:22 PM.

  2. #2
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,102
    Nice post but you forgot model number of Samsung Netbook/Chromebook/Laptop

    Also, I aint sure. But isn't fglrx and newer kernels kinda iffy?

    Code:
    $ inxi -F -z
    System:    Host: biker Kernel: 3.7.8-antix.1-486-smp i686 (32 bit) 
               Desktop: Fluxbox 1.3.2 Distro: antiX-13-beta1_386-base Ahmad Sami 8 February 2013
    Machine:   System: manda product: Intel powered classmate PC version: Gen 1.5L
               Mobo: N/A model: N/A Bios: American Megatrends version: CM94515A.86A.0024.2008.0715.1716 date: 07/15/2008
    CPU:       Single core Intel Core CPU N270 (-HT-) cache: 512 KB flags: (nx pae sse sse2 sse3 ssse3) 
               Clock Speeds: 1: 1600.00 MHz 2: 1600.00 MHz
    Graphics:  Card: Intel Mobile 945GSE Express Integrated Graphics Controller 
               X.Org: 1.12.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1024x600@53.3hz 
               GLX Renderer: Mesa DRI Intel 945GME x86/MMX/SSE2 GLX Version: 1.4 Mesa 8.0.5
    Audio:     Card: Intel NM10/ICH7 Family High Definition Audio Controller driver: snd_hda_intel 
               Sound: Advanced Linux Sound Architecture ver: k3.7.8-antix.1-486-smp
    Network:   Card: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller driver: r8169 
               IF: eth0 state: down mac: <filter>
    Drives:    HDD Total Size: 63.3GB (0.3% used) 1: id: /dev/sda model: KingSpec_KSD size: 63.3GB 
    Partition: ID: / size: 8.7G used: 1.7G (21%) fs: ext2 ID: /home size: 50G used: 206M (1%) fs: ext2 
    Sensors:   System Temperatures: cpu: 61.0C mobo: N/A 
               Fan Speeds (in rpm): cpu: N/A 
    Info:      Processes: 80 Uptime: 2:59 Memory: 220.1/2015.1MB Client: Shell (bash) inxi: 1.8.34 
    harry@biker:~
    $ apt-cache policy acpi
    acpi:
      Installed: 1.6-1
      Candidate: 1.6-1
      Version table:
     *** 1.6-1 0
            500 http://ftp.us.debian.org/debian/ testing/main i386 Packages
            100 /var/lib/dpkg/status
    on my eeepc's I use the

    Debian -- Details of package eeepc-acpi-scripts in sid

    but not sure how Arch handles this with a Samsung.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  3. #3
    Just Joined!
    Join Date
    Feb 2013
    Posts
    3
    Whoops! I knew I forgot something. It's a Samsung NP305V4A Laptop
    I've been using Arch in my Samsung for quite a while now, and never gave me any trouble.
    I haven't found anything wrong with fglrx
    The last time I updated it was 5 days ago...
    Wait...
    Let me rollback to a previous version

  4. #4
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,102
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  5. #5
    Just Joined!
    Join Date
    Feb 2013
    Posts
    3
    Well, how about that...
    It seems to be fglrx's fault.
    I downgraded the driver from version 13.2-1 to 13.1-1 and I can control brightness again.
    How silly of me not to consider that

    Thanks to all those who showed interest!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •