Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
hi all, after touchpad and usb mouse configuration i get strange bihavior from YaST. here ditales: machine: Compaq presario 1714EA (with standard synaptech touch pad) OS: SuSE 9.2 after fresh ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    8

    Mouse problems?!-touchpad and usb mouse


    hi all,
    after touchpad and usb mouse configuration i get strange bihavior from YaST. here ditales:
    machine: Compaq presario 1714EA (with standard synaptech touch pad)
    OS: SuSE 9.2

    after fresh install of SUSE touch pad is recognized as ps/2 mouse. basic functions work fine but scroll (4way)buton dont work. and it is impossible to configure it through YaST. from SaX2, on the other hand, it gets configured fully - same as it use to under windouws . but as soon as i activate synaptech touchpad my usb mous gets lost. i mean no matter what i do i can't make it work. then i went back to SaX2 and added manually usb mouse and it worked perfectly (both and touchpad and usb - just perfectly).
    but after all this if i go to YaST to look at mouse configuration and click on mouse icon - system logs me of!!!!!
    this is very strange...
    can someone explane me whats goin on?

    thnx

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    no idea. did you try this more than once to help corroborate your theory of a bug.

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Posts
    8
    ooooo yeah.... even after fresh reinstall of suse - same thing happends. and i couldn't get my HP psc 1315 to work (no scaning, printing works just fine) and i could,t sync my tungsten T with Kontact, neither hook up my nokia 6670 to computer.....so...to my graitest regret i have to switch to windows again ....(i'm saying all this to provoke somebody to persway me not to do this "fulish" thing.... kind of hope for it, couse i really don wonna go back to WinXP)

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2005
    Posts
    1

    Suse 9.2 Professional Touchpad\USB mouse issues...

    I have what appears to be the same issue... Alps touchpad works "out of the box". But I cannot seem to get the USB mouse to work. YAST seems to be ineffective at best for affecting this configuration.
    Since I went out and purchased the Professional version for this particular reason I have emailed support about this issue. The only feedback I'm getting was to
    1) Reinstall linux with the USB mouse unplugged and the touchpad turned off, after installation plug in the USB mouse. (Makes me wonder if these guys spent some time doing support in Redmond).
    2) Redirection to the USB project and the Hotplug project.
    Just moments before locating this issue I went into Sax and added a USB mouse then went into YAST and was immedeatly logged off. Almost crash like behavior.
    Another behavior that I have noticed is that occasionally coming into Linux from a Windows session (Dual boot configuration) the usb mouse will work, and Linux will inform me that it has detected new hardware and would I like to configure it? However restarting the session makes the USB mouse vanish again.
    Here are my questions:
    A) What logging options can I enable to create a report so I can see exactly what gets loaded when. With this information perhaps I can find the offending module and reconfig it.
    B) Where are the mouse configurations stored in SuSe 9.2, perhaps I can set the mouse up manually.
    C) It looks like YAST is doing some autoconfig on boot, how can I confirm this and how might I disable it?
    D) Is there some sort of HOWTO or doc on creating a "barebones" boot config that I might add stuff to one thing at a time (or sets of things at a time) and see if I can isolate the offending module that way?

    Oh yea, I am configuring Suse 9.2 on a Presarion R3000 with an Athalon 64 chipset. Using the latest (Jan 10) nVidia driver and an updated Suse Linux Professional 9.2 (Update through YOU)

    Thanks...

  6. #5
    Just Joined!
    Join Date
    Mar 2005
    Location
    Kansas City, Missouri
    Posts
    2

    Same Problem Touch Pad - USB Mouse

    I have a new HP Pavilion, Loaded SuSE 9.2 Professional. Touch Pad Works, USB Mouse doesn't. The LED in the Mouse does not light up at all. I also seem to be having probs with the PCMCIA seeing a DLink NIC as well.

    There has to be some driver probs some where.

    ::tc :P

  7. #6
    Just Joined!
    Join Date
    Mar 2005
    Location
    Kansas City, Missouri
    Posts
    2

    USB Mouse on HP Pavilion

    Bubba Dragon, You like hot Salsa. I like habs myself.

    We seem to be real close with respect to this problem. I have a, just bought it two days ago, HP Pavilion, AMD 64. HP & Compac - same company.

    Me thinks it is definitely relative to drivers. Does the LED in your mouse light up? The USB Mouse, when connected to this ZV5430 Notebook does not light up, so therefore, it can't sense any thing. I can plug in a USB-HD. It automounts no problem. I am still reconning this a bit. Me thinks I will check with some buds I have at Novell. May be they can provide a bit of direction. My fear is definite driver issues. If that is the case, the developers will have to take this one over.

  8. #7
    Just Joined!
    Join Date
    Mar 2005
    Posts
    2

    USB issues on a Dell D800 and IBM Thinkpad T30

    I've had the following experiences with 9.2 on both a Dell D800 and IBM Thinkpad T30.

    It looks like USB ports have simply stopped working. Nothing shows up - CDROM's, pen drives, mice.

    For example on both the 800 & the T30 I connected a pen drive and all was well then after I disconnected it and plugged it back in - it never comes back. Same thing for a USB DVD/CD drive - worked fine then after it was removed and plugged back in - it never worked again.

    As far as a USB mouse goes - its turned into a nightmare. Right after instillation both the touchpad and USB mouse both worked fine but after a while the USB mouse stoped working (mouse is fine!). Its light comes on and during boot the light turns off and never comes back on again.

    Please note - I have a 3rd laptop - another D800 and the USB mouse is very iffy on it too - sometimes it works, sometimes it doesn't! Both Dell's are totally up to date using YOU.

    Whats wrong with USB in 9.2?

  9. #8
    Just Joined!
    Join Date
    Mar 2005
    Posts
    2

    touchpad problems

    this is from /usr/share/doc/xfree86-driver-synaptics/README.

    "Note! You cannot have more that one core pointer, so if you want to use an external mouse too, you have to set all mouse input devices except one to "AlwaysCore" instead of "CorePointer".

    what this means is that you'll have to go into /etc/x11/XF86Config (or similar) and edit the settings. The problems that you are having probably result from one or other mouse being set incorrectly.

  10. #9
    Just Joined!
    Join Date
    Mar 2005
    Posts
    2

    Re: touchpad and USB problems

    Smurky -

    Thanks for the reply and thanks for the info re: the touchpads and an additional mouse -

    I can see the logic in what you say and will try it out and see what happens -

    However - questions on this point - why does it work on some systems for long periods of times (in some systems I've seen - its been fine for years) and then just stop working? And, why does the light go out on the mouse early on during boot well before X ever starts?

    Re: the rest of my posting - something appears to be wrong with USB - why do other USB devices such as pen drives, CD/DVD roms & etc simply stop working and never come back?


    Thanks!

    M-

  11. #10
    Just Joined!
    Join Date
    Apr 2005
    Posts
    2
    I am having the same problem running Suse Pro. 9.0 on a Dell Inspirion 8500.

    I find it strange that when you run YAST it can pick up both. Anybody have a script that allows me to set up the choose mouse screen to run on startup?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •