Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I'm using an assembled LapTop with kernel version 2.4.22, as I shut down the system with init 0, the shutdown process hangs with a message 'no more process left ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Location
    Mumbai, India
    Posts
    4

    Lap top hangs while shutdown ...


    Hi,

    I'm using an assembled LapTop with kernel version 2.4.22, as I shut down the system with init 0, the shutdown process hangs with a message 'no more process left in this run level' and the system refuses to shutdown properly.

    Perhaps ACPI is needed for this.Please suggest me a solution.

    Regards
    Rajesh

  2. #2
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Try adding the option ACPI=force to your /etc/lilo/conf file (if you use lilo), then run the lilo -v command.

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Location
    Mumbai, India
    Posts
    4
    Hi Jeremy,

    But I'm using Grub and not lilo, is there any similar option for grub???

    Regards
    Rajesh

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Same option should work for Grub, but you don't have run the grub -v command (as there isn't one ) What the option does force the OS to use ACPI when X isn't running, i.e. when you're shutting down.

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •