Find the answer to your Linux question:
Results 1 to 5 of 5
I've recently tried to upgrade my laptop to the 2.6.10 kernel. the problem is that every kernel I've built so far, at boot time, turns de screen all black. No ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2004
    Location
    Portugal
    Posts
    93

    Kernel 2.6.10 problem on Asus S5200


    I've recently tried to upgrade my laptop to the 2.6.10 kernel.
    the problem is that every kernel I've built so far, at boot time, turns de screen all black. No text mode.
    I tried dosabling the framebuffer, but it didn't do any good.

    Anyone have a clue what the problem is?

    If any of you have the .config kernel file for kernel 2.6.10 or kernel 2.6.9, could you send it to me?

    Thank You

  2. #2
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    If you press
    Code:
    CTRL-ALT-BKSP
    can you run into text mode?
    can you please post your xorg.conf file
    please remove all #Commented line
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  3. #3
    Just Joined!
    Join Date
    Jan 2004
    Location
    Portugal
    Posts
    93
    that's just it! i can run X, and it works fine, but i can't run in text mode, and when i boot, the screen goes black.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2004
    Location
    Portugal
    Posts
    93
    Still can't use frame buffers in text-mode

    But a new problem as apeared: How to control de clockspeed??
    I have enabled it in the kernel as I compiled it, but now I don't know how to use it...
    HELP!!!

  6. #5
    Linux Engineer
    Join Date
    Nov 2004
    Location
    home
    Posts
    796
    Somewhere I think there's an option like "support for console on virtual terminals". You might want to be sure this is enabled. Grep your config file for CONSOLE before you start looking for it. Honestly, I really don't know if that's a real option or if i just made it up right now I can't think of anything else off the top of my head, but I could probably figure something out tomorrow when I got the time.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •