Find the answer to your Linux question:
Results 1 to 3 of 3
(posted this in Knoppix area, no replies) Toshiba Satellite, Celeron 2Ghz hi, I am trying to sort out some problems with a laptop. Knx version is 3.3. I compiled the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    15

    no sync kernel 2.6.11


    (posted this in Knoppix area, no replies)
    Toshiba Satellite, Celeron 2Ghz

    hi,
    I am trying to sort out some problems with a laptop. Knx version is 3.3.
    I compiled the new kernel as usual, no dpkg stuff.
    make menuconfig; make bzImage && make modules
    && make modules_install; make install. Now, I have it dual booting
    with grub, plus the old kernel added in menu as backup. The old
    kernel (2.4.22-xfs) boots normal, the new kernel hangs with or without an initrd file.
    I have compiled 2.6.xx kernels several times, run lspci -v to make
    sure the hardware, and the grub pointers are the same for each kernel as the root device, filesystem are concerned. Here are the errors;

    with initrd-2.6.11;
    RAMDISK: cramfs filesystem found at block 0
    RAMDISKl Loading 1228KiB [1 disk] into ram disk.. done.
    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(3,2)

    without initrd;
    VFS: Cannot open root device "hda2"
    Please append a correct "root=" boot option
    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(3,2)

    The kernel root= boot option is identical for the old kernel, it loads.
    BTW, 2.6.11 hangs for about 20-30 seconds upon IRQ discovery of IDE1 (hdc).

    I've read threads containing similar problems, but no
    solutions have worked. I need first to know if initrd is
    useful specifically to laptops. I have compiled 2.6.xx kernel on
    Dell laptop which would only work with an initrd, but every PC
    Linux partition I use does without this.
    thanks

  2. #2
    Just Joined!
    Join Date
    Mar 2005
    Location
    US
    Posts
    3
    Check to make sure that cramfs is compiled statically into the kernel and not as a module. Turns out that is what my problem was.

    http://www.linuxforums.org/forum/pos...12.html#183412

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Posts
    15
    I'll need to try that. I've fixed it now by removing ROMfs support, still have initrd support. thanks

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •