Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 17 of 17
Does anyone have Atheros AR5004G card? I am not able to find the ".inf" files from my windows install. It seems that these are necessary for the NDISWrapper client....
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Mar 2005
    Posts
    21

    Does anyone have Atheros AR5004G card? I am not able to find the ".inf" files from my windows install. It seems that these are necessary for the NDISWrapper client.

  2. #12
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    Quote Originally Posted by Liveandletlive
    Does anyone have Atheros AR5004G card? I am not able to find the ".inf" files from my windows install. It seems that these are necessary for the NDISWrapper client.
    Did you not get it from your manufactor?

  3. #13
    Just Joined!
    Join Date
    Mar 2005
    Posts
    6
    thanks for your help, but i just switched to fedora core 3 and everything that should have worked on mandrake, actually DOES work on fedora. i really dont know why though.

  4. #14
    Just Joined!
    Join Date
    Mar 2005
    Location
    Illinois
    Posts
    2

    atheros wireless card problems

    Maybe this will help ....

    Running Slackware 10.1 on IBM Thinkpad with:

    Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)

    DMESG Reports:

    ath_hal: module license 'Proprietary' taints kernel.
    ath_hal: 0.9.12.14 (AR5210, AR5211, AR5212)
    wlan: 0.8.4.4 (EXPERIMENTAL)
    ath_rate_onoe: 1.0
    ath_pci: 0.9.4.11 (EXPERIMENTAL)
    ath0: 11a rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
    ath0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
    ath0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
    ath0: mac 5.6 phy 4.1 5ghz radio 1.7 2ghz radio 2.3
    ath0: 802.11 address: 00:05:4e:48:e0:15
    ath0: Use hw queue 0 for WME_AC_BE traffic
    ath0: Use hw queue 1 for WME_AC_BK traffic
    ath0: Use hw queue 2 for WME_AC_VI traffic
    ath0: Use hw queue 3 for WME_AC_VO traffic
    ath0: Atheros 5212: mem=0xc0210000, irq=11

    The portion of my /etc/rc.d/rc.inet1 file that I modified is as follows with changes marked in bold:

    if grep eth${1}: /proc/net/dev 1> /dev/null ; then # interface exists
    if ! /sbin/ifconfig | grep -w "eth${1}" 1>/dev/null || \
    ! /sbin/ifconfig eth${1} | grep "inet addr" 1> /dev/null ; then # interface not up or not configured
    if [ -x /etc/rc.d/rc.wireless ]; then
    . /etc/rc.d/rc.wireless ath${1} # Initialize any wireless parameters
    fi
    if [ "${USE_DHCP[$1]}" = "yes" ]; then # use DHCP to bring interface up
    if [ ! "${DHCP_HOSTNAME[$1]}" = "" ]; then
    echo "/etc/rc.d/rc.inet1: /sbin/dhcpcd -d -t 10 -h ${DHCP_HOSTNAME[$1]} ath${1}" | $LOGGER
    /sbin/dhcpcd -d -t 10 -h ${DHCP_HOSTNAME[$1]} ath${1}
    else
    echo "/etc/rc.d/rc.inet1: /sbin/dhcpcd -d -t 10 eth${1}" | $LOGGER
    /sbin/dhcpcd -d -t 10 eth${1}
    fi

    The above section runs /etc/rc.d/rc.wireless against ath0. The following is the rc.wireless script.

    #!/bin/sh
    # /etc/rc.d/rc.wireless
    #
    # Wireless network card setup.
    #
    # This script sets up PCI, USB, and 32-bit Cardbus wireless devices
    # NOT 16-bit PCMCIA cards! Those are configured in /etc/pcmcia/.
    # Single parameter to this script is the name of a network interface.
    # Normally this script is called from rc.inet1 rather than run
    # directly.
    #
    # This script is a modified '/etc/pcmcia/wireless' script
    # 09/apr/2004 by Eric Hameleers
    #

    if [ -z $1 ] ; then
    echo "Usage: rc.wireless <interface>"
    return 1 2> /dev/null || exit 1
    fi

    INTERFACE=$1

    LOGGER=${LOGGER:-cat}

    # Find the path where wireless tools are installed
    for IWPATH in /usr/{bin,sbin} /usr/local/{bin,sbin} /sbin ; do
    if [ -x $IWPATH/iwconfig ] ; then break ; fi
    done

    # Set all desired settings via iwconfig
    IWCOMMAND="$IWPATH/iwconfig ${INTERFACE}"
    IFCOMMAND="/sbin/ifconfig ${INTERFACE}"

    is_wireless_device ()
    {
    [ -x $IWPATH/iwconfig ] || return 1
    LC_ALL=C $IWPATH/iwconfig $1 2>&1 | \
    grep -q "no wireless extensions" || return 0
    return 1
    }

    # Is the device wireless? If not, exit this script.
    is_wireless_device ${INTERFACE} || return 0 2> /dev/null || exit 0

    # Bring interface up - to avoid 'not ready' errors when calling iwconfig and
    # for determining the HWADDR
    $IFCOMMAND up
    sleep 2

    # Get the MAC address for the interface
    HWADDR=`/sbin/ifconfig ${INTERFACE} | sed -ne 's/.*\(..:..:..:..:..:..\).*/\1/p'`

    # Read the configuration information for the card with address $HWADDR
    # from /etc/rc.d/rc.wireless.conf:
    . /etc/rc.d/rc.wireless.conf

    [ -n "$VERBOSE" -a -n "$INFO" ] && echo "$0: $1 is '$INFO'"

    # Mode needs to be first : some settings apply only in a specific mode!
    if [ -n "$MODE" ] ; then
    echo "$0: $IWCOMMAND mode $MODE" | $LOGGER
    $IWCOMMAND mode $MODE
    fi
    # This is a bit hackish, but should do the job right...
    if [ ! -n "$NICKNAME" ] ; then
    NICKNAME=`/bin/hostname`
    fi
    if [ -n "$ESSID" -o -n "$MODE" ] ; then
    echo "$0: $IWCOMMAND nick $NICKNAME" | $LOGGER
    $IWCOMMAND nick $NICKNAME
    fi
    # Regular stuff...
    if [ -n "$NWID" ] ; then
    echo "$0: $IWCOMMAND nwid $NWID" | $LOGGER
    $IWCOMMAND nwid $NWID
    fi
    if [ -n "$FREQ" ] ; then
    echo "$0: $IWCOMMAND freq $FREQ" | $LOGGER
    $IWCOMMAND freq $FREQ
    elif [ -n "$CHANNEL" ] ; then
    echo "$0: $IWCOMMAND channel $CHANNEL" | $LOGGER
    $IWCOMMAND channel $CHANNEL
    fi
    if [ -n "$KEY" ] ; then
    echo "$0: $IWCOMMAND key ************" | $LOGGER
    $IWCOMMAND key $KEY
    fi
    if [ -n "$SENS" ] ; then
    echo "$0: $IWCOMMAND sens $SENS" | $LOGGER
    $IWCOMMAND sens $SENS
    fi
    if [ -n "$RATE" ] ; then
    echo "$0: $IWCOMMAND rate $RATE" | $LOGGER
    $IWCOMMAND rate $RATE
    fi
    if [ -n "$RTS" ] ; then
    echo "$0: $IWCOMMAND rts $RTS" | $LOGGER
    $IWCOMMAND rts $RTS
    fi
    if [ -n "$FRAG" ] ; then
    echo "$0: $IWCOMMAND frag $FRAG" | $LOGGER
    $IWCOMMAND frag $FRAG
    fi
    # More specific parameters
    if [ -n "$IWCONFIG" ] ; then
    echo "$0: $IWCOMMAND $IWCONFIG" | $LOGGER
    $IWCOMMAND $IWCONFIG
    fi
    if [ -n "$IWSPY" ] ; then
    echo "$0: $IWCOMMAND $IWSPY" | $LOGGER
    $IWCOMMAND $IWSPY
    fi
    if [ -n "$IWPRIV" ] ; then
    echo "$0: $IWCOMMAND $IWPRIV" | $LOGGER
    $IWCOMMAND $IWPRIV
    fi

    # ESSID need to be last : most devices re-perform the scanning/discovery
    # when this is set, and things like encryption keys had better be
    # defined if we want to discover the right set of APs/nodes.
    # NOTE: when automatic association does not work, but you manage to get
    # an IP address by manually setting the ESSID and then calling dhcpcd,
    # then the cause might be the incorrect definition of your ESSID="bla"
    # parameter in rc.wireless.conf.
    # Debug your wireless problems by running 'iwevent' while the card
    # is being configured.
    if [ -n "$ESSID" ] ; then
    echo "$0: $IWCOMMAND essid $ESSID" | $LOGGER
    $IWCOMMAND essid $ESSID
    fi

    # eof

    This will query your WAP for ESSID, etc and then rc.inet1 will contact the DHCP server for an IP address.

    My ifconfig reports:

    ath0 Link encap:Ethernet HWaddr 00:05:4E:48:E0:15
    inet addr:192.168.1.240 Bcast:192.168.1.255 Mask:255.255.255.0
    UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:501 errors:1547 dropped:0 overruns:0 frame:1547
    TX packets:256 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:199
    RX bytes:50703 (49.5 Kb) TX bytes:65576 (64.0 Kb)
    Interrupt:11 Memory:e0b4a000-e0b5a000


    Hope this is of some use to any of you.

    Tom

  5. #15
    Just Joined!
    Join Date
    May 2005
    Posts
    10
    ok, i am totaly clueless. complete newbie. Running Topologi linux (most recent) using a toshiba satellite with a atheros 802.11 super G (ar5211) and am lost as to how to get it to work. HELP. (in windows typing this btw)

    Thanks

  6. #16
    Just Joined!
    Join Date
    Nov 2004
    Location
    Not-So-Sunny Hawaii
    Posts
    27
    OK, good... i'm not crazy

    i am also having trouble with this card (IBM Atheros A/B/G)... and i think that th Gnome network applet is trying to take it over. When i use the applet, it works (but of cours,e horrible profiles), but it won't scan, and it won't work with any other applet (which sucks... GTKwifi looks awesome).

    so, you say that it works just fine with Fedora? that might be a reason to switch...

  7. #17
    Just Joined!
    Join Date
    Aug 2007
    Posts
    1

    Try This

    I am not a Linux Novice and I struggled for months to get any wireless card to work.

    Solution: Go to Best Buy, ebay, whatever and but the Dynex WLAN card. The Cheapest one and configure that. Compiling MADWIFI works. I runs off the Atheros software. I run OpenSuse 10.1 and Suse Enterprise Desktop and got it to work very easily. The Dynex is the only brand I can say works. Belkin, Netgear, etc did not work for me.

    thanks

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •