Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
Hi, I'm new to Linux Forums, but have tried to search the archives as thoroughly as possible. I was unable to come up with anything on the new Dell Inspiron ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    2

    Linux problems on Dell Inspiron 9300


    Hi, I'm new to Linux Forums, but have tried to search the archives as thoroughly as possible. I was unable to come up with anything on the new Dell Inspiron 9300.

    I've been having a real headache trying to get Fedora 3 installed on it. Originally I tried to dual-boot it with Windows XP, but after that failed, I decided to eliminate some variables and wipe the entire drive clean and start over.

    I followed all the default options for a workstation installation, but after it finishes, the first boot is awfully slow (like 10 minutes) and it seems to stall at a number of places. If I boot to X, it freezes on a gray screen after the graphical startup sequence. If I boot to runlevel 3, I can at least login, and then start the X server, but it runs uncharacteristically slow. And this on the latest laptop out there. Once it finally gets in to the GUI, I have slow response time (1 minute to open a terminal window). When I try to shutdown, I get an error message about the ethernet card scrolling endlessly down the screen until I finally turn it off manually.

    Has anyone else seen anything like this? Any ideas what the problem could be? Is the hardware too new for the last Fedora 3 distro? Are the 915 chipset or the fast RAM or the video card not yet supported? Are there other distros that people have tested and have worked (I don't want a distro war, just something that will work).

    Here's the specs on the laptop:
    Pentium M 760 2Ghz / 533Mhz
    2.0 GM DDR2 533 Mhz RAM
    17" UXGA Widescreen Display w/ Trulife
    256 MB NVIDA GeForce Go 6800
    100 GB Hard Drive
    8x DVD/CD RW
    Internal wired (Intel) and wireless (Dell) networking
    Bluetooth


    Thanks for any help out there.
    ~Evan

  2. #2
    Just Joined!
    Join Date
    Apr 2005
    Location
    Chicago
    Posts
    1
    Hi,

    I installed Fedora Core 3 on an Inspiron 9300 just a couple of days ago. The installation went without any problems. But I have a ATI Radeon X300 video card. X is working just fine (I only had to change the resolution by hand to 19200x1200 in Xorg.conf). Sorry, I don't have good advice for you, but you might want to check that your NVIDIA was recognized correctly. There are also drivers available. Version 71.67 seems to workon SUSE 9.2 at least. See this message:
    http://forums.us.dell.com/supportfor...essage.id=5969 (end of the thread).

    Good luck,
    Jochen

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Posts
    2

    success . . . sort of

    Actually, I was able to get most things working. My biggest problem was fixed by installing the 2.6.10-1.770 kernel RPM. Apparently the FC3 kernel didn't recognize my ethernet card (b44). With that fixed, I was able to download the new drivers for both the ethernet and the wireless (using ndiswrapper).

    i also got the nvidia drivers working, but i can't seem to get higher than 1400x1050, even after manually editing my xorg.conf . . . any ideas?

    have you had any luck getting the media control buttons to work? all i could accomplish was the volume ones, thru the gnome keyboard shortcuts interface.

    any luck with power management? gnome's batter meter doesn't seem to read the battery correctly, and I can't seem to shutdown to RAM (suspend/sleep/hibernate/resurrect/etc) successfully. even after following the instructions here:
    http://tavmjong.free.fr/I9200/FedoraCore3.html

    let me know if you've got any ideas on these issues...

    ~evan

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2005
    Posts
    2
    Hi!

    I've also recently bought a Inspiron 9300 with an ATI X300 ... and am having issues
    with getting the screen up using ATI's fglrx 8.10.19. I assume that someone else has had more
    success (I'm getting a dark screen) ... The drivers seem to recognise the X300 ... so I'm
    guessing it's a modeline problem. Anyone have a working XF86Config-4 (or xorg.conf) file
    handy that works in 1920x1200 with an X300?

    Many thanks,
    Julius.

  6. #5
    Just Joined!
    Join Date
    Apr 2005
    Posts
    2

    Inspiron 9300 : x300

    Julius,

    I don't have my inspiron 9300 yet - I'm getting it this week. However, I'm also interested in getting 3d acceleration to work on the mobility radeon x300.

    (I'm getting a dark screen)
    Check question 4.40 is this Gentoo FAQ. http://odin.prohosting.com/wedge01/g...adeon-faq.html

    It suggests changing "MonitorLayout" from "AUTO, AUTO" to "LVDS, AUTO", which seems to help mobility x300/x600 chipsets.

    Does it resolve your issue?

    Currently, are you using the x.org/xfree86 radeon driver, and are you able to get 32bit color at reasonable resolutions?

    Justin

  7. #6
    Just Joined!
    Join Date
    Apr 2005
    Posts
    2

    i9300 and X300 ATI

    Seems the problem goes away when installing fglrx-8.12.10 . I ended up using 2.6.11.6's radeonfb (whch works really well, if not a little unaccelerated) until I noticed the new drivers on the ATI site, which made everything work for me. I was going to try the LVDS change (it seems that that was one of the changes between 8.10.19 and 8.12.10), but before I had gotten around to it ... new drivers were out. (BTW, I am using XFree86)

    I would also recommend getting the synaptics drivers installed .. the vertical scolling works ... I've not bothered with the horizontal.

    Overall, the i9300 @ 1920x1200 (24 bit depth ..) is a cool laptop!

    - Julius.

  8. #7
    Just Joined!
    Join Date
    Apr 2005
    Posts
    1

    dell inspiron 9300 wuxga nvidia suse 9.2 installation report

    - Installation with suse 9.2:
    no probs, except:
    + graphics: needed to install the newest nvidia driver
    directly from nvidias web site driver before using
    sax2 -m 0=nvidia
    + network: needed to update kernel with suses online update
    (used another pccard network device)

    did not try wlan,bluetooth,audio until now

    fazit:
    nice tool, nice graphics, bright contrasts, nice 3d flight simulator

    hint:
    never bye dell hardware without 3 year complete care !
    My last laptop dell M40 got a new mainboard, display, keyboard and harddisk within the 3 years period. No argueing, no stress: someone visited me wherever I wanted and changed hardware.

  9. #8
    Just Joined!
    Join Date
    Apr 2005
    Posts
    1
    Hi,

    Nothing to do with suse, but you might be interested anyway.

    I've installed ubuntu 5 without any problems at all. Gfx, network, sound, everything worked perfectly. Highest resolution (1900xsomething ), wireless network showed up immediatly.

    Kudos for ubuntu !

  10. #9
    Just Joined!
    Join Date
    Apr 2005
    Posts
    2
    I've installed everything succesfully with Kubuntu. However, I'm now getting random lock-ups during heavy HD activity (after 10-40 minutes of heavy activity). These lockups have no log messages, and they require a complete reboot. I've tried with and without fglrx drivers, and it doesn't seem to help.

    I'm not sure if this is HD related or CPU heat related. The CPU temp goes up to about 45C and the HD about 37C. I'm using ata_piix, kernel 2.6.10 and 2.6.11.

    Has anyone else had this trouble?

    thanks,

    Justin

  11. #10
    Just Joined!
    Join Date
    May 2005
    Posts
    2
    I just ordered mine and wanted to do a dual boot with Ububtu 5.04 and WinXP, but from everything I have been reading in forums it makes me a little worried to do so. Advice would be appreciated if any body have the time to give some.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •