Find the answer to your Linux question:
Results 1 to 3 of 3
hello, i'm a linux newbie, so go light on me i'm using mandrake 10.1 (2.6.8 kernel) on a centrino laptop. i have noticed that the fan runs all the time; ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Location
    Norway
    Posts
    18

    fan running...ACPI problem?


    hello,

    i'm a linux newbie, so go light on me i'm using mandrake 10.1 (2.6.8 kernel) on a centrino laptop. i have noticed that the fan runs all the time; usually just a low whirr, but it speeds up when some cpu-intensive stuff is going on. i have win xp installed (dual boot), which runs with NO fan at all most of the time. i have enabled the cpufreq stuff, and am using the "ondemand" frequency scaling governor. my cpu runs at 600 MHz most of the time (out of a total of 1.4 GHz), so that should not generate heat. overall it seems to be pretty cool, but i have NEVER experienced that the fan is completely off.

    when i go to the /proc/acpi directory there is a fan/ directory, but it's empty (as is the thermal_zone/ directory). i get:

    $ acpi -V
    No support for device type: thermal
    AC Adapter 1: on-line

    is there some fan module or something that is not loaded with ACPI? i have read several threads about fan/ACPI problems, but not found any solutions to my problem. any response greatly appreciated!

    hans joakim.

  2. #2
    Just Joined!
    Join Date
    Apr 2005
    Location
    Norway
    Posts
    18
    oh, by the way; i have noticed that there are some .ko files in the /lib/modules/.../kernel/drivers/acpi/ directory (fan.ko, processor.ko, etc...). i am not sure what to do with them... i've tried insmod'ing them manually, but i still get the same error message when i type:

    $ acpi -V
    No support for device type: thermal
    AC adapter 1: on-line

    if there's some lack in hardware support, what about upgrading ACPI/kernel?

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Location
    Norway
    Posts
    18
    perhaps there's some lack of support for my fan in ACPI? what about switching to APM, would that make things better/worse?

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •