Find the answer to your Linux question:
Results 1 to 6 of 6
I know I know - I seem to be saying something a few other newbies have said as well - they are unable to get their wirless cards to work. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    11

    Wireless Problem Mandrake Powerpack 10.1


    I know I know - I seem to be saying something a few other newbies have said as well - they are unable to get their wirless cards to work. It should be no surprise that I am no different.

    I am very new to Linux - Just got it today and installed it.

    I have a Compaq Presario x1000 dual-boating Win XP Pro & Mandrake Powerpack 10.1. The wireless card is Intel Pro/Wireless LAN 2100 3B Mini PCI Adapter (yes its a Centrino setup).

    Linux detects the card and sees it and has drivers for it and everything - no problem. My problem is in the configuration in Mandrake. I am running WEP on the WAP, and I've put in all the settings I know (for instance the SSID broadcast name and the WEP key - but then there are other text fields (I believe one of them was frequency) and several others that I have no idea what to put in for them. Is anyone able to walk me through my configuration so I can get my wireless to work?
    Thanks!

    ~Anthony

  2. #2
    Just Joined!
    Join Date
    Apr 2005
    Posts
    20
    I don't think you need to modify the other parameters - just make sure the ESSID and the WEP keys match.

    First try out without the WEP.

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Posts
    11

    WEP seems to be the problem

    Hey!

    I got my wireless to work when I turned WEP off - so WEP seems to be the problem. I tried both 64 bit and 128 bit using both jsut the "passphrase" and the full hex number. Nothing seems to work. Any ideas?

    ~Anthony

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    I can't really say what exactly you are doing wrong here,
    since I have no problem at all to use WEP in my configuration.
    You should double check you Access Point configuration, enable WEP and after that try the comman
    Code:
    iwconfig wlan0 enc 0123456789ABCDEF0123456789
    The example above is when you have enabled WEP-128 HEX encoding.
    (Yes you must use exactly 26 HEX characters)
    Change "wlan0" to your interface name.

  6. #5
    Just Joined!
    Join Date
    Apr 2005
    Posts
    11
    I tried your command but it didn't work (I got an error).
    Here's what happened.

    iwconfig eth2 enc 4C5ADC0180 restricted <-- the 4c5adc0180 is my 64 bit hex encryption key

    it came back with an error:
    Error for wireless request "Set Encode" (8B2a) :
    SET failed on device eth2: Operation not supported.

    I then tried the command without the restricted command at the end and I got the exact same error.

    ...What does this mean?

    ~Anthony

  7. #6
    Just Joined!
    Join Date
    Apr 2005
    Posts
    20
    Hope the enc key matches the one you have defined on your accesspoint.

    e.g. if you have defined key 0 on the accesspoint, your iwconfig should be

    Code:
    iwconfig eth2 essid <whatever> enc &#91;1&#93; BEAD5BA5EDF00DF00DFEEDF00D restricted
    ** Note F<zero><zero>D

    you can also use key instead of enc. (man iwconfig)

    I am not sure where Mandrake stores the keys.

    you can try defining the KEY in /etc/sysconfig/network-scripts/ifcfg-eth2

    add these 2 entries

    ESSID=your essid
    KEYn=your 26 hex character key.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •