Find the answer to your Linux question:
Results 1 to 3 of 3
I had an interesting experience configuring audio on this particular machine, which I thought was worth recording somewhere Google could find it in case someone else tripped over the same ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    1

    Interesting experience with audio on IBM ThinkPad R51


    I had an interesting experience configuring audio on this particular machine, which I thought was worth recording somewhere Google could find it in case someone else tripped over the same issue.

    My work laptop died (fragged HD) and I needed to configure a new box in a hurry. I chose an R51 from what we had in stock since I know these flavours of IBM machines iare very well supported, I love the built in 3 button mouse and "eraser" mouse-stick, and a couple of other folks were already running Linux on them - it was the fastest box on the shelf too which didn't hurt

    I quickly cast around the office for install media - I'm an "install and forget" kind of person, and I tend to run one Red Hat distro for 2-3 years at a time or longer, upgrading the kernel and installing the odd lib as needed when I download or install new toys. A trusted colleague introduced me to CentOS, which if you haven't heard of it is the genericized fully-open version of the Red Hat Enterprise dekstop distro.

    CentOS loads and installs beautifully on an R51, and configures all the hardware automagically, including the Intel 2200 "Centrino" 802.11 wireless card. It also picks up the 80201BG aka ICH4 chipset, which is the second generation Intel AC'97 audio. However, it didn't work - no matter how much I tweaked with the ALSA settings and Gnome mixer, not a peep would it make.

    It may seem like a lot of fuss to worry about audio on a work machine (I never got around to installing ALSA on the A30 that was its predecessor) but I tend to carry it on vacation to slake my email thirst, and this way I can justify the extra hand baggage to the other half if she can watch movies on the plane

    Even though I was very certain that the code that came with CentOS 4.0 (Linux 2.6.9, ALSA 1.0.6) should work with the hardware, I tried a few things - (i) picking up a slightly newer kernel RPM using up2date, (ii) building and overlaying the latest ALSA (1.0.9rc2) drivers and utils from source, and (iii) even pulling and building the latest stable 2.6.11 kernel from kernel.org, having read that 2.6.11 includes relevant new hooks for ALSA (control over headphone jack sensing)

    Nada. Nothing. Zllch. Pax aurum est.

    The only thing I managed to get out of it to this point was to confirm the headphone jack worked, by plugging it into receiver and speakers in the livingroom and getting a faint "pop" when pressing the little hardware mute / unmute button located above F5.

    At this point, I was wondering if there was a hardware fault with the machine, I had never booted it under Windows (hate to taint hardware like that to even know if the sound card worked.

    So, I got together with a colleague who had gotten sound on his running without difficulty (he's the hacker type and runs 2.6.10 with Gentoo) and swapped hard drives and booted, using the original CentOS-installed 2.6.9 kernel in the case of his chassis with my drive.

    It turned out there wasn't a hardware problem - wierdly, the sound on BOTH machines worked. As soon as my CentOS install loaded the ASLA driver, there was a high pitched keening of feedback, because my saved config had the mike enabled at full amplification. Helpfully, both continued to work after swapping the HD's back.

    I have no idea what happened, but I can only surmise there was some firmware patch or persistent setting to the AC'97 chipset that was applied by the Gentoo-loaded driver, but I have no idea what it might be.

    There is no audio config in the R51 BIOS, the only thing I did there was to turn off the secondary mouse - in addition to their wonderful eraser, IBM has started supplying a touchpad with two mouse buttons, as found on lesser brands of laptop, and it simply gets in the way if you're using the keyboard.

    I am interested to play further with the 2.6.11 kernel since apparently there are some nice Thinkpad hacks in it, but alas the plugin for the Cisco VPN client we currently use doesn't compile against it, so not viable as a "daily driver" for me - I can report however that everything else works flawlessly including VMware 5.x.

  2. #2
    Just Joined!
    Join Date
    May 2005
    Posts
    1

    Try a commercial driver

    We've had similar problems with sound here. We've never been able to get sound working on the Intel sound cards using the default RH drivers. At one point, we installed outdated SoundBlasters to get around this problem. The Sound blasters worked but only allowed one app at a time to use the sound card. All other audio based app's were locked off.

    If you upgrade your kernel version to the Fedora Core 2 version, you might be able to get audio working. However, the FC2 kernel is nowhere near as stable as the CentOS kernel.

    Eventually we stumbled across a commercial sound driver that works. You can get a trial at http://www.opensound.com/. This driver will allow multiple app's to access the sound card and works like a charm with the Intel sound chip set.

  3. #3
    dh4
    dh4 is offline
    Just Joined!
    Join Date
    Jun 2006
    Posts
    1

    OpenSound driver worked with Thinkpad R51

    I tried the OpenSound driver on my IBM (Lenovo) Thinkpad R51 and it worked great. You should setup the OpenSound driver to load at boot and make sure your apps are pointing to it (i.e. xmms) becuase you will have a choice of drivers to use for some apps.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •