Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 21
weedman, you have agpart compiled in right? Also, take a look at this howto for gentoo and ati...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379

    weedman, you have agpart compiled in right? Also, take a look at this howto for gentoo and ati
    Life is complex, it has a real part and an imaginary part.

  2. #12
    Linux Enthusiast Weedman's Avatar
    Join Date
    May 2005
    Location
    Tasmania, Australia
    Posts
    640
    followed the guide, with no success. i have got agpart compiled in.

    this is really beginning to annoy me. it is nothing but a pain.
    -weed
    "Time has more than one meaning, and is more than one dimension" - /.unknown
    --Registered Linux user #396583--

  3. #13
    Linux Enthusiast Weedman's Avatar
    Join Date
    May 2005
    Location
    Tasmania, Australia
    Posts
    640
    Semi-fixed:

    used vesafb-tng instead of radeonfb. still gives "you have passed an undefined mode number" but once i press enter, it works.

    i am sure somone/something said somewhere that vesafb should not be enabled if i want X to work properly.

    -weed
    "Time has more than one meaning, and is more than one dimension" - /.unknown
    --Registered Linux user #396583--

  4. #14
    Just Joined!
    Join Date
    Dec 2005
    Posts
    20

    My Solution

    Hi, everybody! I run Slackware 10.1 on an Compaq Presario M2105US w/ the ATI Radeon 200M Xpress - and I have direct rendering.

    The frame rates for gears I got are about 54-80 fps in KDE and about 64-80 fps in Fluxbox. This was tested with both 64MB and 128MB of shared ram allocated to video, during different boots, of course.

    How did I get the direct rendering? Well, I first used the ATI propreitary drivers. and just recently after seeing this post thought I'd try to do the other half of the work. Key changes I can think of in xorg.conf are that both "glx" and "dri" modules are loaded, video driver is set to "fglrx", I uncommented the DRI section towards the end of my config file. Slackware and/or the driver installation would have done any other changes I am not completely aware about, if any.

    To check if direct rendering is enabled, type "glxinfo | grep direct" into a terminal (while X is running) and it should tell you yes or no.

    Hope this helps!
    --luke_z3

  5. #15
    Linux Enthusiast Weedman's Avatar
    Join Date
    May 2005
    Location
    Tasmania, Australia
    Posts
    640
    thats odd. i can get 120-130fps easily with the 8.21 prop. drivers and 32mb of shared ram.

    the 8.14 drivers didnt work for me, so i unmasked the 8.21 drivers and i run fluxbox with no probs.

    that is with gentoo though. i dont know about any other distro with this graphics chipset.

    btw, does anybody know if my fps is just enough to play some 3d games (eg ut)?
    thanx
    -weed
    "Time has more than one meaning, and is more than one dimension" - /.unknown
    --Registered Linux user #396583--

  6. #16
    Just Joined!
    Join Date
    Dec 2005
    Posts
    20
    Quote Originally Posted by Weedman
    thats odd. i can get 120-130fps easily with the 8.21 prop. drivers and 32mb of shared ram.

    the 8.14 drivers didnt work for me, so i unmasked the 8.21 drivers and i run fluxbox with no probs.
    Yeah, I thought it was rather strange that the screensaver preview shows 350-400+ fps but had so low of fps when run full screen. I think I might actuallly have an older version of the drivers, so I'll download the newest and see what I get. I'll let you know how that turns out.

  7. #17
    Linux Enthusiast Weedman's Avatar
    Join Date
    May 2005
    Location
    Tasmania, Australia
    Posts
    640
    ill be quite interested at your results luke_z3.
    good luck
    -weed
    "Time has more than one meaning, and is more than one dimension" - /.unknown
    --Registered Linux user #396583--

  8. #18
    Just Joined!
    Join Date
    Dec 2005
    Posts
    20
    Well, as it turns out, I did have the older driver. But even with the new driver, I get practically the same results. Still, it's on my laptop - therefore the performance of a screensaver is not a high priority for me - especially when I spend most of my time using the CLI on it (aafire is a good "screensaver" for that if I really need it). Also, if it's not used, it goes off. For my desktop however...that's where I would show off the screensavers.

  9. #19
    Linux Enthusiast Weedman's Avatar
    Join Date
    May 2005
    Location
    Tasmania, Australia
    Posts
    640
    what a bummer!
    i have as of yet to install screensavers as i have to wait for my download limit to be cleared (hopefully tomorrow).

    -weed
    "Time has more than one meaning, and is more than one dimension" - /.unknown
    --Registered Linux user #396583--

  10. #20
    Just Joined!
    Join Date
    Jun 2005
    Location
    california
    Posts
    3

    Question

    Quote Originally Posted by luke_z3
    Hi, everybody! I run Slackware 10.1 on an Compaq Presario M2105US w/ the ATI Radeon 200M Xpress - and I have direct rendering.

    The frame rates for gears I got are about 54-80 fps in KDE and about 64-80 fps in Fluxbox. This was tested with both 64MB and 128MB of shared ram allocated to video, during different boots, of course.

    How did I get the direct rendering? Well, I first used the ATI propreitary drivers. and just recently after seeing this post thought I'd try to do the other half of the work. Key changes I can think of in xorg.conf are that both "glx" and "dri" modules are loaded, video driver is set to "fglrx", I uncommented the DRI section towards the end of my config file. Slackware and/or the driver installation would have done any other changes I am not completely aware about, if any.

    To check if direct rendering is enabled, type "glxinfo | grep direct" into a terminal (while X is running) and it should tell you yes or no.

    Hope this helps!
    --luke_z3
    I'm still having trouble with my setup. I have a compaq presario v5000 (amd64) using 2.6.15_1831 kernel. I installed the proprietary ATI drivers. Enabled glx and dri modules as well as the dri section. Could you post your xorg.conf? Also, did you have to install other kernel modules? (Btw, I'm using Fedora Core 4).

    thanks!
    theoryno3

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •