Find the answer to your Linux question:
Results 1 to 4 of 4
I am trying to setup my Centrino notebook (Acer TM803) running Fedora Core 2 as a wireless access point for PDA (iPAQ5500) running Familiar v0.8.2. The notebook is connected to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    2

    Centrino ipw2100 as a Wireless Access Point


    I am trying to setup my Centrino notebook (Acer TM803) running Fedora Core 2 as a wireless access point for PDA (iPAQ5500) running Familiar v0.8.2. The notebook is connected to the broadband internet which I want to be able to access from the PDA. This is the final goal, no security is needed at this stage.

    The ipw2100 driver is successfully installed on the notebook and the WiFi is working, WiFi is also working fine on the PDA side (i can connect to a dedicated access point from both). After trying to configure HostAP for a couple of days or to create an Ad-Hoc network between the notebook and PDA I was nearly sure it is impossible. I thought the notebook WiFi card simply does not support the mode I want. However, I managed to do an Ad-Hoc network and access the Internet from the PDA when WindowsXP is running on the notebook!

    With a bit of inspiration I spent another day trying to do the same in Linux. No success. In Linux I cannot do even Ad-Hoc network, not talking about the initial goal - Access Point. The PDA simply does not see the wireless network at all .

    Has anybody solved a similar problem or has an idea what might be wrong?
    I would be grateful for a HOWTO or other useful information on the subject.

  2. #2
    Just Joined!
    Join Date
    Jun 2005
    Posts
    2
    I have not done much investigation into this area, but I have successfuly peered my ipw2100 wifi with other ipw2100 in ad-hoc mode. Also to a cisco aironet 340. This was with linux 2.6.10 kernel, hostap-driver-0.3.3 and ipw2100-1.0.2 - my ipw2100 is built into a dell D600.

    I remember that at least when peering with the cisco device I never got any rate reported with iwconfig on the ipw2100 side - it said Rate=0Mbit/s all the time.

    Never tried AP (master) mode. If I do I'll let you know if I come to any conclusions.

  3. #3
    Just Joined!
    Join Date
    May 2005
    Posts
    2
    The problem is partially solved. I can connect in Ad-Hoc mode now. The next steps are Access Point mode and WPA.

  4. #4
    Just Joined!
    Join Date
    Jun 2005
    Posts
    2
    I just tried AP mode with the ipw2100 and the cisco card, but with no luck.
    First the hostap driver only supports AP mode with prism hardware and intersil firmware as far as I understand.

    Also chances are that ipw2100 firmware doesn't include AP support at all.
    I'm not skilled enough to debug the binary firmware, nor have I got the time to learn. By the time I'd done this laptop would probably have been due for recycling a couple of times :-)

    .. I quick grep into the ipw2100-1.1.0 code shows the driver isn't ready for AP mode as well..

    --- from ieee80211_rx.c ---
    if (ieee->iw_mode == IW_MODE_MASTER) {
    printk(KERN_DEBUG "%s: Master mode not yet suppported.\n",
    ieee->dev->name);
    return 0;
    ---

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •