Find the answer to your Linux question:
Results 1 to 3 of 3
Dear linux gurus, I have a DELL Latitude C400. Ships with a Synaptics touchpad. I'm using Fedora Core kernel version 2.6.11. The drivers for the touchpad are installed too. The ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    Location
    Asia
    Posts
    4

    Touchpad and Modem Woes


    Dear linux gurus,

    I have a DELL Latitude C400. Ships with a Synaptics touchpad. I'm using Fedora Core kernel version 2.6.11. The drivers for the touchpad are installed too. The problem is that the touchpad is too sensitive. I touch the pad and the cursor moves 15 miles on the screen. The drivers include a program that lets the user control these touchpad parameters, but the changes aren't permanent, and the user interface of the program is almost very bad. The program is `synclient'. The man page and the documentation aren't too friendly. So, Help!

    Next woe: Modem drivers. My distro of Linux is called PCQLinux 2005 (servie pack 1). This is an `Indianized' version of Fedora Core. The changes are only in the cosmetics. The kernel and the rest of the core of the OS is Fedora Core (Core 4, I think). This distro, now, doesn't (seem to) ship with the linux source files. And, I have drivers that can compile only with the linux source in place. slmodem-2.9.10 are the modem drivers I have (Smart Link Soft Modem for Linux). The modem I have is PCTEL 2304WT V.92 MDC Modem. Are there drivers that come as a binary file pack and install neatly, without requiring me to compile anything? Or must I install the actual Fedora Core? Help! (again!)

  2. #2
    Just Joined!
    Join Date
    Feb 2005
    Location
    Noplace Interesting
    Posts
    76
    Well, a quick fix if you're using KDE is to go into the control center kcontrol, click peripherials, mouse, and select the advanced tab. (sorry about all the clicking, maybe the keyboard will work.) Adjust the pointer acceleration slide so that your mouse will slow way down and hit apply.

    If you have the kernel headers installed, you may not need to install the full kernel source code. Go in /usr/src/linux/include/linux (if it exists, this is what it is for Knoppix) and look for files that end in .h These are headers. I was able to compile with only headers.
    Note: I could not compile slmodemd on an x86_64 machine -- you must compile it on a 32-bit x86 machine.
    Do you have to use ./slmodemd --alsa <alsa_name> to use your modem? -- if so, please post the output of these commands
    cat /proc/asound/devices
    cat /proc/asound/cards
    lsmod|grep -i modem
    file /dev/ttySL0

    and perhaps, can you also post the alsa name you used when you ran ./slmodemd --alsa <alsa_name>
    This would help me out tremendously, as I have the same modem as you and have not been able to get it working, just because I don't know the alsa name.

    BTW, I'm no guru, don't expect anything too life-changing.

  3. #3
    Just Joined!
    Join Date
    Jun 2005
    Location
    Asia
    Posts
    4
    Well, touchpad problem solved. I had to make a few entries in the /etc/X11/xorg.conf file.

    Modem problem still remains. I was _able_ to compile the drivers. The `make' command mknod`s a few character device files: slamr[0-5]. There seems to be no error then. But when I do:
    slmodemd /dev/slamr0

    the program reports an error:
    unable to lstat /dev/slamr0: No such file or directory

    But when I do: ls -l /dev/slamr0
    I get the listing for /dev/slamr0. What's weird is, when I restart the computer and try the ls command on /dev/slamr0, then there's 'no such file or directory'. Previously I had Red Hat Enterprise Linux 3 (kernel 2.4.11). These same drivers compiled and worked wonderfully on it. But on Fedora Core 3 (kernel 2.6.11), they seem to have trouble getting to work. However, the driver source programs compiled smoothly. BTW, I don't use the -alsa switch. At least, I never used it on RHEL3. Must I use newer drivers, or is there a fix with the version I have (slmodem-2.9.10.tar.gz is the package file name)? Help!

    ------
    ``Portability is for people who cannot write new programs.''
    -Linus Benedict Torvalds

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •