Find the answer to your Linux question:
Results 1 to 4 of 4
Oddly enough, my laptop will just stop. It will stop and stall there and just stay there with the screen on as it was before. This happens with all distros ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Location
    Noplace Interesting
    Posts
    76

    AMD Athlon 64 book keeps stalling


    Oddly enough, my laptop will just stop. It will stop and stall there and just stay there with the screen on as it was before. This happens with all distros I have tried. (even windows stalls) This stalling is erratic and unpredictable.

    The computer will not accept ANYTHING from standard input, but will continue carrying out commands that had started executing before the stall. I noticed that when I tried Debian-like systems, that this was printed on standard output just before the stall.
    APIC error on CPU0

    Is my CPU damaged somewhere, and this is the cause of all the failures?

  2. #2
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    that is an acpi problem so i sugest uninstalling the acpi module or recompiling without it or the part of it that you fitd to be the problem
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  3. #3
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,132
    How about heat issues, has the box been getting pretty hot? This is partially related to the last post. I once had a DellGX150 that would start dragging for ages, then get some response back. Kept getting worse and worse, then I found out the fan on the PSU was gone, internal temperature was hot enough to melt an IDE cable. That's pretty hot.

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    That doesn't look at all like an ACPI (Advanced Configuration and Power management Interface) problem to me. It looks like an APIC (Advanced Programmable Interrupt Controller) problem.

    If the system fails to recognize your APIC, I honestly have no idea what's wrong, except it very much seems as though there would be something wrong with your CPU. As bigtomrodney says, check so that it isn't just a heat issue. If that's not it, I would suggest trying the change the CPU (even though I know Athlon64s are very expensive, but maybe you can get it on warranty?).
    It could be the motherboard as well, though. I doubt it, but it's not impossible.

    Doesn't it say anything except just "APIC error on CPU0"? It should at least output two hexadecimal numbers after that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •