I have an HP dv1170ea laptop.
Specifications: http://h10010.www1.hp.com/wwpc/uk/en...-29574725.html

I've used linux for quite some time now, ubuntu being the distro of choice.
However, I decided to install Debian on my laptop because I messed up the partitioning and had to format the entire disk. Anyway, Ubuntu worked fine before, I just wanted to try something different, and decided Debian was perhaps a logical choice.

Got the newest version of Debian 3.1 on a DVD from a magazine (Linux format).
The install went great, no problems there. I decided to go for a acpi=off install, because acpi is buggy.

'Tis when I boot the problems start. After some time it just freezes at a non responsive prompt.
After a "page up" I read something that could be the prob, though Im not sure...
-------------------------------------------------------------------------------
Unable to handle kernel NULL pointer dereference at virutal address 00000024 printing eip:
de9561d2
*pde = 00000000
Oops: 0000
CPU: 0
EIP: 0010:[<de9561d2>] Not tainted
EFLAGS: 00010246
eax: fffffff ebx: 00000000 ecx: dce26c00 edx: dce26c00
esi: dded5400 edi: 00000000 ebp: c15d6660 esp: dd8c9e34
ds: 0018 es: 0018 ss: 0018
Process modprobe (pid: 389, stackpage=dd8c9000)
Stack: 00000282 00000246 c02c5412 00000246 dce26c00 dded5400 c15d66f8 c15d6660
de959fd7 c15d6660 ffffffff 00000000 00041820 000015d6 c15d6660 00000a04

Blablababalaallala

Code: 8b 43 24 8b 48 08 85 c9 75 27 0f b7 82 16 02 00 00 83 e0 fb
/etc/rcS.d/S36discover: line 204: 389 Segmentation fault modprobe $MODULE
usb-uhci disabled in configuration
Loading ehci-hcd module.
<6>usb.c: registered new driver usbdevfs
usb.c: registered new driver hub

---------------------------------------------------------------------------------
At this point it just stops, the prompt blinking but no further.
Somehow I think the Segmentation fault is key...

Ofcourse I have no idea what it means, and no idea what the problem is... Anybody?
I installed the FC4 from the other side of the dvd (it was a dual sided dvd) and that worked... But not Debian. [/url]