Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 13 of 13
I recently restored an old Latitude LM 133 MHz machine and put Windows 98 on it... After a lot of research and many problems. I just thought I'd put some ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Jan 2007
    Posts
    1

    I recently restored an old Latitude LM 133 MHz machine and put Windows 98 on it... After a lot of research and many problems. I just thought I'd put some info here to hopefully save someone some time.

    First, the bios password. Mine had a password on it and of course, the previous owner didn't remember it. I found a nice little utility called "KillCMOS.exe" which will run in windows (assuming you can make a windows 98 boot disk or something similar.) You can do a google search for "killCMOS.exe" you should be able to find it.

    What it does is change all the CMOS checksums (doesn't change any actual programming or data) so that when you reboot the checksums don't match and it returns the CMOS back to factory settings. Might take 2 reboots. It worked on my LM.

    The next problem you will face is that there IS NO option to boot from CD, even if you get into the bios. What I did is make a windows 98 boot floppy from bootdisk.com. Using fdisk, format, and the sys command, I was able to make the C: drive bootable.

    If you copy the files off the boot floppy, you may have to change the ini files such that any reference to the a: drive you change to c:. With some messing around I was able to boot the hard drive and have cdrom access. This is handy because unless you have a parallel port floppy you can't have the floppy drive and the CD drive in the machine at the same time.

    If you want to put linux on it (I didn't even try) you can usually find a dos executable on the linux distro that you can use to hopefully install. Good luck with that one Oh and btw, only relatively recent linux releases have the X package that supports the NeoMagic video card.

    My choice for an OS was Windows 98. The installation went relatively smoothly, except for one prompt asking where the a: drive went to. After repeatedly trying to tell it it was gone and not coming back, I had to reboot with the cdrom drive still in the bay and it did not ask me again.

    Next problem you might face is the PC Card ports. PC Cards for this machine are not "CardBUS" compatible. If you want to use PC Cards, they have to be the old 16 bit 5 volt kind. No computer store sells them anymore. So a good way to tell if it's not going to work in your LM is to go to any computer store - either online or not and look at their selection of PCMCIA cards. Those are all cardbus and will not work. I saw some on e-bay, and I myself am using a Xircom XE2000 10/100 Ethernet PC Card.

    If you are lucky enough to get your hands on a PC Card 16-bit ethernet card, you may still have issues. I had to go to the advanced tab in the network control panel and change to 10 Mbit and Full Duplex instead of the default options.

    Windows 98 comes with the horribly outdated Internet Exlorer 4.0. IE 4.0 will not render most modern web pages properly, but it is easy enough to get yourself a copy of IE 6.1 which installed just fine.

    The memory is EDO. Mine had two sticks representing a total of 16 MB of ram. Add that to the 8 MB of on-board memory for a whopping 24 MB total of ram. Everything seems to run ok though even so. EDO memory is also not sold anymore and is hard to come by.

    So that's where I'm at, I've got a 9 year old laptop with 24 MB of ram that can browse the internet using a wired ethernet connection... Hope this helps save someone some trouble some day.

    Good luck!

  2. #12
    Linux Newbie easuter's Avatar
    Join Date
    Jan 2006
    Location
    Portugal
    Posts
    194
    I had the same problem that that thread discussed, and fixed it by using the SmartBootManager image provided on the Slackware 11 CD1.
    Since you might not have access to it, I uploaded it to my personal ftp, and you can get it at this link:

    http://clientes.netvisao.pt/alynnsut/sbootmgr.dsk

    Download it to wherever you like.
    Then open a terminal, and move into the directory where you saved the file. Put a fresh floppy into the drive
    Now, type in this command:

    Code:
    cat sbootmgr.dsk > /dev/fd0
    When it finishes, you can reboot and use that floppy to boot from CDROM drives, network, usb, etc... very useful

    HTH

    EDIT:-----
    To use that command, I'm assuming that you are using Linux or a Unix-like system.
    All Empires rise and fall. The Microsoft Empire has already risen, only one way to go now...

  3. #13
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    Wow is this thread old.
    I am moving it to the Laptop section.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  4. $spacer_open
    $spacer_close
Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •