Find the answer to your Linux question:
Results 1 to 7 of 7
I am having great trouble getting my widescreen to work out right. My card is able to have resolutions uptp 1900x1200. However, my laptop monitor is only able to handle ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Location
    Opelika, Alabama
    Posts
    49

    Widescreen woes


    I am having great trouble getting my widescreen to work out right. My card is able to have resolutions uptp 1900x1200. However, my laptop monitor is only able to handle resolutions up to 1280x800. When I try to use the 1280x800 resolution I get a "double vision" effect on the right side of my screen. I need someone to walk me through a fix for this. I am posting my xorg.conf file if that is any help.

    Dell Inspiron 9100
    ATI Radon 9800 pro card

    Here is my xorg.conf
    Code:
    Section "ServerLayout"
    	Identifier     "Default Layout"
    	Screen      0  "Screen0" 0 0
    	InputDevice    "Mouse0" "CorePointer"
    	InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
    # RgbPath is the location of the RGB database.  Note, this is the name of the 
    # file minus the extension (like ".txt" or ".db").  There is normally
    # no need to change the default.
    
    # Multiple FontPath entries are allowed (they are concatenated together)
    # By default, Red Hat 6.0 and later now use a font server independent of
    # the X server to render fonts.
    
    	RgbPath      "/usr/X11R6/lib/X11/rgb"
    	FontPath     "unix/:7100"
    EndSection
    
    Section "Module"
    	Load  "GLcore"
            Load  "bitmap"
    	Load  "dbe"
    	Load  "ddc"
            Load  "dri"
    	Load  "extmod"
    	Load  "glx"
    	Load  "record"
    	Load  "freetype"
    	Load  "type1"
            Load  "vbe"
    EndSection
    
    Section "InputDevice"
    # Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
    #	Option	"Xleds"		"1 2 3"
    
    # To disable the XKEYBOARD extension, uncomment XkbDisable.
    #	Option	"XkbDisable"
    
    # To customise the XKB settings to suit your keyboard, modify the
    # lines below (which are the defaults).  For example, for a non-U.S.
    # keyboard, you will probably want to use:
    #	Option	"XkbModel"	"pc102"
    # If you have a US Microsoft Natural keyboard, you can use:
    #	Option	"XkbModel"	"microsoft"
    #
    # Then to change the language, change the Layout setting.
    # For example, a german layout can be obtained with:
    #	Option	"XkbLayout"	"de"
    # or:
    #	Option	"XkbLayout"	"de"
    #	Option	"XkbVariant"	"nodeadkeys"
    #
    # If you'd like to switch the positions of your capslock and
    # control keys, use:
    #	Option	"XkbOptions"	"ctrl:swapcaps"
    # Or if you just want both to be control, use:
    #	Option	"XkbOptions"	"ctrl:nocaps"
    #
    	Identifier  "Keyboard0"
    	Driver      "keyboard"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "us"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse0"
    	Driver      "mouse"
    	Option	    "Protocol" "IMPS/2"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "ZAxisMapping" "4 5"
    	Option	    "Emulate3Buttons" "yes"
    EndSection
    
    Section "Monitor"
    	Identifier   "Monitor0"
    	VendorName   "Monitor Vendor"
    	ModelName    "Unprobed Monitor"
     ### Uncomment if you don't want to default to DDC:
    	HorizSync    31.5 - 110
    	VertRefresh  28-90
    	Option	    "dpms"
    EndSection
    
    Section "Device"
    	Identifier  "Videocard0"
    	Driver      "radeon"
    	Option      "NoDCC"
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Videocard0"
    	Monitor    "Monitor0"
    	DefaultDepth     24
    	SubSection "Display"
    		Depth     24
    		Modes    "1280x800" # this could be extended
    	EndSubSection
    EndSection
    
    Section "DRI"
    	Group        0
    	Mode         0666
    EndSection
    If anything else is needed, please let me know.

    Thanks again.
    thornaj

  2. #2
    Just Joined! Ekim's Avatar
    Join Date
    Jun 2005
    Location
    51st state, US
    Posts
    60
    what distro you have?

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Location
    Opelika, Alabama
    Posts
    49
    I am using Fedora Core 3.

  4. #4
    Linux Guru
    Join Date
    Nov 2004
    Posts
    6,110
    I will post up my xorg.conf for my Dell i8500 this evening, which has the same 1920x1200 screen.
    It should have details of lower supported resolutions too.

  5. #5
    Just Joined!
    Join Date
    Feb 2005
    Location
    Opelika, Alabama
    Posts
    49
    Thanks. One other quick question. Am I going to have to go into the screen resolution under preferences and manually change it to the resolution I want, or will this be done automatically with the xorg.conf.

    Thanks,
    thornaj

  6. #6
    Linux Guru
    Join Date
    Nov 2004
    Posts
    6,110
    This information is kept in the xorg.conf.

    I will try to post up my xorg.conf tonight (GMT) if I get a chance.

  7. #7
    Just Joined!
    Join Date
    Feb 2005
    Location
    Opelika, Alabama
    Posts
    49
    Here is the deal. Can anyone explain this to me? My xorg.conf file is correct. However, I could not get the resolution to work. I had a wild thought. I logged out of my user account and logged in as root. I went to the screen resolution setting and changed to the resolution that I want to use. I then check the option that said make this defualt for the computer. I logged out of my root account and logged back in as my user. I had to go the the screen resolution and change it to the resolution I wanted. After I had done all of this it finnaly works. I am curious why I had to log in as root to make this work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •