Find the answer to your Linux question:
Results 1 to 6 of 6
as i sad i am a newbie on linux .. my cpu is a pentium M 1.5 and linux shows that the cpu is runing only at 500 Hz .. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2006
    Posts
    3

    CPU low speed


    as i sad i am a newbie on linux .. my cpu is a pentium M 1.5 and linux shows that the cpu is runing only at 500 Hz .. should i be concernet .. please help

  2. #2
    Linux Enthusiast deltaflyer's Avatar
    Join Date
    May 2005
    Posts
    577
    depends if you are running on battery & have processor intensive tasks running, also, check your powersave settings. click on the little battery icon on the taskbar to configure.

    andy
    SLOMO: acer extensa 5235 2.2ghz,2gb ram 160gb hdd wireless
    SPEEDY: homebrew desktop,Amd x2 dualcore,2gb ram,500gb +1tb( 2x500gb) hdd suse 11.3,32mb fibreline
    registered linux user #401845

  3. #3
    Linux Newbie
    Join Date
    Feb 2006
    Location
    KP22
    Posts
    106
    First, what distro do you use and how did you figure out your CPU speed?
    Linux kernel has a nice functionality, CPU frequency scaling. It's possible - when running on battery - that software called cpufreq (or something similar to it) reduces your CPU speed to improve battery time.

    I have also a laptop, and when I plug power cord out, cpufreq reduces my CPU speed from 2,6 GHz to 650 MHz (my CPU is 2.6 GHz P4) and it makes a nice improvement to my battery-running-time (this heavy CPU-thing sucks battery dry before you can say cheese).

    Try to plug power cord in and out and check if it changes CPU frequency on the fly. If not, maybe you should be a "bit" concerned.

    And yes, if it really runs at 500 Hz I would take that thing back to manufacturer..

  4. #4
    Just Joined!
    Join Date
    Feb 2006
    Posts
    3
    i use fedora core 4 distro .. and i don't think it is a hardware problem because before using linux i used win xp and it worked just fine... and i checked .. it runs at 500Mhz when it is plugged in .. can somebody help me?

  5. #5
    Linux Enthusiast Weedman's Avatar
    Join Date
    May 2005
    Location
    Tasmania, Australia
    Posts
    640
    fc4 doesnt have many of the cpufreq modules in the kernel by default.

    if i were you, i would either change distro, recompile the kernel (hard) or search for the cpufreq modules package (i dont know if there is one).

    i had to compile my own kernel + install a few drivers to enable me to change my cpu freq.

    hope this helped, i shared you pain until i changed distro (now running gentoo )
    -weed
    "Time has more than one meaning, and is more than one dimension" - /.unknown
    --Registered Linux user #396583--

  6. #6
    Linux Newbie
    Join Date
    Feb 2006
    Location
    KP22
    Posts
    106
    Yes, trying another distribution would be a good thing to do. If it fails again, maybe your CPU has been damaged.

    Gentoo really is great, and because it compiles itself, I forgot that the kernel might need update.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •