Find the answer to your Linux question:
Results 1 to 4 of 4
I did this once in RedHat years ago but have forgotten how. Even if I remember, the method may not be the same in Slackware and I can't find out ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,628

    Change wireless from eth0 to eth1?


    I did this once in RedHat years ago but have forgotten how. Even if I remember, the method may not be the same in Slackware and I can't find out how after a lot of "googling"

    My laptop's wireless PCMCIA card is at eth0. Since I didn't configure the modem, I guess that is where udev placed it(?)

    When I try to commit /sbin/iwconfig eth0 I get a "Operation not permitted." I'm thinking this might be because the Orinico PCMCIA card is at eth0 instead of eth1.

    How do I change this so my wireless card will be accessed through eth1 instead of eth0? Thanks.
    Last edited by Dapper Dan; 03-23-2006 at 01:16 PM.
    Linux Mint + IceWM Registered:#371367 New Members: click here

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,628
    Follow up:

    Code:
    /sbin/iwconfig eth0 commit
    Error for wireless request "Commit changes" (8B00) :
        SET failed on device eth0 ; Operation not supported.
    Would it matter where my wireless card is? Would I still get this error if it was at eth1? Am I getting this error because I'm running the 2.4 kernel? Would I be able to "commit" my iwconfig settings if I install the 2.6 kernel?

    Any input appreciated.
    Linux Mint + IceWM Registered:#371367 New Members: click here

  3. #3
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    Are you using a WEP key? if so, you may have to set it in restricted mode (some cards seem to like this more than others):

    iwconfig eth0 key restricted <WEP-KEY>
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  4. #4
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,628
    Thanks for the response Flatline. I tried that but I still get the same error. This may have nothing to do with eth0 vs. eth1 so I'm going to try it a different way in the Slackware help forum here. Thanks again.
    Linux Mint + IceWM Registered:#371367 New Members: click here

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •