Find the answer to your Linux question:
Results 1 to 3 of 3
I Installed the latest firefox on my Acer Aspire 1692 dual boot Win XP / SuSE Linux 10.0. The problem is when I move my finger to the left/upper corner ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! spacegypsy's Avatar
    Join Date
    Apr 2006
    Posts
    3

    touchpad problem


    I Installed the latest firefox on my Acer Aspire 1692 dual boot Win XP / SuSE Linux 10.0.
    The problem is when I move my finger to the left/upper corner of the pad the previous page reappears.
    I assure you it's pretty annoying.
    Is it possible to disable this function?
    It's only doing it in Firefox, in all other applications it's working fine.
    Maybe somebody can help me,
    thanx

  2. #2
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Location
    Riverton, UT, USA
    Posts
    1,001
    Good news, that's a Synaptics touchpad, which has a good driver for Xorg with lots of configurable options.
    To turn off the top-left corner "button," open your /etc/X11/xorg.conf, find the InputDevice section for the touchpad (it will have the "synaptics" driver listed), and add this line:
    Code:
         Option     "LTCornerButton"   "0"
    There are plenty of other options you can set to get the touchpad working really nicely. See this page for a sample xorg.conf that another guy used for the same laptop.
    For kicks, here's the InputDevice section that I use with my touchpad:
    Code:
    Section "InputDevice"
     Identifier "Touchpad"
     Driver "synaptics"
     Option "Device" "/dev/psaux"
     Option "Protocol" "auto-dev"
     Option "LeftEdge" "1500"
     Option "RightEdge" "5800"
     Option "TopEdge" "1500"
     Option "BottomEdge" "4500"
     Option "FingerLow" "30"
     Option "FingerHigh" "35"
     Option "MaxTapTime" "0"
     Option "MaxTapMove" "220"
     Option "VertScrollDelta" "100"
     Option "MinSpeed" "0.08"
     Option "MaxSpeed" "0.20"
     Option "AccelFactor" "0.0012"
     Option "SHMConfig" "on"
     Option "Repeater" "/dev/input/mice"
    EndSection
    Setting MaxTapTime to 0 disables the tap-to-click feature, which is probably why I haven't noticed the corner clicking annoyances.
    Stand up and be counted as a Linux user!

  3. #3
    Just Joined! spacegypsy's Avatar
    Join Date
    Apr 2006
    Posts
    3
    Thanx man;
    It's working!!!
    Section "InputDevice"
    Identifier "Mouse[1]"
    Driver "synaptics"
    Option "Device" "/dev/input/mice"
    Option "Emulate3Buttons" "on"
    Option "InputFashion" "Mouse"
    Option "Name" "Synaptics;Touchpad"
    Option "Protocol" "explorerps/2"
    Option "SHMConfig" "on"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    Option "LTCornerButton" "0"
    EndSection
    Feel free to tell me any anomalies or suggestions.
    Thanks again

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •