Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, I'm wondering if you can help me solve this problem i have. When i installed the ubuntu dapper drake on my toshiba satellite L30. The soundcard is a realtek ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2006
    Posts
    2

    there is no sound when i installed ubuntu on my laptop


    Hi,

    I'm wondering if you can help me solve this problem i have. When i installed the ubuntu dapper drake on my toshiba satellite L30.

    The soundcard is a realtek ALC861.

    I am confused there is an ALSA server and an OSS server.

    Can anyone help me figure out how to get the sound card working?

    thank you

  2. #2
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Quote Originally Posted by edalvarez
    The soundcard is a realtek ALC861.
    If I am not mystaking the module for this card should be called "snd_hda_intel".

    Is it loaded ?
    Code:
    lsmod | grep -i snd_hda
    will tell you.

    If it is not, try :
    Code:
    sudo modprobe snd_hda_intel
    And look at the output of
    Code:
    dmesg | tail
    to make sure it loaded correctly.


    If you want further help, please post the output of those commands :
    Code:
    dpkg -l | grep -i $(uname -r)
    and
    Code:
    lspci | grep -i audio
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  3. #3
    Just Joined!
    Join Date
    Sep 2006
    Posts
    2

    no sound, t

    hi,

    thank you for the reply and help...

    sorry this is late, i just got some free time to work on the sound.

    i tried what you said and here are the results of the commands:

    snd_hda_intel 18964 1
    snd_hda_codec 154672 1 snd_hda_intel
    snd_pcm 89864 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
    snd 55268 6 snd_hda_intel,snd_hda_codec,snd_pcm_oss,snd_mixer_ oss,snd_pcm,snd_timer
    snd_page_alloc 10632 2 snd_hda_intel,snd_pcm

    -laptop:~$ dmesg | tail
    [17181209.252000] ACPI: CPU0 (power states: C1[C1] C2[C2] C3[C3])
    [17181209.252000] ACPI: Processor [CPU0] (supports 8 throttling states)
    [17181209.264000] ACPI: Thermal Zone [THRM] (54 C)
    [17181209.320000] ACPI: AC Adapter [ACAD] (on-line)
    [17181209.344000] ACPI: Battery Slot [BAT1] (battery present)
    [17181218.476000] ath0: no IPv6 routers present
    [17181311.588000] ath0: no IPv6 routers present
    [17182253.016000] ADDRCONF(NETDEV_UP): ath0: link is not ready
    [17182255.668000] ADDRCONF(NETDEV_CHANGE): ath0: link becomes ready
    [17182265.776000] ath0: no IPv6 routers present

    when i go to sound preferences, it says that the default soundcard is HDA ATI SB and i have the Enable software sound mixing check box enabled

    when i use the volume control, the title say 0:HDA ATI SB alsamixer but there is also a menu option to change devices and the other one is 1: Realtek ALC861 OSS mixer.

    could this be the problem?
    thanks again

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •