Find the answer to your Linux question:
Results 1 to 2 of 2
I did plug a linksys pcmcia ethernet card to my laptop, did boot linux Mandrake 7.0 -> at linux boot up, I can see "cardmgr" has detected the Linksys Etherfast ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2003
    Posts
    15

    so close to have my pcmcia NIC working...


    I did plug a linksys pcmcia ethernet card to my laptop,
    did boot linux Mandrake 7.0 -> at linux boot up, I can
    see "cardmgr" has detected the Linksys Etherfast network card (with no mention of irq, nor I/O).
    ->/sbin/cardctl status and /sbin/cardctl ident
    both detect the card:
    # /sbin/cardctl
    socket 1:
    5V 16-bit pc card
    function 0: [ready],[wp]
    But does not give m eany I/O and IRQ!!!!
    # /sbin/cardctl ident
    Socket 1:
    Product info: "Linksys", "Etherfast 10/100 Integrated PC Card (PCM100), "Ver 1.0"
    manfid: 0x0149, 0xc1ab
    function: 6 (network)
    Is the MANFID the I/O??? What about the IRQ?
    How come the IRQ and I/O are not displayed?
    Actually, even with "LSPCI -V", I do not get any
    entry "I/O,IRQ" for my network card!
    More details that tells me that I am so close to have
    the pcmcia working ->
    ->when I run "lsmod" , I get:
    pcmcia_core (used by ds i82365)
    i82365 (used by 2) ..that's the module for my nic right?
    ->card services are running cause
    when I run " ps -ef | grep cardmgr ", I get:
    root 746 1 9 19:05 /sbin/cardmgr
    ->In /etc/sysconfig/pcmcia, I have:
    PCMCIA=yes
    PCIC=i82365
    BUT IN /etc/pcmcia/config, there's no exact entry
    for my nic (such as it was outputted by "/sbin/cardctl ident"). Most of them are linksys e-cards, except for
    the following one:
    ->card "Linksys Ethernet"
    version "Linksys", "Combo PCMCIA Ethernet Card (EC2T)"
    bind "pcnet_cs"
    Actually there's an entry that caught my attention
    cause it has same "MANFID" as the "CARDCTL IDENT" outputs on my system:
    ->card "NE2000 Compatible Ethernet"
    version "Ethernet", "Adapter"
    #manfid 0x0149, 0xc1ab
    bind "pcnet_cs"
    (What's the point of /etc/pcmcia/config? What do I need to do here? should I rely on the ne2000 entry or should I absolutely add or rely on the linksys entries. If I should rely on the ne2000 entry, should I take out the # symbol in front of manfid 0x0149, 0xc1ab ?? ??????)

    What do I need to do to complete the setup
    of this NIC card (for now, ifconfig has no entry for eth0)
    Really sorry for all these writings.
    I just need this detected NIC to be set (using ifconfig),
    but am limited by the fact there's no clue of what
    I/O or IRQ goes with it.

    Linux Mandrake 7.0
    Kernel 2.4.8
    nic: linksys pcmcia etherfast 10/100 pc card (pcm100 v2)

  2. #2
    Just Joined!
    Join Date
    Apr 2004
    Posts
    14
    I got my first cardbus (32bit version of PCMCIA) wireless card installed and working last week, so I'm no expert okay, but I'll try to share with you what I've learned so far to the best of my knowledge.

    Just to clarify a few things:
    (1) pcmcia_core (used by ds i82365)
    i82365 (used by 2) ..that's the module for my nic right?

    I don't think so. I think pcmcia core is the controller for your pcmcia interface (i.e. the controller chip that is on the laptop itself, and interacts with whatever is plugged into the pcmcia/cardbus slots)
    i82365 is the module that initializes the pcmcia controller (together with the pcmcia core module) and operates to detect the insertion of 16-bit pcmcia cards, determines the card function and load the appropriate module for this particular card.

    - so it appears that the pcmcia_core and i82365 modules are loaded and running, but they are not correctly detecting the ethernet card and loading its module.

    (2) # /sbin/cardctl ident
    Socket 1:
    Product info: "Linksys", "Etherfast 10/100 Integrated PC Card (PCM100), "Ver 1.0"
    manfid: 0x0149, 0xc1ab
    function: 6 (network)
    Is the MANFID the I/O??? What about the IRQ?

    The manfid is an unambiguous manufacturer's ID code. So it identifies the manufacturer (0x0149) and the "chipset-specific model number" (0xc1ab). So this is not the I/O or IRQ.
    - very occasionally a manufacturer changes chipsets and does NOT change the manfid, which can be pretty hard to figure out !

    (3) /etc/pcmcia/config
    - I believe this file is used by i82365 to determine which module to load for a given manfid
    - it's basically acting as a "cross-reference" list, as near as I can tell, so i82365 can determine which module to load for a given chipset. I think this is used for 16-bit pcmcia cards specifically, and 32-bit (cardbus) cards are configured differently by the "hotplug" module.
    - it is quite possible that your Ethernet card is newer than Mandrake 7.0 (which is quite an old version now) which is why you can't find this unit in /etc/pcmcia/config
    - the syntax for the entries in this file can be found in: man pcmciacard


    In my SuSE 8.1 /etc/pcmcia/config file I find:

    "Linksys EtherFast 10/100 Fast Ethernet"
    version "Linksys", "EtherFast 10/100 Integrated PC Card (PCM100)"
    #manfid 0x0149, 0xc1ab
    bind "pcnet_cs"

    This tells me (if I understand this right) that pcnet_cs is the module to load for this card.

    (4) take notes on what you change as you change it, so you can "back your way out of it", but at this point I would try making the above entry to the end of your /etc/pcmcia/config file and ejecting and re-inserting your card.
    - if I am right (maybe I'm not i82365 will pickup the insertion of a new pcmcia card, scan /etc/pcmcia/config for the module to load for this card, and load pcnet_cs and you'll be off an running !!!
    - try pinging something on your network which you know the I.P.# of
    e.g. ping -c 3 192.168.0.1

    (5) if Mandrake 7.0 has a hardware/netowrk configuration utility, you might want to try that to set this all up instead.

    (6) you may still have to setup /etc/resolv.conf and/or your DSL or cable network setup.


    Hope this has been of some help,
    Rick D.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •