Find the answer to your Linux question:
Page 1 of 9 1 2 3 4 5 ... LastLast
Results 1 to 10 of 83
Just for the record and a little bit of help here and there: I got an HP dv6110us (turion x2) and a dv6105us (turion single core) -- one for me ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2006
    Posts
    10

    linux on hp dv6000 amd laptops


    Just for the record and a little bit of help here and there:

    I got an HP dv6110us (turion x2) and a dv6105us (turion single core) -- one for me and one for the wife.

    I tried installing Ubuntu 6.10, Edgy Etch on both systems.

    Booting:

    It seems that APIC is broken on these models.

    x2: at the least, noapic and nosmp need to be appended as kernel options in order to boot and get most everything to work correctly.

    turion: noapic needs to be appended.

    both: I have added pci=routeirq

    Graphics:

    both: you need the beta NVIDIA driver: 1.0-9625, or possibly better.
    both: you probably need to manually edit the /etc/X11/xorg.conf file for 1280x800 resolution.

    Wireless:

    I tried the bcm43xx driver with the bcm43xx-fwcutter utility. Unfortunately, network speeds were pathetic (on the order of 20kbs, and would lock the wireless device -- this could be related to APIC issues).

    both: ndiswrapper works well enough to be used. I used the Dell wireless drivers for the BCM 4311 wireless device, and things are peachier ... except:

    x2: this is why you need nosmp. Without APIC arbitration, the wireless card can't share an interrupt. You can use the wireless card for a few minutes, before ndiswrapper will throw a panic pertaining to APIC, and the machine will be unstable. You might be able to use SMP if you use the ethernet adapter.

    turion: its not smp, so you don't need this flag.

    ndiswrapper: you'll need to add:
    wireless_mode $MODE
    wireless_essid $ESSID

    to /etc/network/interfaces. Change $MODE and $ESSID to appropriate values for your network.

    Ethernet: works
    ACPI: battery status works, cpu throttling seems to work
    Sound: works. Some application tweaking required if you use ESD(gnome) or ARTSD(kde).

    Modem: untested

    USB: you may get errors pertaining to the ehci_hcd:usb2 on IRQ 7 or so. I've not tried any farther as of yet.

    cd burning: works
    dvd: untested

    synaptics trackpad:

    its really sensitive. If you don't tune it (either in /etc/X11/xorg.conf or via a synaptics utility), it might do strange things!

    Note:

    you'll need to add option "SHMConfig" "on" to the relevant entry in xorg.conf either way.

    General Issues:

    if you "boot too fast", it might lock up trying to assign an IRQ for the IDE and SATA controllers. If you let grub count down from 10, or (maybe) go into the BIOS and allow displaying Setup and Boot Up changes for about 10 seconds, everything is peachy.

    What I'd like resolved?

    I'd like APIC working! I'd also like to boot smp on the x2!

    Hope this helps!

  2. #2
    Linux Newbie
    Join Date
    Oct 2004
    Posts
    114

    Smile

    I read about DSDT bug on nforce chipsets on Turion 64 laptops from Asus and Gateway. There are several 64 bit Linux LiveCD distro with the fix.

    Perhaps you should ask other nforce + AMD Turion 64 Linux users.

  3. #3
    Just Joined!
    Join Date
    Nov 2006
    Posts
    10
    Oh ... I forgot to add:

    this is the 32 bit version of Edgy Etch. Haven't tried 64 bit yet.

    And, you'll need to blacklist the bcm43xx driver so ndiswrapper will load instead.

    Thanks for the suggestion on the dsdt, xxqq. It was on my list of things to check into.

    root@naginata:~# iasl -tc dsdt.dsl

    Intel ACPI Component Architecture
    ASL Optimizing Compiler version 20060608 [Jun 29 2006]
    Copyright (C) 2000 - 2006 Intel Corporation
    Supports ACPI Specification Revision 3.0a

    dsdt.dsl 83: Method (\_WAK, 1, NotSerialized)
    Warning 1079 - ^ Reserved method must return a value (_WAK)

    dsdt.dsl 4992: Method (_EJ0, 0, NotSerialized)
    Warning 1076 - ^ Reserved method has too few arguments (_EJ0 requires 1)

    ASL Input: dsdt.dsl - 6510 lines, 225202 bytes, 3233 keywords
    AML Output: dsdt.aml - 26501 bytes 665 named objects 2568 executable opcodes

    Compilation complete. 0 Errors, 2 Warnings, 0 Remarks, 883 Optimizations


    time to dig some more ....

  4. #4
    Just Joined!
    Join Date
    Nov 2006
    Posts
    10

    no dice on DSDT

    dv6110us, turion x2:

    I fixed the errors (_WAK is sleep wake state, _EJ0 is whether or not a device can be hotswapped) and added a compiled DSDT, but no dice.

    It won't boot without noapic, usually hanging on APIC timing.

    With no flags, it hangs on TSC check.

    If I add notsc to the kernel boot options, it hangs on apic timing. I've tried nohpet, and apicpmtimer as well.

    With noapic, putting the wireless card under load, I eventually get:

    Nov 6 13:50:20 naginata kernel: [17180751.728000] <c01499a4> __report_bad_irq+0x24/0x80 <c0149a9d> note_interrupt+0x9d/0x270

    Nov 6 13:50:20 naginata kernel: [17180751.728000] <f8a72002> ndis_isr+0x52/0xc0 [ndiswrapper] <c0149323> handle_IRQ_event+0x33/0x60

    Nov 6 13:50:20 naginata kernel: [17180751.728000] <c0149448> __do_IRQ+0xf8/0x110 <c0105c89> do_IRQ+0x19/0x30

    Nov 6 13:50:20 naginata kernel: [17180751.728000] <c010408a> common_interrupt+0x1a/0x20

    and wireless is dead. Sometimes, depending on what else is sharing that IRQ, that device goes too. Very bad if its the NVIDIA controller.

  5. #5
    Just Joined!
    Join Date
    Jun 2005
    Posts
    3

    Up for some hand-handing with a newbie?

    This is my first install of Linux, ever. I bought the notebook on a whim, because the price looked good ($549 after rebate) and it was the last day of the sale. I bought my HP dv6105us a few weeks ago, but I haven't been able to install Linux.

    The manager agreed that I could return the PC, because I was told that I could return it for 14 days. However, that isn't the store's po;icy, and I have asked for an extension. I had a deal with the manager that if I couldn't install Linux, I could get a refund, so I am nervous about the time frame, because if he backs out, I am stuck.

    So far I have tried the Kubuntu Dapper Drake 64 bit alternate, the Ubuntu Dapper Drake 64 bit live, and SLED 10. None worked. In one of my posts elsewhere, I saw that an error message said something about a file with APIC in its name, so your post has me hopeful.

    Anyway, I do like how the notebook works under M$, but I agree with the Linux ethic, and don't feel safe using wireless under Windows. I will try a reinstall, and see if I can figure out what to do, though I don't understand your posts.

    Also, it sounds like many items are still not resolved with your installation. How likely is it that they are resolvable? I am wondering if I should just shop around for a used machine being sold by a Linux user.

    Thanks,
    Mary

  6. #6
    Just Joined!
    Join Date
    Nov 2006
    Posts
    10
    Try the Edgy Etch AMD64 alternative installation cdrom. I was able to boot it without any special parameters, which I find very encouraging.

    Hmmm ... maybe tonight, I'll screw around with trying to boot it from the AMD64 alternate CD and using the hdd as root ....

  7. #7
    Just Joined!
    Join Date
    Jun 2005
    Posts
    3

    Finally got Ubuntu Edgy to boot!

    I had about a half dozen partitions on my HD. I tried to install, and the PC would not set up the boot information. I deleted the partition, and reran the install. Ubuntu figured it out somehow, and I could boot from Ubuntu.

    I used the Edgy alt AMD64 CD, as you recommended. I don't have time to do anything else right now, I was going to return the PC, and this was my last try. However, the manager who I had spoken to did not leave info with the manager on duty today, so the PC has a repreive, until tommorow.

    Hope she works out. haven't digested your list of what checks out below.

    Thank you,
    Mary

  8. #8
    Just Joined!
    Join Date
    Jun 2005
    Posts
    3

    Thumbs down I threw in the towel, returned the machine.

    After I got Edgy to boot, I hired a college student off of Craigslist to configure it for me. He had no luck, and I wanted to get the machine back to the store before they decided that I had kept it too long. In hindsight, I would have probably been better off to struggle with it myself, (with help from this forum, of course )

    Well, the holidays are coming up, and the stores are going to be advertising many good deals (along with crummy ones, of course.) I will do some research on laptop compatibility with Linux. And if I don't find a nice shiny laptop to put under the tree for myself, then I am sure that there is someone who will have one too many once the holidays are over.

    BTW, I am so glad for online forums such as this one. I became so frustrated with all my family and freinds, and even this student I hired. Noone understood why it ws so important to me to be able to run Linux (even the guy I was paying ). Finally, I realized that it doesn't matter if I can convince anyone else of the benefits of Linux. I know that it is the right choice for me. I know that I will probably own my machine longer than M$ and other mainstream software will support it.

    Tux rules!

    Mary

  9. #9
    Linux Newbie
    Join Date
    Oct 2004
    Posts
    114

    Smile

    When I shop for new laptops with my friend, I always bring several LiveCDs for testing the Laptop compatibility with Linux.

    Or you can write down the brand and type and ask other Linux users.

    Several old laptops are supported by Linux. Most of the old laptops are sold in clearance sale.

  10. #10
    Just Joined!
    Join Date
    Nov 2006
    Posts
    2

    Smile Only a few problems

    I also bought an HP6105US for 549 dollars.
    I have been using simplyMepis at home for a year and a half.
    It works great on my Athlonxp2000. When I got this laptop home I proceeded to turn it on to see what it did with the included Media Center OS. After ten minutes of filling out forms and still no desktop and not wanting answer even more questions to use something I already owned, I decided that I had enough and threw my Mepis Cd in there and cleared my hard drive of the Redmond product.
    The mepis os is 32 bit only and after a week of playing around with it i had these issues. No wireless, no hardware(special) buttons volume/mute/media/etc. and included nvidia drivers did not work although these open source display was fine.
    So I decided to try 64bit linux.
    My first try FC5 would not install, then Gentoo which worked on the live cd but all the time I tried to install it I got error messages after a few hours.
    Next Ubuntu 6.10 64 normal install. Everything works great except, included wireless drivers and suspend/hibernate. Also occasionally it it does not boot correctly and when I slowed my bios boot settings it has been more reliable.
    From reading other forums my wireless should work with ndiswrapper when I figure out how to do that and I need the latest nvidia drivers(beta) to get 3d acceleration.
    Still it is hard to beat at this price. And I am satisfied.

Page 1 of 9 1 2 3 4 5 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •