Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
Hi y'all I'm new to this forum, not new to linux, but still a bit of a newb. In any case, I just got this Acer Aspire 5100 laptop... here's ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2006
    Posts
    1

    Red face Linux on Acer Aspire 5100


    Hi y'all

    I'm new to this forum, not new to linux, but still a bit of a newb.
    In any case, I just got this Acer Aspire 5100 laptop... here's some of the major specs to save you time:

    AMD Turion 64 x2 1.6GHz (800MHz /core)
    ATI Radeon XPress 1100
    120 GB PATA hdd
    1 GB DDR2 ram

    Anyyyyway, i want, need, an alternative to windows (or vista. ew.) and i figured I might as well fiddaddle with putting linux on this machine. First i tried Fedora (first 64bit, then x86)... the screen went blank after the splash install screen (i hit enter, even tried noapci). Then I tried Gentoo (both x86 and 64bit)- which I was reallly excited about- but that displayed 'kernal panic! aiyeeee!' about 40 seconds into the boot cd load. So far the only thing that's worked is Ubuntu family distros, of which the x86 versions work better than the 64bit versions.

    My internet connection has been crappy for the last couple days (im in college, but they are redoing our system) so I just ordered the SUSE 10,1 64bit cd's (I also need these for another system) and I am hoping to god they work.

    My questions are as this:

    1. Has anyone had experience with loading linux on the Acer Aspire 5100? If so, what was that experience like.

    2. Are there any ati xpress1100 video drivers out there for linux?

    3. What would be my best bet in terms of learning how to maneuver linux from the terminal. I know basics, as well as how to program (proficiently) C, C++, and MatLab, so I'm not completely technically deficient. I just haven't spent enough time learning Linux architecture.


    Any help is appreciated.

    Thankyou!

  2. #2
    Just Joined!
    Join Date
    Nov 2006
    Posts
    1

    I get the same labtop

    Yeah, I get the Acer Aspire 5100.
    From my point of view it doesn't work correctly with the most of linux.
    I tried with my favourite distro: suse 10.1 but it was imposible to work with the alsa system. it didn't detect the sound system. So I decided to install other distro in 64 bits.
    After tried Kbuntu, Fedora 6 and Mandriva 2007. The distro which I feel works better with my labtop is Mandriva. However I'm still waiting to find somebody who know how can alsa works in Suse 10.1 in the Acer Aspire 5100 labtops.

    I'll advice you to try some distros, and please tell me which one works better with your Acer. Because I don't feel so much comfortable using Mandriva.

    Best regards

    Juan

  3. #3
    Just Joined!
    Join Date
    Nov 2006
    Posts
    1
    Hello, i have "successfully" installed Gentoo Linux 2006.1 on aspire 5100, the only things that do not work are the Bluetooth, the camera & some special keys in the keyboard, everything else works ( i have not tried the memory slot ), the sound has some kind of trick but it works too, when i was installing Gentoo i got some problem with a kernel panic but it looks like the amd64's CD of 2006.1 is bad, because i downloaded the DVD version and it worked nice, i did not have to put special options at boot, maybe thou should'st try the DVD version of amd64, another thing...Knoppix works too, i used it to burn the DVD iso of amd64 to a DVD so then install Gentoo amd64.

    For the Ati xpress thou should'st use the Ati-Drivers, and they can be downloaded from the Ati webpage, or "emerge ati-drivers" on Gentoo, that is all, for the sound i recommend the Alsa-Driver package, the driver is "hda-intel" and should be loaded with the options "model=acer position_fix=1", or simply copy & paste the following to /etc/modules.d/alsa :

    alias /dev/mixer snd-mixer-oss
    alias /dev/dsp snd-pcm-oss
    alias /dev/midi snd-seq-oss
    options snd_hda_intel model=acer position_fix=1
    alias snd-card-0 snd-hda-intel
    alias sound-slot-0 snd-hda-intel

    and in Gentoo for using the Alsa-Driver package there must be a line in /etc/make.conf :

    ALSA_CARDS="hda-intel"

    and in the kernel the part:

    <M> Sound card support
    < > Advanced Linux Sound Architecture
    < > Open Sound System (DEPRECATED)

  4. #4
    Just Joined!
    Join Date
    Dec 2006
    Posts
    1
    I just got an Aspire 5100 and have installed Fedora Core 6. The only problem I have is getting the wifi card to work. It is a Broadcom Air Force 54g.

  5. #5
    Just Joined!
    Join Date
    Dec 2006
    Posts
    1

    distros on aspire 5100

    Hi,
    I have a ubuntu dapper (x386) that works just fine (sometimes at boot time or at shutdown time the screen goes wild but never while in use). Mepis worked just fine (x386). Fedora core 6 also (x386).
    Suse 10.1 : huge disappointment. The first time i installed it, it worked about ok except that when the day after I rebooted it, i was not able to get the internet working and i didn't have access to my usb mouse (the touchpad worked ok). I re-installed it and didn't get to the end of the install. I tried a third time. Things are like the first install plus i cannot properly shutdown at least in graphical mode (i didn't try the console). But even during the install session, i wasn't able to do the upgrade there were lots of eror message concerning the dependences.

    for the other distrib I tried like told by aultl the wifi doesn't work.

  6. #6
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,132
    I ran Ubuntu 32bit and 64 bit on a Ferrari, both worked great. The only difficulty was with the broadcom wifi card.

  7. #7
    Just Joined!
    Join Date
    Dec 2006
    Posts
    1

    Kubuntu Edgy 6.10 distribution experiences

    Hi there!
    I have an acer aspire 5100 laptop, same specs running for about a month. I partitioned the disk in two 60 GB partitions, one for windows, the other one for linux. I allowed linux to automatically repartition the second one.

    I've installed both the ubuntu live cd and the kubuntu live dvd 64bit versions.
    The sound card works much better with the kubuntu dvd, however, there is still a little problem whith audio:
    to make it work properly, i always need to move the volume scroller down and then up again in order to make the left speaker work.

    When it boots it remembers the volume levels, however it never works in stereo mode, only one of the speakers working, until you move the scroller.

    The video card works properly, though installing the drivers for the first time is a real pain... For me, the fglrx driver is working better than the ati driver. The wallpaper looks like garbage before installing the driver, but just after doing it, it looks fine.

    When you shut down the machine, green bars with red dots appear, seems a bit scary hehehe, but no complaints about it.

    Sometimes (rarely) the computer hangs, specially when playing audio in amarok. Curiously, after a hang, the only way to restart the computer is pressing the on/off button for a few seconds, and when it comes back, the fsck utility reports errors.


    There is no driver yet (i have seen one still in development??) for the web cam.

    The bluetooth is not working at all, though i haven't made the effort to get it working.

    Wireless lan works fine, however some times it will fail when connecting to the access point. If you try again it will connect most of the times.

    If some one has an update for any of these problems, or knows a better working distribution, i will appreciate it.

  8. #8
    Just Joined!
    Join Date
    Jan 2007
    Location
    Jalisco, Mexico
    Posts
    1
    Hello there!

    I also have an Acer Aspire 5102WMLi with the exact same specs as listed above.

    It currently has Windows XP Media Center Edition (the one bundled) and Fedora Core 6, but it had had several Linux distributions on it. I will try to briefly summarize my experience with them.

    Mandriva 2006: This was my 'current' Linux distribution in my desktop so I installed it in the 'brand new' laptop as well. Soon I found it couldn't recognize my sound card (very new perhaps) so instead of fixing it (I was lazy at that) I installed the latest version of Mandriva available.

    Mandriva Free 2007 64 bits: It ran very well, quite stable overall despite the fact several applications crashed sometimes (GIMP for example). I think 64 bit things are not mature enough (at least in Mandriva).

    Ubuntu 6.10: I had heard so many (and good) comments about Ubuntu that I decided to replace Mandriva. This Ubuntu gave a very good experience: almost everything was recognized and put to work by default (only the proprietary things like the wireless did not work), it was rock-solid and I was very happy with it. The only problems I had were with OpenOffice.org Base (the version 'customized by Ubuntu because the official worked well when I installed it). The security is rather odd for me because I am used to log in as root in the console and become almighty, this Ubuntu did not allow me to do so. However I lost my system because something strange happened and the file system became corrupted (perhaps a bad reboot). I could save all my data though.

    SUSE 10.1 64 bits: I only had SUSE installed for about an hour. The simply fact is that I found all the packages bundled with it outdated (compared to those included in Ubuntu 6.10 or even in Mandriva 2007), the update/repository system rather odd for me, and it never recognized the sound card.

    Fedora Core 6: This is my current Linux distribution. Since I found Fedora Core 5 quite stable in my desktop I decided to give Fedora Core 6 a shot in the laptop. The first time I installed it I ran into problems since the beginning because the CPU Scaling Applet did not work. Then I learned how to compile kernels and fix that. I lost my first installation because of an ext3 corrupted file system (since then I only use reiser). However when I installed it for the second time EVERYTHING worked fine (well, proprietary things did not work but they weren't supposed to). This Fedora is quite stable, up-to-date, and is the fastest to boot. I think I won't change of distribution. The related forum is excellent (www.fedoraforum.org) and there I found how to configure the wireless.

    Regards.
    Joe.

  9. #9
    Just Joined!
    Join Date
    Jan 2007
    Posts
    1

    It works

    I just came upon this thread before I went on installing linux on Acer 5100. this is my experience after I tried personally...


    I have an acer ferrari 4005 that I installed Gentoo 2006.1 (amd64) ... Everything works. After I got this laptop working I installed OpenBSD on my Acer 5100.. I soon found that it's a waste of resources of this laptop (so hence it's not worth the time unless you really like your bsd)... so I switched back to Gentoo.... I got everything working again (suspend was not working at first and took a while to figure out)... now the only thing that doesn't work is the camera.... IMO, Gentoo is your best bet but you have to know how linux works --- off topic here but I have Vista/Gentoo dual boot and this laptop is performing better than my Ferrari under both OS's (minus the low 1280 resolution as compared to 1680 widescreen plasma of ferrari)...

    now you may think that gentoo installation is tough (and it is) but you never learn if you don't try ... believe me it's worth it !!

  10. #10
    Snu
    Snu is offline
    Just Joined!
    Join Date
    Jan 2007
    Posts
    2
    i have 32bit ubuntu 6.1 running on an aspire 5100 (different specs tho: single core 2ghz and 80gb hd).
    the wireless, sound, and graphics were all a pain, but work fine now.
    a couple links that might be helpful for anyone having troubles:
    https://help.ubuntu.com/community/BinaryDriverHowto/ATI
    http://wiki.linuxquestions.org/wiki/...e_one_54g_card
    dont remember what exactly i did for the sound, it was only playing in one speaker... think i recompiled and reinstalled alsa. well, it works now perfectly tho.

    i just wish it had a nvidia gfx card instead, have to use xgl with beryl... no aiglx with ati drivers :\
    i am curious if the opensource drivers work decently on the xpress 1100? i cant seem to find any info on it.
    also, strange note, the ati proprietary drivers detect the card as a xpress 200m. hmm...

    i havnt found any info on the bluetooth yet, tho im not overly motivated to try and get it working (dont have any bluetooth devices), if anyone knows how to get it working, please post.
    same goes for the flash card reader, cant seem to get it working, tho it seems to be detected fine... well, i have a usb drive anyway.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •