Find the answer to your Linux question:
Results 1 to 4 of 4
I just installed Fedora 1.91 on my Dell Inspiron 8600 ( ATI Mobility Radeaon 9600 Pro card, with an WSXGA+ 1680x1050 ). I have been running into all sorts of ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2004
    Posts
    1

    Laptop Monitor Turns Off -- And other exciting problems


    I just installed Fedora 1.91 on my Dell Inspiron 8600 ( ATI Mobility Radeaon 9600 Pro card, with an WSXGA+ 1680x1050 ). I have been running into all sorts of difficulties trying to get it to work though :


    1. Booting into Runlevel 5 seemed to turn off the monitor. I initially suspected it might have just blanked out, but CNTRL+ATL+F1 , CNTRL+ALT+F2 combos did not bring up the console window. So the monitor did turn off.
    During installation I had specified my card type as a Generic VESA and monitor as Dell Laptop Display capable of 1400X.


    2. Since that didnt work, I rebooted using my rescue disk, changed the inittab to boot in Runlevel 3. Upon reboot, starting the SYSLOG caused a whole bunch of AVC Denied { write } messages .


    3. On next boot, I didnt start the Syslog, logged in as Root and got to my command prompt. I get this message though :

    Your default context is root:sysadm_r:sysadm_t.
    Do you want to choose a different one? [n] n

    Is this is warning only to say I should generally avoid using root account ?


    4. I then proceeded to modify the xFree86Config file and in the Monitors section I added "1600x1200" resolution.

    5. Then I switched to runlevel 5 using telinit 5. This did bring up the GUI for me. But right before the GUI came up I saw a whole bunch of AVC denied { write } messages again. I suspect even after the GUI came up the messages were being continously being spewed ( to standard error ? ) . The GUI seemed considerably slow too.

    6. Then when I tried to logout the monitor just turned off again. ~sigh~


    anyone know whats going on ? Sorry for the newbie questions and thanks in advance.

  2. #2
    Just Joined!
    Join Date
    May 2004
    Location
    Denmark
    Posts
    3
    I've got the same monitor-problem running Mandrake 10.0 on a Medion MD 6200 (GeForceFX Go5200 64MB RAM AGP*8, 15" 1024*768@60Hz).

    My monitor turns off once the X-server starts. But my computer does start and run KDE correctly because it was able to display the proper image on a standard 17" CRT VGA monitor.

    I've tried (almost) everything that I could think off, but since I'm new to Linux that isn't much, really.

    Since I haven't got a spare monitor for running Linux help would be much appreciated.

    Thanks.
    Invidia

  3. #3
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817

    Mandrake and XF86

    Sorry for coming in late. I had some real problems with mandrake 9.2 with the GUI on not 1 but three different systems. There are apparently some real problems in the auto configuration routine. I'm pretty sure that you'll get a different XF86Config file depending on whether it's created during install, or with XFree86 --configure or with XF86config. (I'm sure I've got some wrong commands there, but the point is that there are two ways to do it post-install and all three ways get a different answer.) If you haven't solved the problem or given up yet, post your XF86Config file (I think that's the right name!) and I can compare it to mine from two different installs and maybe I can help.

    Cheers-

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    This part is for all of you.....First of all once the monitor switches off try to switch through the differant resolutions slowly by holdhing ctrl + alt and hitting + or - and then if one of the resolutions dosnt come up or you have only selected one resolution then then redo the XF86Config and choose more resolutions so you can then scroll through then to find one that works! Also to kill the X server hold ctrl + alt and hit backspace a few times

    Also if you have installed the Ati-drivers then there is also another XF86Configurator you can use...type
    Code:
     /opt/ati/bin/fglrxconfig


    AnanthR and if you are using the automatic x configurator then that might be the problen i have never had it work ...or rather set up the resolutions so try the manual configurator

    Code:
     /usr/X11R6/bin/xf86config
    or the above 1 with the ati-drivers
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •