Find the answer to your Linux question:
Results 1 to 4 of 4
HP dv9000: Installation hangs on setting date and time I am installing FC6 (or trying too) on my new HP dv 9000. After the initial phase of installation and rebooting ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Posts
    9

    HP dv9000: Installation hangs on setting date and time


    HP dv9000: Installation hangs on setting date and time

    I am installing FC6 (or trying too) on my new HP dv 9000. After the initial phase of installation and rebooting one goes through the Welcome, License Agreement, Firewall, etc. screens. When I click the "Forward" button on the "Date and Time" screen, the install goes off into la la land and hangs up? Anyone seent this? Any ideas on how to correct and get past this to complete the installation?

    Thanks,
    Ed

  2. #2
    Just Joined!
    Join Date
    Feb 2007
    Posts
    1
    I had the same problem when i installed kubuntu and turning acpi=off seemed to fix it. Hope it helps.

  3. #3
    Just Joined!
    Join Date
    Mar 2007
    Posts
    1
    Adding "noapic" to my kernel arguments fixed this problem for me. I did this from the very start, meaning when I booted the installer CD, I typed "linux noapic" instead of just pressing enter. It automatically appended noapic to the grub.conf file when it installed grub... which makes me happy.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jul 2007
    Posts
    1
    On RHEL5 x86_64 (FC6 also probably) the problem is appears to be ehci_hcd. Here is how to work around it without doing drastic things like disabling ACPI (I'm using BIOS F.28 ):

    1. Install from CD, adding "acpi=off noapic" when booting from the CD.
    2. On the first boot from the hard disk, edit the kernel line in grub adding the same options
    3. Add the following to /etc/modprobe.d/blacklist:
    blacklist ehci_hcd

    4. Make a startup script that removes the ehci_hcd kernel module during boot. This needs to be done early in the boot process, like S02. My script:


    #!/bin/bash
    #
    # Do not remove the next 3 lines, they are used by chkconfig
    # chkconfig: 2345 02 02
    # description: Implement boot-time workarounds for the HP dv9000z laptop. \
    # (Unload ehci_hcd due to USB problems.)
    #

    PATH=/sbin:/bin:/usr/sbin
    if [[ ! -z `dmidecode | grep dv9000` ]]
    then
    if [[ ! -z `lsmod | grep ehci` ]]
    then
    echo -n "unloading ehci_hcd kernel module: "
    rmmod ehci_hcd
    fi
    fi


    Now you can reboot WITHOUT the acpi=off and noapic options. Power management works, cpu frequency scaling, etc.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •