Find the answer to your Linux question:
Results 1 to 5 of 5
I recently bought a dv6227cl and am greatly endebted to all the submitters to this forum for your help in getting linux to run on it. First and formost I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2007
    Posts
    3

    Question Clock speed while idle


    I recently bought a dv6227cl and am greatly endebted to all the submitters to
    this forum for your help in getting linux to run on it. First and formost I
    give you a heartfelt thank-you!

    There are still some things that I have not been able to get to work, however.
    One of the main ones is CPU frequency scaling or throttling.

    I am running SimplyMEPIS 6.5.b6_64 and the kernel is reported as
    2.6.15-27-desktop64-smp. My dv6227cl has an AMD Turion64x2.

    The boot parameters:

    root=/dev/sda2 nomce quiet vga=791 resume=/dev/sda3
    noapic pci=assign-busses noirqdebug

    I noticed the "desktop" word in the kernel name. Is that "desktop" as opposed
    to "laptop" or is that "desktop" as opposed to "server"? Anyway, the clock
    speed seems to be locked at one frequency regardless of how idle the processor
    is. When the ambient temperature is about 23 to 25 degrees C, the temperature
    of the notebook (acpi sensor) cycles from 50 to 59 degrees C. It will climb
    for about 60 seconds and then fall for about 90 seconds so that it takes about
    2.5 minutes to complete a cycle. I can't hear the fan, but I suppose it is
    cycling. All of this is with the "KDE System Guard" running, a terminal window
    open, and a Konqueror window open, but with no other activity going on on the
    notebook. The "process table" of "KDE System Guard" shows itself as taking
    about 1.75 "User%" most of the time, and "kded" as taking 0.88 of "User%". And
    "System%" and "Nice" are zero almost all the time. In other words, hardly
    anything going on. The clock frequencies of both CPU's are 1600Mhz. All this
    is with the AC adapter plugged in *or* not! It is the same either on battery
    or AC adapter.

    I tried in KPowersave to set the "CPU Frequency Policy" to "Dynamic" but it is
    still 1600Mhz no matter what.

    The temperature and fan would be tolerable if not for the fact they indicate
    the battery life will be dismal. Only five minutes after unplugging the AC
    adapter (system still just idling), KPowersave indicates a charge of 93% and
    estimates 51 minutes remaining. I have not let the battery run down all the
    way and timed it for a real test, but it's bound to be rather short without
    reducing the clock speed. What I would like, of course, is to have the CPU run
    fast when I am really using all those cycles for something, and have the clock
    slow when the processor is mearly idling.

    Is this what other dv6000 series laptop owners are seeing, or is there a way to
    throttle back the clock speed when the system is idle?

  2. #2
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Location
    Riverton, UT, USA
    Posts
    1,001
    Check that you have the libcpufreq0 and cpufrequtils packages installed, plus a scaling daemon (powernowd is a good one). Without those, frequency scaling won't work.
    Stand up and be counted as a Linux user!

  3. #3
    Just Joined!
    Join Date
    Mar 2007
    Posts
    3

    Clock still fast while idle

    Quote Originally Posted by Zelmo
    Check that you have the libcpufreq0 and cpufrequtils packages installed, plus a scaling daemon (powernowd is a good one). Without those, frequency scaling won't work.
    Thank you, Zelmo, for your reply. It helped alittle. I found that I had
    libcpufreq0 installed, but did not have cpufrequtils installed. I did install
    cpufrequtils. I found I did not have "powernowd" but I do have "powersaved".

    After installing the cpufrequtils package, I right-clicked on the KPowersave
    icon (it is on the KDE panel and looks like a plug when AC adapter is plugged
    in, or a battery unplugged) and changed the "CPU Frequency Policy" from
    "Performance" to "Dynamic". By left-clicking on the KPowersave icon, I bring
    up the "KPowersave Information Dialog" which shows the "Powersave Daemon:
    running" and the frequencies of the two processors still at 1600Mhz. After
    rebooting, the CPU policy has changed back to "Performance". I unplug the AC
    and the policy changes to "Dynamic", but the processor speeds do not change.
    They have always been 1600Mhz. I leave the machine alone until the screen goes
    blank (2 minutes) and when I check it again, the speeds are 1600. It says the
    "Powersave Daemon" is "running".

    Also KDE System Guard shows speeds have been 1600 all along. The temperature has
    been cycling from 50 to 60 degrees C with about a 2 minute period. CPU
    usr/sys/nice loads all combined have been somewhere below 10%.

    Evidently, it's still chewing up energy at a high rate. Is there anything else
    I can test or investigate?

  4. #4
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    To enable CPU frequency management, you will need to get the proper modules loaded at startup. Nowadays you don't need anymore a CPU scaling daemon, as this functionality is included directly into the Linux Kernel.

    I wrote a tutorial not long ago that sums it up nicely for Debian-based distro (like Mepis or Ubuntu). I suggest you take a look at it :
    http://technowizah.com/2007/01/debia...anagement.html

    If you have further questions after reading it, just post back.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  5. #5
    Just Joined!
    Join Date
    Mar 2007
    Posts
    3

    ondemand always chooses 1600Mhz

    Thank you, antidrugue, for your reply, and for writing that tutorial. I read
    the tutorial. As I said before, I am running SimplyMEPIS 64 on an AMD
    Turion64x2. It is a "Mobile Technology TL-50". You said a CPU scaling daemon
    is not necessary, and that may be, but for some reason the "KPowersave
    Information Dialog" in MEPIS reports explicitly "Powersave Daemon: running".

    After using KPowersave to set the CPU Frequency Policy to "Dynamic", I issued
    the command "cpufreq-info" you mentioned in the tutorial. I got this:

    cpufrequtils 0.4: cpufreq-info (C) Dominik Brodowski 2004
    Report errors and bugs to linux@brodo.de, please.
    analyzing CPU 0:
    driver: powernow-k8
    CPUs which need to switch frequency at the same time: 0 1
    hardware limits: 800 MHz - 1.60 GHz
    available frequency steps: 1.60 GHz, 800 MHz
    available cpufreq governors: userspace, powersave, ondemand, performance
    current policy: frequency should be within 800 MHz and 1.60 GHz.
    The governor "ondemand" may decide which speed to use
    within this range.
    current CPU frequency is 1.60 GHz.
    analyzing CPU 1:
    driver: powernow-k8
    CPUs which need to switch frequency at the same time: 0 1
    hardware limits: 800 MHz - 1.60 GHz
    available frequency steps: 1.60 GHz, 800 MHz
    available cpufreq governors: userspace, powersave, ondemand, performance
    current policy: frequency should be within 800 MHz and 1.60 GHz.
    The governor "ondemand" may decide which speed to use
    within this range.
    current CPU frequency is 1.60 GHz.

    I also used lsmod to verify that the driver and policy governer modules are
    loaded.

    It looks like the tutorial says it should and it is consistent with everything
    KDE System Guard and KPowersave says, but evidently "ondemand" is deciding
    to leave the frequency at it's maximum no matter what. Granted, the frequency
    steps are limited to two. But really, it's 1600Mhz and the temperature cycles
    from 50 to 60 degrees C with KDE System Guard being the only open window.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •