Find the answer to your Linux question:
Results 1 to 6 of 6
Recently bought HP Pavilion dv9208nr. Have deleted M$ Windows Vista and installed SuSE 10.1 (32-bit), and after much fussing around finally got the mini-PCI wireless card working. However, the sound ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    3

    Question I have sound but no volume control ???


    Recently bought HP Pavilion dv9208nr. Have deleted M$ Windows Vista and installed SuSE 10.1 (32-bit), and after much fussing around finally got the mini-PCI wireless card working.

    However, the sound card was detected and configured during installation ... and I have sound ... LOTS of SOUND ... with absolutely no volume control ... cannot even mute it.

    lspci -v yields:
    00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
    Subsystem: Hewlett-Packard Company Unknown device 30b7
    Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 225
    Memory at b0000000 (32-bit, non-prefetchable) [size=16K]
    Capabilities: [44] Power Management version 2
    Capabilities: [50] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
    Capabilities: [6c] HyperTransport: MSI Mapping

    lsmod | grep snd yields:
    snd_mixer_oss 20224 1 snd_pcm_oss
    snd_seq 53104 0
    snd_seq_device 11916 1 snd_seq
    snd_hda_intel 21652 2
    snd_hda_codec 139136 1 snd_hda_intel
    snd_pcm 86532 3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
    snd_timer 25860 2 snd_seq,snd_pcm
    snd 56708 12 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,s nd_hda_intel,snd_hda_codec,snd_pcm,snd_timer
    soundcore 13024 1 snd
    snd_page_alloc 13576 2 snd_hda_intel,snd_pcmbilities: [6c] HyperTransport: MSI Mapping

    I see "intel" in there in several spots ... though this laptop has the AMD Turion 64 X2 and "nVidia" everything else (or so lspci seems to indicate).

    Have admit I am at a loss even as to where to begin ... tried changing from ALSA to OSS, etc. with absolutely no effect.

    Suggestions?

  2. #2
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Location
    Riverton, UT, USA
    Posts
    1,001
    Does alsamixer (or alsamixergui) give you any controls?
    What desktop environment or window manager are you using?
    Stand up and be counted as a Linux user!

  3. #3
    Just Joined!
    Join Date
    Oct 2006
    Posts
    3
    Quote Originally Posted by Zelmo
    Does alsamixer (or alsamixergui) give you any controls?
    What desktop environment or window manager are you using?
    Zelmo,
    I am running GNOME 2.12.2 at this point ... have almost always used KDE before. If I startup "alsamixer" it only gives me the same two controls that right clicking the speaker icon and choosing "Open volume control" does: "PCM" and "Capture" -- neither of which actual seems to control anything.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2006
    Posts
    3
    bump

    Anyone else have any thoughts on this one?

    TIA,
    Dennis

  6. #5
    Just Joined! savvy_cowgirl's Avatar
    Join Date
    Mar 2007
    Posts
    52
    Well, I'm really new at linux, so take this for what it is worth. I have a HP Pav dv6226us and am running suse10.1 also. I understand that if you have the same sound bits I do, that there is a problem with suse 10.1 and the sound card. On another forum I read about a fellow who had a HP lappy similiar to ours and when he installed suse 10.2 that fixed the lack of ability to control the volume and all his special buttons above the keyboard worked too.
    so, I am thinking of trying to put suse 10.2 on. I don't know if this helps you or not, but I understand a bug report has been filed with suse on this card....

  7. #6
    Just Joined!
    Join Date
    Jan 2006
    Location
    India
    Posts
    52
    Try out the command "aumix" in command line.

    If you are using GNOME Desktop Manager ----- use "gmix"
    And if you are using KDE Desktop Manager ----- use "kmix"


    Regards
    rajesh

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •