Find the answer to your Linux question:
Results 1 to 7 of 7
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Hardware RAID confusion

    I have been getting ready to set up a new server running Fedora 8 but have been having a little confusing problems when installing Fedora about the RAID hard drives.

    In the computer there will be six hard drives, 2 x 320 GB in a mirror RAID, and 4 x 500 GB in RAID 10. The four drives in RAID 10 are connected to a Highpoint RocketRAID card and hardware configured already to be in RAID 10. The two mirrored drives are connected to the integrated SATA RAID controller and already configured to be in a RAID 1.

    The problem comes when I begin installation of Fedora 8. When going in to the advanced options for partitions. In the list of available disk drives and available space, it shows all the hard drives as if there was no RAID configured at all. Since I have hardware RAID configured, I don't want to use the software RAID setup in the partition screen of the Fedora 8 installation, but I also want to be sure that the drives really are in their correct RAID and not just being used in Linux as non-RAID independent drives.

    Is there something I'm doing wrong, or simply looking at this too complicated and everything should be correct?

    I can try and give more information if it is needed, I have just been quite confused by this. Thank you all for your time and help!

  2. #2
    It sounds like the onboard and add-in card are not real "hardware" RAID controllers. Their RAID functionality is part of the software driver. It's also likely that that special "RAID" driver is only available for Windows. When you load up Fedora, it's using a standard SATA driver (that works with the SATA chip), and the chipset is in turn showing Fedora all of the attached disks.

    You may want to do more research, but unless the "RAID" driver is released for Linux as well, you will end up using the MD driver in Linux - which will probably be the same/faster than the Windows software "RAID driver" anyway.

    Real hardware RAID controllers are not cheap, and only thru the software driver do you see these "RAID" solutions on cheaper, home-level motherboards and add-in cards.

    An example of a real *hardware* SAS/SATA RAID controller.

  3. #3
    This should still be considered a hardware raid controller card, the Highpoint RocketRAID card cost more than your example from newegg and has its own firmware configuration and everything before the BIOS information and they said was independent of any certain OS.

    After installing Linux a few times already, it still shows in the RAID BIOS configuration screen (outside of Linux still) that the drives are functioning properly in RAID 1/0. I was just confused if it really is seeing this RAID configuration in Linux since during installation it lists all of the hard drives as available drives.

  4. $spacer_open
  5. #4
    You may want to do more research, but unless the "RAID" driver is released for Linux as well, you will end up using the MD driver in Linux...
    1) You still haven't said which HP you are using and so anyone reading still has to guess.
    2) You originally included that your onboard SATA was a RAID controller like your add-in card. This tells me you are not familiar with a "true" hardware RAID and software RAID chips. You may want to do some more reading on the topic.
    3) Are you using the HP driver or a generic SATA driver?
    Some HP Driver Link
    4) If you install and manipulate each drive independently (like every "RAID" drive is listed as sdc, sdd, sde, etc.) then these drives are not in a RAID set being managed by the controller - and this could be due to the SATA driver being loaded. If 4 drives are combined into one RAID set, then (with the correct driver), the OS should see this as one drive.

    From one of the HP RR Manuals about installing Fedora:

    2) At the “Welcome to Fedora Linux” installation screen, a prompt labeled
    “boot:” will appear at the bottom of the screen. Type in “linux dd” and then
    press Enter.
    3) When prompted “Do you have a driver disk?”, select “Yes”. At the “Insert
    your driver disk and press OK to continue. ” prompt, insert the driver
    diskette and then select “OK”.
    4) The system will now load the RocketRAID driver automatically.
    My suggestion would be to:

    A) Unplug the RAID card.
    B) Install Linux to the 320G drives using the MD driver for mirroring, etc.
    C) Once OS is installed, plug in the HP card.
    D) Download and install the HP driver for your card.
    E) Configure the volumes you want on the RAID set. Hopefully the OS will see it as one big drive.

  6. #5
    My apologies, I forgot to include the type of RocketRAID - that could lead to quite some confusion! It is a Highpoint RocketRAID 2310. I went to their website, tried to download Fedora drivers for that card and follow their instructions for making a driver diskette for loading before installing Fedora. However, following their instructions did not work, as the image file for the disk included would not copy to any of the three floppy disks we tried, as when we attempted to load from the disk we got the error, "This software is not intended for this version of Fedora." We attempted with just about every driver disk image available, every Fedora version, Red Hat, everything, and had no luck.

    Finally, I reinstalled as you said, unplugging the HP card and installing on only the mirrored 320 GB drives. I noted that when I unplugged the HP card, I had these two hard drives still connected directly to the motherboard so they would be set up with the nVidia RAID on the motherboard itself. When I did this, the installation recognized only one disk, and it named it as an nVidia Drive (in connection with the nVidia Professional RAID chipset that the drives are mirrored by.) In this way, only one 320 GB space was shown meaning the RAID seemed to be working.

    I reinstalled Fedora in this way, and then reconnected the HP card. I tried to follow the directions directly from highpoint-tech again for installing the card but the drivers simply would not work, and the RAID Manangement tools would not run because it was missing required files.

    After several hours of working through this, I finally disconnected the HP card and connected ALL six drives to the motherboard. I then went in to the motherboard's nVidia RAID Bios tool and configured the two 320 GB drives to run in Mirrored still, and the four 500 GB drives I set in a new RAID 0+1. This appeared in all means to work just fine and still accomplish the same tasks.

    However, when I then went to install Fedora once again, in the available drives I had the following list:

    nVidia RAID drive 320GB (it appears that the two 320 GB drives are still showing in Fedora as correctly in RAID and only allows writing to one drive.)

    hdg1 (thus it appears Fedora won't recognize the four 500 GB drives corretly in RAID 0+1 also set up in nVidia RAID Bios.)

    It looks like for now the most hassle-free thing to do is try to just bypass using the RocketRAID card as it has iffy support on Fedora for how I can set it up at least. However, I'm still having some confusing problems with the nVidia MCP55 Pro RAID controller on the motherboard.

    The computer is a SUPERMICRO, 4021M-T2R+

  7. #6
    I also tried installing a Rocet"RAID" controller on Fedora 8.
    I was using the 2320 (I believe).
    It has drivers compiled up to fedora 7 (which is not Fedora 8 )--so I went ahead and compiled the drivers for it, created a driver disk for the fedora 8 installation, typed "linux dd" at the prompt, saw the drivers, installed them, started Fedora 8 installation!!....
    Then an insane beeping noise happened close to the end of the installation process!
    I don't know if you've ever heard one of these alarms before or not, but I could almost compare it to an air horn going off about every second.

    Anyway, this was the "RAID" controller beeping. The manual said that it goes off when there is a disk failure. Well, I paid $170 for a "pro" to look at it and they said that it was a driver issue and that it is a common problem.

    I say "pro" because the company I bought the card from told me that it was a true Hardware RAID controller--but it apparently is not. This pro is Fry's Electronics in Austin, TX.
    Later they told me that they don't even carry HW Controllers...
    ANYWAY. The point is, there are a lot of us feeling your woes.

    I'm currently trying to find a good solution in which a good HW RAID controller capable of RAID 5 and supports Fedora 8+.

    Did the website have Fedora 8 drivers for your card? If not then you will HAVE to compile them yourself and make a driver disk and do the procedure mentioned above.

    Question: If I have a true HW RAID controller, do I even need drivers or does the card totally show itself to the OS as a physical hard drive that the OS can just use happily?

  8. #7
    The RocketRAID controller I got did have listed support drivers on their website for Fedora 8, but when you go to make the image disk from the drivers given, it would not work. Nothing would copy correctly. Even if SOME files copy to the driver diskette correctly, it does not copy correctly or something, as when you start up the installation, put in the driver diskette, and try to load from the disk you get the error "This file was not intended for this version of Fedora" even after trying ever version available on the Fedora options.

    In the end, I didn't have the time to continue trying to fix this problem and completely bypassed the rocketRAID card, running the hard drives off the direct motherboard SATA ports and using the software RAID setup in Fedora 8. This way ended up working fine for me I suppose, though technically not as fast or as reliable as could be.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts