Find the answer to your Linux question:
Results 1 to 3 of 3

Thread: No sound, help?

Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    No sound, help?


    I'm running FC2. I've been running it for about a year, but recently my boot harddrive died and I had to reinstall.

    This time, it didn't detect my soundcard. Since the soundcard is a little silver box tacked to the motherboard, I know it didn't come loose.

    If I run
    $alsamixer, it returns "alsamixer: function snd_ctl_open failed for default: No such device"
    $/sbin/lsmod returns
    Module Size Used by
    snd_pcm_oss 40740 0
    snd_pcm 68872 1 snd_pcm_oss
    snd_page_alloc 7940 1 snd_pcm
    snd_timer 17156 1 snd_pcm
    snd_mixer_oss 13824 1 snd_pcm_oss
    snd 38372 4 snd_pcm_oss,snd_pcm,snd_timer,snd_mixer_oss
    soundcore 6112 1 snd
    parport_pc 19392 1
    lp 8236 0
    parport 29640 2 parport_pc,lp
    autofs4 10624 0
    sunrpc 101064 1
    8139too 17792 0
    mii 3584 1 8139too
    ipt_REJECT 4736 1
    ipt_state 1536 4
    ip_conntrack 24968 1 ipt_state
    iptable_filter 2048 1
    ip_tables 13440 3 ipt_REJECT,ipt_state,iptable_filter
    floppy 47440 0
    sg 27552 0
    scsi_mod 91344 1 sg
    microcode 4768 0
    binfmt_misc 7176 1
    dm_mod 33184 0
    button 4504 0
    battery 6924 0
    asus_acpi 8472 0
    ac 3340 0
    i830 55856 2
    ipv6 184288 8

    I have alsa-drivers , libs, and utils installed, and have run ./snddevices in the alsa-drivers directory. It created /dev/snd, I checked.

    Right now, I don't even know what's specifically wrong-- let alone how to fix it. Any insight would be very, very, very appreciated.

    ETA: sound detection sees the card: says the module it's using is snd-Intel8x0. But any attempt to raise the volume results in auto-mute.

  2. #2
    Linux Engineer psic's Avatar
    Join Date
    Nov 2004
    Ljubljana, Slovenia
    Not really sure, how about trying alsaconfig (as root)? I don't really know about Fedora but it worked for mepis...
    Stumbling around the 'net:

  3. #3

    Starting sound driver: snd-intel8x0 WARNING: Error inserting snd (/lib/modules/2.6.10-1.9_FC2/kernel/sound/acore/snd.ko): Invalid module format
    WARNING: Error inserting snd_seq_device (/lib/modules/2.6.10-1.9_FC2/kernel/sound/acore/seq/snd-seq-device.ko): Invalid module format
    WARNING: Error inserting snd_rawmidi (/lib/modules/2.6.10-1.9_FC2/kernel/sound/acore/snd-rawmidi.ko): Invalid module format
    WARNING: Error inserting snd_mpu401_uart (/lib/modules/2.6.10-1.9_FC2/kernel/sound/drivers/mpu401/snd-mpu401-uart.ko): Invalid module format
    WARNING: Error inserting snd_page_alloc (/lib/modules/2.6.10-1.9_FC2/kernel/sound/acore/snd-page-alloc.ko): Invalid module format
    WARNING: Error inserting snd_timer (/lib/modules/2.6.10-1.9_FC2/kernel/sound/acore/snd-timer.ko): Invalid module format
    WARNING: Error inserting snd_pcm (/lib/modules/2.6.10-1.9_FC2/kernel/sound/acore/snd-pcm.ko): Invalid module format
    WARNING: Error inserting snd_ac97_codec (/lib/modules/2.6.10-1.9_FC2/kernel/sound/pci/ac97/snd-ac97-codec.ko): Invalid module format
    FATAL: Error inserting snd_intel8x0 (/lib/modules/2.6.10-1.9_FC2/kernel/sound/pci/snd-intel8x0.ko): Invalid module format

  4. $spacer_open

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts