Find the answer to your Linux question:
Results 1 to 1 of 1
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    pam won't let me login at agetty [SOLVED]

    After I emerged gnome and rebooted my gentoo box, i can no longer login from the physical terminal (agetty, ctrl-shift f1-f6). It asks me for username, but after I entered the username, it waits for a few seconds without prompting me for the password, and then goes back to the username prompt again.

    SSH and gdm works fine. only the agetty won't let me login. someone suggested that it is a problem with pam, but didn't have a clue about how to solve it.

    I hope all you security experts can help me. I am new to linux, and have no clue why that happened. thanks!

    i must have unmerged pam-login at some point without updating shadow. problem went away after emerge --update shadow and emerge util-linux
    Last edited by emanresu; 07-07-2006 at 03:30 AM. Reason: solution found. problem solved

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts