Ok, one of the things I like about mandrake is their KDE has a nice startup sound when desktop is loading. I always wanted to do it in fedora but using GNOME enviroment. So I posted the thread here. But I could not wait for the answer and started experimenting will all the players I installed (realplayer, mplayer, xmms, rhymthbox).

But all of them started in GUI but not mplayer! so this what you can do:

1. Download what ever sound you like from www.gnome-look.org and go to system sounds. This is the sound I am using.

2. Leave your sound in the home directory (unless some else can help with this).

3. In order for sound to play in the background you need to install mplayer.

4. Go to preferences >more preferences >sessions >startup programs and add this command:
Code:
mplayer Startup1_4.ogg
and the sound will play in the backgroud without starting mplayer gui at your desktop STARTUP!

Update: TESTED in mandrake 10.1 using Gnome 2.6 and it works. For mandrake you need to install mplayer via urpmi:
Code:
urmpi mplayer