Find the answer to your Linux question:
Results 1 to 2 of 2
NOTE : if you read the tutorial and are still experiencing difficulties and would like help, you are asked to start a new topic on the forums . Please do ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2004
    Posts
    7

    HOWTO Activate the USB system for RedHat (and maybe others)


    NOTE: if you read the tutorial and are still experiencing difficulties and would like help, you are asked to start a new topic on the forums.
    Please do NOT reply to this thread to ask a technical question. Replies to THIS thread should be corrections and enhancements on the tutorial/howto only.
    Thanks in advance for your co-operation.
    LinuxForums.org

    ------------------------------------------


    I just thought I would post this to help people in the same position as I was a few days ago.

    I was trying to use my USB Optical mouse with my laptop / RedHat9, but nothing would happen when I plugged the mouse in. I found many forum posts and help pages explaining how to troubleshoot the mouse, how to do this and that blah blah, but they all assumed that the mouse was somehow seen by the computer and just not recognised (e.g. the eye was on), but mine did nothing, the eye light did not come on, there were no messages about USB at boot.

    Well after giving up on the internet and just rooting around in the local files, I came to the kernel configuration tool in KDE. This showed me that USB support was not compiled in my kernel! Oh no I thought, I don't know how to recompile a kernel, I have only been using linux for a week! After yet more snooping around the system, I found some drivers, and after playing little, I managed to load USB support in to the Kernel without rebuilding, using the loadable kernel modules. Here is what I did, Im not sure this is totaly correct, or if it will work for you, but it seems to have worked well for me:

    Firstly I ran
    Code:
    kudzu -p > kudzu.log
    Then
    Code:
    cat kudzu.log|more
    In here I could see that my USB hardware was detected, and it hinted that usb-uhci should be the driver used, I believe this is the driver for all intel USB systems.

    Ok, so next I made my way to:
    Code:
    cd /lib/modules/2.4.20-8/kernel/drivers/usb
    note that 2.4.20-8 may be different depending on your kernel, it doesn't matter.

    Ok, now check for 3 files:

    usbcore.o (the core usb driver I would guess!)
    usb-uhci.o (the uhci specific driver, another guess)
    hid.o (human input devices driver, Im sure of this, mice-keyboards etc)


    Next I ran
    Code:
    depmod -a
    this makes sure all dependancies are loaded, I think.

    Then
    Code:
    insmod usbcore.o
    Then
    Code:
    insmod usb-uhci.o
    And finally
    Code:
    insmod hid.o
    Hey Presto, my mouse came to life and worked instantly!!!

    I was going to search for info on how to load these modules automatically on boot, but it seems
    the the kernel remembers that you loaded these, and does that automatically until you unload it manually.

    Note that although I was doing this to get my mouse running (hence hid.o), I guess if you are having the problem that your USB system is inactive then you can follow the same procedure, there are many other modules in the usb folder, for storage, cameras etc etc, so you can replace hid.o with the driver you need.

    Hope that helps save a lot of frustration for someone...

    P.s if you have any corrections or more in depth explanations to add, post below and I will update the post.

    Justin.

  2. #2
    Linux User
    Join Date
    Jan 2003
    Location
    Cardiff, Wales
    Posts
    478

    redhat

    I used to run RH9 on my laptop.

    I just had to change the following line in my /etc/modules.conf file.
    modules.conf controls the way modules are loaded and the function of the various mod functions.
    Code:
    alias usb-controller usb-ohci
    as it was initially using usb-uhci which didn't seem to work.

    To see what modules are being used run
    Code:
    /sbin/lsmod | more
    the best way to trouble shoot something like this is to plug it in after booted and then use
    Code:
    tail /var/log/messages
    You should then see the stuff that's loaded for the device. and what driver etc is claiming it.
    Don't know if this helps or not but the lsmod is much shorter than your command - and will work without kudzu.

    good luck
    Kris
    No trees were harmed during the creation of this message. Its made from a blend of elephant tusk and dolphin meat.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •