Find the answer to your Linux question:
Results 1 to 6 of 6
Hi, I have mandriva linux 2007.1. Before I configured my 3d desktop I decided to run the mandriva update tool. Now, when I try to configure beryl it says "could ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2007
    Posts
    27

    Could not install the beryl-core package Help!


    Hi, I have mandriva linux 2007.1. Before I configured my 3d desktop I decided to run the mandriva update tool. Now, when I try to configure beryl it says "could not install the beryl-core" package." So I went to the mandriva RPM download section and downloadeded all the latest beryl rpms (the core, the mager, the plugins, and settings packages.) But when I try to install them I get errors. Here is what get in the terminal when trying to install some of the different beryl packages.

    Code:
    [avi@localhost Download]$ su
    [root@localhost Download]# rpm -i beryl-core-0.2.0-2mdv2007.1.i586.rpm
    error: Failed dependencies:
            libberyl-core0 = 0.2.0-2mdv2007.1 is needed by beryl-core-0.2.0-2mdv2007.1.i586
            beryl-plugins = 0.2.0 is needed by beryl-core-0.2.0-2mdv2007.1.i586
            beryl-settings = 0.2.0 is needed by beryl-core-0.2.0-2mdv2007.1.i586
            emerald = 0.2.0 is needed by beryl-core-0.2.0-2mdv2007.1.i586
            compositing-wm-common is needed by beryl-core-0.2.0-2mdv2007.1.i586
            libberylsettings.so.0 is needed by beryl-core-0.2.0-2mdv2007.1.i586
    [root@localhost Download]# rpm -i beryl-manager-0.2.0-1mdv2007.1.i586.rpm
    error: Failed dependencies:
            xvinfo is needed by beryl-manager-0.2.0-1mdv2007.1.i586
            xlsclients is needed by beryl-manager-0.2.0-1mdv2007.1.i586
    [root@localhost Download]# rpm -i beryl-plugins-0.2.0-1mdv2007.1.i586.rpm
    error: Failed dependencies:
            beryl-core is needed by beryl-plugins-0.2.0-1mdv2007.1.i586
            libberyldecoration.so.0 is needed by beryl-plugins-0.2.0-1mdv2007.1.i586
            libberylsettings.so.0 is needed by beryl-plugins-0.2.0-1mdv2007.1.i586
    [root@localhost Download]# rpm -i beryl-settings-0.2.0-1mdv2007.1.i586.rpm
    error: Failed dependencies:
            beryl-settings-bindings = 0.2.0 is needed by beryl-settings-0.2.0-1mdv2007.1.i586
    [root@localhost Download]#
    I'm a linux newb though I'm learning a lot fast. Thanks for the help.

  2. #2
    Just Joined!
    Join Date
    Jul 2007
    Posts
    27
    well, now I also downloaded the libberyl-core so it doesn't say I need that but it still says I need everything else. It looks like all the packages need each other to be installed. Is there a way to install them all at once?

  3. #3
    Linux User abhishek456's Avatar
    Join Date
    Dec 2006
    Posts
    470
    try this in terminal

    Code:
    urpmi beryl-core beryl-manager
    urpmi takes care of dependencies
    life is the greatest opportunity that the nature had given you

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jul 2007
    Posts
    27
    This is what I get when I do that. Doing your suggesion got rid of the dependancies but I still have other errors.
    Code:
      
    [root@localhost Download]# urpmi beryl-core-0.2.0-2mdv2007.1.i586.rpm beryl-manager-0.2.0-1mdv2007.1.i586.rpm
    A requested package cannot be installed:
    beryl-core-0.2.0-2mdv2007.1.i586 (due to unsatisfied beryl-settings[== 0.2.0])
    beryl-manager-0.2.0-1mdv2007.1.i586 (due to unsatisfied xvinfo)
    Continue installation anyway? (Y/n)
    Continuing the installation doesn't help.

    This isn't really mandriva specific. It should probably be in another topic

  6. #5
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    Follow the commands exactly as they were printed by abhishek456 and post back any output. Also try adding the various main, contrib, plf and updates repos for your version of Mandriva, using the instructions from easyurpmi. By doing this you will have more packages, which can help with resolving dependencies.

  7. #6
    Just Joined!
    Join Date
    Jul 2007
    Posts
    27
    Thanks. I used easyurpmi to update and then it installed fine, .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •