Hi all.

The feedback I've got in this forum has always been amazing and has helped me make the complete transition to Linux (can't even remember Windows anymore). So I hope no-one will mind me pitching another very noobish question.

I'm having a lot of trouble getting my gamepads to work. I have tried a generic (god knows what brand) 6-button pad and (the more important) a Playstation 2 pad with a USB adapter.

Most games I use keyboard and mouse for, but I've just got the Playstation Emulator 'ePSXe' running and it's just not the same without a pad (running legally I will add. I do own a playstation, just not a TV )

When I attach the pad, the hardware section of 'Configure Your Computer' detects it as a UPS! That is confusing the hell out of me! I have tried searching the forums and Google and although I found many things mentioning gamepads and linux, I found none I understood. I still am pretty unsure what to acctually do to get it working.

Can anybody please help me out on this?

I am running Mandriva 2007 with the 2.6.17-5mdv kernel.

I don't know if it's needed, but in other threads people have asked to see 'lsusb', so here's mine:

Code:
Bus 002 Device 001: ID 0000:0000
Bus 004 Device 004: ID 058f:6362 Alcor Micro Corp.
Bus 004 Device 001: ID 0000:0000
Bus 005 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 001 Device 007: ID 1038:0100 Ideazon, Inc. Zboard
Bus 001 Device 005: ID 0925:8866 Lakeview Research WiseGroup Ltd, MP-8866 Dual Joypad
Bus 001 Device 004: ID 03eb:3301 Atmel Corp. at43301 4-port Hub
Bus 001 Device 003: ID 054c:0155 Sony Corp.
Bus 001 Device 001: ID 0000:0000
(thats with the PSX pad plugged in, bus 001 device 005)

If anyone is able to help me out on this, it would be very apreciated!