Find the answer to your Linux question:
Results 1 to 6 of 6
I've now tried 9 (count 'em) distributions of Linux to try to bring back my computer. Mandriva is the -closest- I can get to a successful install. I get all ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2007
    Posts
    6

    Exclamation Bootlader Install Failure


    I've now tried 9 (count 'em) distributions of Linux to try to bring back my computer. Mandriva is the -closest- I can get to a successful install. I get all the way up to loading GRUB. 'Preparing Bootloader' leads directly to an error, rather than the summary section. I've tried getting GRUB off of the disk in recovery mode, but it won't load off the CD, and I can't find it on the HDD (even though I selected to have the installer files copied over). Not even the LiveCD will load. The boot screen for that disk just freezes after rendering the status bar, and [esc] won't reveal the details. The specific error is "mkinitrd failed: (mkinitrd -v -f /boot/initrd-2.6.17-13mdv.img --ifneeded 2.6.17-13mdv))" including that 2nd ')' on a Dell Dimension 4600, 1GiB RAM, 120GB HDD, 256MB ATI GFX using the 2007.1 Spring Free mini CD. Yes, I've run all of the memory/disc checks.

    BTW: it's not a new box - actually a 5-yr-old jalopy w/ lots of upgraded innards. Only the case and mobo are orig. Dell.

  2. #2
    Linux Engineer scrarfussi's Avatar
    Join Date
    Aug 2006
    Posts
    1,029
    maybe its yourhardware linux is having a problem recognising your hardware

  3. #3
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Yeah, it's likely some hardware issue. You might be able to get past this by disabling some hardware, or by using the cheatcodes that are available through the F-keys right before the CD begins to fully boot.

    Otherwise, have you tried Sabayon?

    It's reported by other users right here on the forums to work with just about all hardware. I'm not sure it will work for you but others have reported it works when other distros failed.

    Let us know...
    oz

  4. #4
    Just Joined!
    Join Date
    Aug 2007
    Posts
    6
    If it were a hardware issue, wouldn't it have kicked in sooner than the last 8/10 of the way through the install? (I think?)

    In any case, I'm *right now* in the middle of trying a Debian install, and it's looking good. We'll see. Maybe the fact that my system's been cobbled together over the past 5 years? I doubt that would matter, but...whatever. I just need this @#)%(& thing up and running.

  5. #5
    Linux User abhishek456's Avatar
    Join Date
    Dec 2006
    Posts
    470
    try using any of these codes during installation and see wheter it get's past installation

    ide=nodma
    acpi=off
    acpi=off apm=off
    linux nofb
    i8042.nomux
    life is the greatest opportunity that the nature had given you

  6. #6
    Just Joined!
    Join Date
    Aug 2007
    Posts
    6

    Debian wins...sorta

    Well, the Debian install worked. In part. Linux is installed, but X11 is somehow drawing upwards of 98% of my CPU. Since my computer is now running slower than flash-frozen molasses, I need to start looking up hardware compatibility charts and check every freaking transistor, I guess. It's so strange, 'cuz Ubuntu ran beautifully on the same box with a different primary HDD (the current one was originally the secondary).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •