Find the answer to your Linux question:
Results 1 to 4 of 4

Thread: No Make File!

Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Question No Make File!

    I installed Apache successfully & then tried to install PHP-5.2.4 from a tar.gz file. After uncompressing the tar.gz file, this is how I configured PHP (as described in the help file):

    ./configure --build=i586-alt-linux --host=i586-alt-linux --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib --libexecdir=/usr/lib --localstatedir=/var/lib --sharedstatedir=/usr/com --mandir=/usr/share/man --infodir=/usr/share/info --disable-dependency-tracking --without-included-gettext --prefix=/usr --enable-inline-optimization --with-pic --enable-cli --disable-cgi --disable-debug --enable-safe-mode --disable-magic-quotes --disable-rpath --enable-bcmath --enable-ctype --enable-ftp --enable-session --enable-shmop --enable-sysvsem --enable-sysvshm --enable-libxml --disable-dom --disable-simplexml --disable-hash --enable-xml --enable-wddx --enable-shared=yes --enable-static=no --enable-so --with-layout=GNU --with-exec-dir=/usr/bin --with-zlib=/usr --with-gettext=/usr --with-iconv --without-mysql --with-mm=/usr --without-sqlite --with-regex=php --without-pear --with-config-file-path=/etc/php/5.2.4/apache-2.2.4-mod_php --with-mssql=/usr --with-apxs2=/usr/local/apache-2.2.4/bin/apxs --with-apache2=/usr/local/apache-2.2.4

    Next when I executed make, the following error got generated:

    make: *** No targets specified and no makefile found. Stop.

    When I had a look at the directory in which I uncompressed the tar.gz file, thereīs no file named Makefile though there are files named Makefile.frag, Makefile.fragments, Makefile.gcov,, Makefile.objects, makedist & makerpm.

    Why didnīt the Makefile get created when I configured PHP? It should have, isnīt it?

    I am really having a harrowing time installing LAMP. I had installed PHP successfully earlier but after installing MySQL, PHP refused to run.

    Some PLEASE give me a solution to overcome this problem. Itīs driving me nuts. Itīs been more than a week since I started installing LAMP & till now, I havenīt managed to install it.



  2. #2
    Linux Engineer rcgreen's Avatar
    Join Date
    May 2006
    the hills
    You should have gotten error messages when you
    ran configure. Run it again, and post errors here.

  3. #3
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Birmingham - UK
    You don't need to compile all those options in. If you just need to hook up with MYSQL and Apache then for example:
    ./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql=/usr/local/mysql/
    A top tip is to try to keep it simple. It will still work! The above options are just an example and you'll need to check for differences on your setup. Alternatively - assuming you have a later version of MYSQL - you might try:
    ./configure --with-apxs2=/usr/local/apache2/bin/apxs --without-mysql --with-mysqli=/usr/local/mysql/bin/mysql_config
    make && make install

    There are probably some extra steps to carry out before things will run. I rarely do this, but I would suggest buying a book, or finding out more from a Google search. Or ask on here again. It can seem hard to make this one work.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  4. $spacer_open
  5. #4
    Linux Newbie
    Join Date
    Dec 2005
    You didn't mention if configure script ran successfully to the last line ! Probably, configure script didn't finish because of some dependency problems. Run configure with those same options or whatever and see the last few lines of output. That should hint you what you are missing. If you need to find out the exact nature of error, look into config.log in the same directory as the configure script.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts