Find the answer to your Linux question:
Results 1 to 9 of 9
I've disabled power management for the monitor but it still enters standby after about 20 minutes of mouse/keyboard inactivity. It means I have to jiggle my mouse around every so ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2007
    Location
    Hilversum, Netherlands
    Posts
    11

    Screen goes into standby when watching movies


    I've disabled power management for the monitor but it still enters standby after about 20 minutes of mouse/keyboard inactivity. It means I have to jiggle my mouse around every so often when I'm watching movies. Very annoying. I would be grateful for any ideas.

  2. #2
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,672
    Check screen saver setting for your desktop and also check if there are any setting in bios that might affect this.

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  3. #3
    Just Joined!
    Join Date
    Oct 2007
    Location
    Hilversum, Netherlands
    Posts
    11
    Thanks for your reply, Lazydog.

    I have my (lovely 3d) screen saver set to come on after 40mins but I never get to see it because the monitor always goes into standby after 20 minutes of keyboard/mouse inactivity.

    I checked in BIOS and also the monitor's own settings but I can't see anything in either that would hint at hardware power management for the screen. It would seem to be something Mandriva is controlling as I don't have this issue on windows (sorry for swearing) or Ubuntu.

    Any other ideas/solutions gratefully received!!

    Thanks

    Joe

  4. #4
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,672
    OK, sounds like you have checked most things. Q:do you have power management setup on your system? Might want to look there. If you are not having issues with other OSes then it has to be a setting on this OS.

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  5. #5
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    You could try the xset command. Open a terminal, become root (the su command) and type: xset -q .

    This will produce quite a lot of output, but you need to look at the part which says:
    Code:
    DPMS (Energy Star):
      Standby: 900    Suspend: 1800    Off: 2700
      DPMS is Enabled
      Monitor is On
    You could try typing xset -dpms to disable the whole lot. Type man xset for a more complete explanation.
    Last edited by fingal; 10-13-2007 at 12:05 PM. Reason: Further details
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  6. #6
    Just Joined!
    Join Date
    Oct 2007
    Location
    Hilversum, Netherlands
    Posts
    11
    Thank you both for replying. Fingal, your suggestion has solved my problem. Great stuff!! Many thanks

    Joe

  7. #7
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Quote Originally Posted by joemoer View Post
    Thank you both for replying. Fingal, your suggestion has solved my problem. Great stuff!! Many thanks

    Joe
    Good, I'm pleased to read that! I notice that the xset manual says:
    These settings will be reset to default values when you log out.
    So you might need to add that command into a startup script somewhere. In any case, now you know the problem can be fixed somehow!
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  8. #8
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,672
    OK, to hard code this if you are using KDE so that you don't have to change it after reboot;

    Control Center -> Peripherals -> Display

    Click on Power Control

    There you can setup the monitor Standby, Suspend and Power Off timers. That will set the setting to be the same when rebooting.
    If you are using another desktop I'm sure there will be something similar.

    That is what I was talking about when I asked Q:do you have power management setup on your system?

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  9. #9
    Just Joined!
    Join Date
    Oct 2007
    Location
    Hilversum, Netherlands
    Posts
    11
    Quote Originally Posted by Lazydog View Post
    OK, to hard code this if you are using KDE so that you don't have to change it after reboot;

    Control Center -> Peripherals -> Display

    Click on Power Control

    There you can setup the monitor Standby, Suspend and Power Off timers. That will set the setting to be the same when rebooting.
    If you are using another desktop I'm sure there will be something similar.

    That is what I was talking about when I asked Q:do you have power management setup on your system?
    That was what I tried at first. I've actually switched off power management in there but strangely it doesn't seem to make a difference - the screen still goes into standby after 20 minutes regardless.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •