Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I'm running Mandriva 2008 One and I've attempted to follow this how-to guide: http://www.howtoforge.com/mandriva_p...virus_exchange I'm trying to configure Postfix to scan inbound and outbound smtp mail on my network. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2007
    Posts
    4

    Unhappy Postfix on Mandriva Gateway for Exchange


    Hi,

    I'm running Mandriva 2008 One and I've attempted to follow this how-to guide:

    http://www.howtoforge.com/mandriva_p...virus_exchange

    I'm trying to configure Postfix to scan inbound and outbound smtp mail on my network. We use Exchange 2003 internally on a Windows 2003 domain. I also have an ISA firewall sat at the border, so the Mandriva machine is behind this ISA box.

    I have email flowing just fine without using the Mandriva box. So when I have Exchange setup to route external SMTP through the ISA server using the IP of the ISA server as a smarthost, it all works fine inbound and outbound.

    As soon as I set the smarthost IP on the Exchange server to point to the Mandriva machine, email stops flowing.

    I'm a total newb with Linux, so please be gentle

    I don't even know where to look on the Mandriva box to see if mail is being received into any of the queues?

    I have tried telnetting to the Mandriva box using port 25, and I think it connects - I don't see any message saying it couldn't establish a connection - but I also don't see what I would class as an SMTP connected notice?

    I have disabled the firewall on the Mandriva box - as a temporary measure, to see if that made a difference but unfortunately it hasn't so far.

    Any help you can offer is greatly appreciated!!!

    Thanks and kind regards,

    Greg.

  2. #2
    Just Joined!
    Join Date
    Oct 2007
    Posts
    4

    Unhappy

    Hi Guys,

    After a bit more digging around, I've found the following information contained in the Postfix logs:

    /var/log/mail/info.log:
    Code:
    Oct 25 09:28:16 tlvmmail1 spamd[5868]: prefork: child states: II 
    Oct 25 09:28:16 tlvmmail1 spamd[5868]: prefork: child states: II 
    Oct 25 09:28:16 tlvmmail1 postfix/postfix-script[7445]: stopping the Postfix mail system 
    Oct 25 09:28:16 tlvmmail1 postfix/master[6961]: terminating on signal 15 
    Oct 25 09:29:47 tlvmmail1 postfix/postfix-script[5684]: starting the Postfix mail system 
    Oct 25 09:29:47 tlvmmail1 postfix/master[5685]: daemon started -- version 2.4.5, configuration /etc/postfix 
    Oct 25 09:29:48 tlvmmail1 amavis[5146]: starting.  /usr/sbin/amavisd at tlvmmail1 amavisd-new-2.5.2 (20070627), Unicode aware 
    Oct 25 09:29:48 tlvmmail1 amavis[5146]: Perl version               5.008008 
    Oct 25 09:29:50 tlvmmail1 spamd[4948]: config: failed to parse line, skipping, in "/etc/mail/spamassassin/local.cf": use_dcc1 
    Oct 25 09:29:50 tlvmmail1 spamd[4948]: config: failed to parse line, skipping, in "/etc/mail/spamassassin/local.cf": dcc_timeout 10 
    Oct 25 09:29:50 tlvmmail1 spamd[4948]: config: failed to parse line, skipping, in "/etc/mail/spamassassin/local.cf": dcc_home /var/lib/dcc 
    Oct 25 09:29:50 tlvmmail1 spamd[4948]: config: failed to parse line, skipping, in "/etc/mail/spamassassin/local.cf": dcc_path /usr/bin/dccproc 
    Oct 25 09:29:51 tlvmmail1 spamd[4948]: logger: removing stderr method 
    Oct 25 09:30:00 tlvmmail1 spamd[5818]: rules: meta test FM_DDDD_TIMES_2 has dependency 'FH_HOST_EQ_D_D_D_D' with a zero score 
    Oct 25 09:30:00 tlvmmail1 spamd[5818]: rules: meta test FM_SEX_HOSTDDDD has dependency 'FH_HOST_EQ_D_D_D_D' with a zero score 
    Oct 25 09:30:00 tlvmmail1 spamd[5818]: rules: meta test HS_PHARMA_1 has dependency 'HS_SUBJ_ONLINE_PHARMACEUTICAL' with a zero score 
    Oct 25 09:30:01 tlvmmail1 spamd[5818]: spamd: server started on port 783/tcp (running version 3.2.3) 
    Oct 25 09:30:01 tlvmmail1 spamd[5818]: spamd: server pid: 5818 
    Oct 25 09:30:01 tlvmmail1 spamd[5818]: spamd: server successfully spawned child process, pid 6048 
    Oct 25 09:30:01 tlvmmail1 spamd[5818]: spamd: server successfully spawned child process, pid 6049 
    Oct 25 09:30:01 tlvmmail1 spamd[5818]: prefork: child states: II
    /var/log/mail/warnings.log:
    Code:
    Oct 25 09:29:47 tlvmmail1 postfix/postfix-script[5603]: warning: group or other writable: /etc/postfix/./main.cf 
    Oct 25 09:29:47 tlvmmail1 postfix/postfix-script[5625]: warning: group or other writable: /etc/postfix/./main.cf~ 
    Oct 25 09:29:47 tlvmmail1 postfix/postfix-script[5641]: warning: group or other writable: /etc/postfix/./main.cf.orig 
    Oct 25 09:29:53 tlvmmail1 spamd[5818]: razor2: razor2 check failed: No such file or directory razor2: Can't read conf file: /root/.razor/razor-agent.conf at /usr/lib/perl5/vendor_perl/5.8.8/Mail/SpamAssassin/Plugin/Razor2.pm line 326.

    The /var/log/mail/errors.log file was empty

    I assume that this means the config is not quite right yet?

    Any advice based on the above logfile contents is greatly appreciated!

    Thanks and kind regards,

    Greg.

  3. #3
    Just Joined!
    Join Date
    Oct 2007
    Posts
    4
    OK, I've fixed all those errors and I'm making some progress

    It now appears as though my problem lies with Amavisd. Having Googled for this, I should be able to telnet to 127.0.01 on port 10025 - but this is not working. I've tried to amend the amavisd.conf file and now when I issue the command amavisd reload, I get the following error:

    The amavisd daemon is apparently not running, no PID file /var/lib/amavis/amavisd.pid

    Any ideas why that's occurring and how I should fix it? Should I just re-install Amavisd and start over?

    Thanks,

    Greg.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2007
    Posts
    4

    Unhappy

    OK, I did manage to get Amavisd to run now after using the amavisd debug command and fixing what was wrong there. I can telnet to 127.0.0.1 10025, but it seems like the email relaying is not configured correctly. I now get the following error in the /var/log/mail/info/log file:

    Code:
    Oct 26 14:24:15 tlvmmail1 postfix/smtpd[7868]: connect from tlvsmail1.tlab.local[172.xxx.xxx.xxx] 
    Oct 26 14:24:18 tlvmmail1 postfix/smtpd[7868]: D54D730AA1: client=tlvsmail1.tlab.local[172.xxx.xxx.xxx] 
    Oct 26 14:24:18 tlvmmail1 postfix/cleanup[7871]: D54D730AA1: message-id=<3927C4FEE97FAF4F9BF223B02624190E24FC@TLVSMAIL1.tlab.local> 
    Oct 26 14:24:18 tlvmmail1 postfix/qmgr[7235]: D54D730AA1: from=<gregn@myaddress.com>, size=2510, nrcpt=1 (queue active) 
    Oct 26 14:24:18 tlvmmail1 postfix/smtpd[7868]: disconnect from tlvsmail1.tlab.local[172.xxx.xxx.xxx] 
    Oct 26 14:24:20 tlvmmail1 amavis[7103]: (07103-03) Blocked MTA-BLOCKED, [172.xxx.xxx.xxx] <gregn@myaddress.com> -> <gregnottage@gmail.com>, Message-ID: <3927C4FEE97FAF4F9BF223B02624190E24FC@TLVSMAIL1.tlab.local>, mail_id: YB4u1Zy7PilA, Hits: 2.176, size: 2510, 1956 ms 
    Oct 26 14:24:20 tlvmmail1 postfix/smtp[7872]: D54D730AA1: to=<gregnottage@gmail.com>, relay=127.0.0.1[127.0.0.1]:10025, delay=2.1, delays=0.08/0.02/0.09/1.9, dsn=4.5.0, status=deferred (host 127.0.0.1[127.0.0.1] said: 451 4.5.0 From MTA([127.0.0.1]:10026) during fwd-connect (Negative greeting:  at (eval 52) line 442, <GEN8> line 504.): id=07103-03 (in reply to end of DATA command))
    Any ideas what needs changing?

    Thanks,

    Greg.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •