Find the answer to your Linux question:
Results 1 to 5 of 5
Right now I'm trying to get my Winfast TV2000 XP TV Tuner (NTSC) to work on my Mandriva Spring (2007.1) and I can't seem to get it to work. Mandriva ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2007
    Location
    Arizona
    Posts
    4

    Problems with TV Tuner Card


    Right now I'm trying to get my Winfast TV2000 XP TV Tuner (NTSC) to work on my Mandriva Spring (2007.1) and I can't seem to get it to work. Mandriva seems to detect it, but when I start up a tv program like Tv Time I get a blue screen that says no signal and when I use KDETV scanning for channels brings up nothing. Here is my dmesg output

    Linux video capture interface: v1.00
    saa7130/34: v4l2 driver version 0.2.14 loaded
    bttv: driver version 0.9.16 loaded
    bttv: using 4 buffers with 2080k (520 pages) each for capture
    bttv: Bt8xx card found (0).
    ACPI: PCI Interrupt 0000:00:08.0[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 11
    bttv0: Bt878 (rev 17) at 0000:00:08.0, irq: 11, latency: 32, mmio: 0xe2018000
    bttv0: detected: Leadtek TV 2000 XP [card=34], PCI subsystem ID is 107d:6609
    bttv0: using: Askey CPH05X/06X (bt87 [many vendors] [card=24,insmod option]
    bttv0: gpio: en=00000000, out=00000000 in=003ff502 [init]
    bttv0: using tuner=2
    bttv0: i2c: checking for MSP34xx @ 0x80... not found
    bttv0: i2c: checking for TDA9875 @ 0xb0... not found
    bttv0: i2c: checking for TDA7432 @ 0x8a... not found
    bttv0: i2c: checking for TDA9887 @ 0x86... not found
    tuner 0-0061: chip found @ 0xc2 (bt878 #0 [sw])
    tuner 0-0061: type set to 2 (Philips NTSC (FI1236,FM1236 and compatibles))
    bttv0: registered device video0
    bttv0: registered device vbi0
    bttv0: PLL: 28636363 => 35468950 .. ok
    input: bttv IR (card=24) as /class/input/input2
    bttv-input: bttv IR (card=24) detected at pci-0000:00:08.0/ir0
    bt878: AUDIO driver version 0.0.0 loaded
    bt878: Bt878 AUDIO function found (0).
    ACPI: PCI Interrupt 0000:00:08.1[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 11
    bt878_probe: card id=[0x6609107d], Unknown card.
    Exiting..
    ACPI: PCI interrupt for device 0000:00:08.1 disabled
    bt878: probe of 0000:00:08.1 failed with error -22

    By the way I did try to edit the modprobe.conf so the default tuner=5 and the card=34
    any help with this would be greatly appreciated. Sorry if I left out any Important details I am new to linux and have been a winblows user for most my life.

  2. #2
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Hi - I've not had much luck getting my own tv card to work. This might be a good starting point: video4linux

    From what I can tell, some chipsets are well supported, while others cause problems. Good luck!
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  3. #3
    Just Joined!
    Join Date
    Nov 2007
    Posts
    3
    My old ATI card with the bt878 chipset is the one thing on my machine that always works and never breaks during upgrades! Bought it way back in win98 days. Now working fine on 2008.

  4. #4
    Just Joined!
    Join Date
    Oct 2007
    Location
    Arizona
    Posts
    4
    O.k. after a week of searching I finally got it to work thanks to this article XFree86 and Video4Linux. It was really quite simple to get working all I had to do was install the i2c driver and like magic everything started working. Thanks to all of those who and input to add to this thread and hopefully it will help some users out. Next thing is to get the IR remote working.

  5. #5
    Just Joined!
    Join Date
    Oct 2007
    Location
    Arizona
    Posts
    4
    O.k. I need a little more help. I want to install and configure lirc, but can't get it to work. I tried using the lirc package that comes with mandriva, but I don't know how to configure it. So I tried to install it from source so I could configure it before the install. Here is what I did.

    "cd /usr/src/lirc-0.8.2"

    "./setup.sh"
    which starts a semi graphical interface

    I choose card 34 as the driver and saved/ran the config which went fine

    afterwhich I did a "make"

    and thats when I run into errors

    make[5]: *** [/usr/src/lirc-0.8.2/drivers/lirc_gpio/lirc_gpio.o] Error 1
    make[4]: *** [_module_/usr/src/lirc-0.8.2/drivers/lirc_gpio] Error 2
    make[4]: Leaving directory `/usr/src/linux-2.6.17-16mdv'
    make[3]: *** [lirc_gpio.o] Error 2
    make[3]: Leaving directory `/usr/src/lirc-0.8.2/drivers/lirc_gpio'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/usr/src/lirc-0.8.2/drivers'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/usr/src/lirc-0.8.2'
    make: *** [all] Error 2

    From here I don't know what to do. Any help would be appreciated.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •