Find the answer to your Linux question:
Results 1 to 8 of 8
I have Mandriva 2007 (not Spring) installed on my laptop. The laptop runs a screen resolution of 1280x800 and all works fine as long as I run normal desktop applications ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Location
    Sydney, Australia
    Posts
    86

    Restricting screen resolution


    I have Mandriva 2007 (not Spring) installed on my laptop. The laptop runs a screen resolution of 1280x800 and all works fine as long as I run normal desktop applications (like OpenOffice, Anjuta, Netbeans etc). But I occasionally want to play games using wine, or dosbox. Whenever I run one of these games in full screen mode they cut off the bottom of the screen. How can I fix this? I suppose I have to change something in my XOrg.conf but I do not know what, can someone help me with a few pointers?

  2. #2
    Just Joined! ikirkum's Avatar
    Join Date
    Dec 2006
    Posts
    2
    Quote Originally Posted by daik View Post
    I have Mandriva 2007 (not Spring) installed on my laptop. The laptop runs a screen resolution of 1280x800 and all works fine as long as I run normal desktop applications (like OpenOffice, Anjuta, Netbeans etc). But I occasionally want to play games using wine, or dosbox. Whenever I run one of these games in full screen mode they cut off the bottom of the screen. How can I fix this? I suppose I have to change something in my XOrg.conf but I do not know what, can someone help me with a few pointers?
    open terminal and run setup and check if you find X Configuration and change that resolution to 1024x728 and check the same.

  3. #3
    Just Joined!
    Join Date
    Jan 2007
    Location
    Sydney, Australia
    Posts
    86
    I do not seem to have 'setup' installed, do you happen to know what package I need to install to get this? (I tried both as my user and as root)

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2007
    Location
    Mexico
    Posts
    65
    Did you try right click on the desktop, Desktop Configuration, Screen, Size Screen???

    choose 1024

    or if it dont appears, add it on Xorg.cof ( /etc/X11 )

    Im using ( now ) Mandriva One 2008

  6. #5
    Just Joined!
    Join Date
    Jan 2007
    Location
    Sydney, Australia
    Posts
    86
    Now I am back after being away for a few weeks...
    I do not have that option. I can "customize desktop background" (or what the wording happen to be, I have that machine off right now). Maybe that is a new feature in mandriva 2008?
    Anyone know how to do this in 2007.0, it seems to be exactly what I am after, setting the size of the screen.
    However gnome works just fine, if I maximize a normal gnome application it sizes itself properly. It is only wine applications that misbehaves it seems.

  7. #6
    Just Joined!
    Join Date
    Oct 2006
    Location
    Surrey, UK
    Posts
    22
    If you are using KDE you can put the "Resize and Rotate" applet in the system tray.
    When you click this applet you get a menu of screen sizes to choose from.

    To get the applet goto MENU System->Configuration->Hardware->KRandRTray

    HTH
    Terry.

  8. #7
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Post the contents of /etc/X11/xorg.conf file here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #8
    Just Joined!
    Join Date
    Jan 2007
    Location
    Sydney, Australia
    Posts
    86
    Here is my xorg.conf. I would assume the problem lies in this file, but I am not confident enough to spot it or fix it. Any help is greatly appreciated!
    Attached Files Attached Files

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •