Find the answer to your Linux question:
Results 1 to 5 of 5
The problem is I cannot have write access to a shared FAT32 partition. I've been working on it for too long, basically doing and redoing the same things, but nothing ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2007
    Posts
    3

    partition ownership and permissions - I need help!


    The problem is I cannot have write access to a shared FAT32 partition.
    I've been working on it for too long, basically doing and redoing the same things, but nothing seems to change the situation. I'm starting to feel

    What I've tried:
    1) first chown from terminal (I then understood that it doesn't work on fat32 partition where the user will always be root)
    2) using Manage disk partition from the Mandriva Control Center, changing the options, formatting, umounting and mounting again
    3) then i've started writing on /etc/fstab from terminal and trying to allow as much as possible but nothing seems to help!

    From the mounted list:
    /dev/hda7 on /media/10G type vfat (rw,check=relaxed)

    This is My /etc/fstab (the problem is with /dev/hda7):
    /dev/hda6 / reiserfs defaults 1 1
    /dev/hda7 /media/10G vfat auto,uid=500,gid=500,rw,umask=000 0 0
    /dev/sda1 /media/hd vfat umask=0,users,iocharset=utf8,sync,noauto,exec 0 0
    /dev/hda1 /media/hd2 ntfs umask=0022,nls=utf8,sync,ro 0 0
    /dev/sdb1 /media/hd3 vfat umask=0,users,iocharset=utf8,sync,noauto,exec 0 0
    none /proc proc defaults 0 0
    /dev/hda5 swap swap defaults 0 0

    I really don't know what to do more. Please, help me!!!

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !

    /dev/hda7 /media/10G vfat auto,uid=500,gid=500,rw,umask=000 0 0
    /dev/sda1 /media/hd vfat umask=0,users,iocharset=utf8,sync,noauto,exec 0 0
    /dev/hda1 /media/hd2 ntfs umask=0022,nls=utf8,sync,ro 0 0
    /dev/sdb1 /media/hd3 vfat umask=0,users,iocharset=utf8,sync,noauto,exec 0 0
    defaults and umask=0 set default permissions for all users. Linux doesn't support NTFS write access out of box. Regular users will have NTFS read and Fat32 read/write access.
    Edit /etc/fstab file.
    Code:
    /dev/hda7 /media/10G vfat defaults,umask=0  0  0
    /dev/sda1 /media/hd vfat defaults,umask=0  0  0
    /dev/hda1 /media/hd2 ntfs defaults,umask=0  0  0
    /dev/sdb1 /media/hd3 vfat defaults,umask=0  0  0
    Install ntfs-3g package to enable NTFS write access.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Nov 2007
    Posts
    3
    Thanks for the suggestion, but it's not changing the situation.

    My problem is just with /dev/hda7 (that is a fat32), all the other partitions are working fine and I don't need to write on the ntfs partition.

    I unmounted hda7, changed the configuration and mounted it again, but I still can't write on this partition. What is the solution to this? I really can't get out of this and I have a partition that I can't use.

    Here my /etc/fstab now:
    /dev/hda6 / reiserfs defaults 1 1
    /dev/hda7 /media/10G vfat defaults,umask=0 0 0
    /dev/sda1 /media/hd vfat umask=0,users,iocharset=utf8,sync,noauto,exec 0 0
    /dev/hda1 /media/hd2 ntfs umask=0022,nls=utf8,sync,ro 0 0
    /dev/sdb1 /media/hd3 vfat umask=0,users,iocharset=utf8,sync,noauto,exec 0 0
    none /proc proc defaults 0 0
    /dev/hda5 swap swap defaults 0 0

    Have a nice night and try to give a feedback if you can help me!

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Nov 2007
    Posts
    3
    I finally did it!!!

    unmount (umount /dev/hd7),
    made a new directory (mkdir /media/10G),
    and finally mount again with (mount /dev/hda7 /media/10G -t vfat -o umask=000)

    Now it works, I can write on that FAT partition. Don't ask me why it didn't work with all the other lines I've been writing.

  6. #5
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    made a new directory (mkdir /media/10G),
    Did you delete existing /media/10G folder before creating new one? It looks like mount point problem only.
    Glad to know that you have sorted out problem !
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •