Find the answer to your Linux question:
Results 1 to 5 of 5
Greetings Forum, I didn't quite know where exactly to put this post, but since I'm using Mandrake 10, I figured this is as good as any. My problem is something ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2003
    Location
    East Coast USA
    Posts
    15

    Multiple Sound Cards


    Greetings Forum,

    I didn't quite know where exactly to put this post, but since I'm using Mandrake 10, I figured this is as good as any. My problem is something I would imagine is simple to fix (although, I cannot seem to fix it). I have a computer with a Creative Labs sound card and a sound card built into my motherboard. Now Mandrake found both cards, and installed drivers for each, I am currently booted in Windows so I cannot list the drivers the install chose. Now I think I know what the problem is and I have experimented. I believe that Mandrake chose the onboard sound card as the default (just as windows does when I install it) and it uses this sound card for everything. However, my speakers are plugged into my SoundBlaster. Now, I tried something simple and disabled the onboard sound card in BIOS. When I booted into Linux, KDE was sluggish and it took a good 40 seconds longer for it to actually start (KDE that is) and once I was in KDE the sound worked, but the whole desktop was slow, it took well over a minute for a virtual terminal to come up. Then when I clicked the equivalent of start->shutdown the X Server hung up.

    As soon as I boot back into Linux, I can list the drivers chosen for each card. Anyone have any ideas on how I can make my SoundBlaster card the default card. I would hate not being able to use it because it sounds a lot better than the built in card.

    Thanks for any help
    -Primary Canary

  2. #2
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    i don't know well about mandrake but the same problem i had though.suse uses yast and the only thing you have to do is to disable your sound card not from bios but from linux.or you can choose with kamix the default sound card to be sound blaster by right clicking on the icon.
    Linux For Ever!

  3. #3
    Just Joined!
    Join Date
    Jan 2003
    Location
    East Coast USA
    Posts
    15
    Ok,
    suse uses yast and the only thing you have to do is to disable your sound card not from bios but from linux.or you can choose with kamix the default sound card to be sound blaster by right clicking on the icon
    How do I disable the card from linux?

    I currently do not have a kamix installed (I tried locate kamix because kamix cannot be found) but I do have a KMix, is that what you meant? When I right click on KMix, I get the options
    Configure KMix
    About KMix
    Mute
    Hide Mixer Window
    Quit

    Configure KMix brings up a dialog where you can specify GUI options for the mixer window. I do not see where to disable or choose a sound card using KMix.

    Now as for the information that linux found on my sound cards.
    I click start->system-configuration-configure your computer which brings up Mandrake Control Center

    I goto the hardware section which looks similar to Windows DeviceManager
    Under sound there are two cards listed
    Sound Blaster AudioPCI64V/AudioPCI128 with the following information
    • Vendor: ‎Creative Labs
      Alternative drivers: ‎snd-ens1371
      Bus: ‎PCI
      Bus identification: ‎1274:1371
      Location on the bus: ‎0:a:0
      Description: ‎Sound Blaster AudioPCI64V/AudioPCI128
      Module: ‎es1371
      Media class: ‎MULTIMEDIA_AUDIO


    and under that is
    ‎VT8233 [AC97 Audio Controller] with
    • Vendor: ‎VIA Technologies
      Alternative drivers: ‎via82cxxx_audio
      Bus: ‎PCI
      Bus identification: ‎1106:3059
      Location on the bus: ‎0:11:5
      Description: ‎VT8233 [AC97 Audio Controller]
      Module: ‎snd-via82xx
      Media class: ‎MULTIMEDIA_AUDIO


    now there are buttons under the information window labeled
    configure module and run config tool
    but these just let me choose an alternate driver. I need to change the default sound card.
    Any Ideas anyone? Any help is greatly appreciated.
    - Primary Canary

  4. #4
    Just Joined!
    Join Date
    Aug 2004
    Posts
    4
    you can have both souncards active and still use your sblive as the default

    To do that Goto 'configure your computer' and there for 'hardware'

    in the hardware list you will see both of your soundcards listed.

    go for the reinstallation (i donot remember the name as i'm in a netcafe not on linux) and a window pops up asking you to select module for your soundcards one by one..

    change the module if alsa then oss only for your sblive card and reboot your system.

    Now I hope your both cards will work with sblive as the default one.

    Now if you want you can reconfigure your sblive card to use the old module and still have it as the dafault.

    The point here is that the last soundcard configured is the default one.

    I it does not wrkout try configuring alternately.

  5. #5
    Linux User
    Join Date
    Nov 2002
    Posts
    420
    There should be a setting in your bios to disable the on-board features. It is usually labelled Bios features or something similar. This is the best way to disable the on-board sound. If it is not under bios features then try some of the other headings. Ususally installing a card disables on-board features but obviously this did not happen in your case.

    Counterspy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •