Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
I have a Seagate external hard drive which shows up int the Mandriva Control Centre /Hardware but fails to appear under Konqueror's Storage Media. As a result I can't access ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2006
    Posts
    35

    EXTERNAL HD fails to mount MANDRIVA 2008


    I have a Seagate external hard drive which shows up int the Mandriva Control Centre /Hardware but fails to appear under Konqueror's Storage Media. As a result I can't access it for backups etc.

    Any ideas on how to rectify this problem would be appreciated.

    Thanks in advance,

    Tony Littlejohn

  2. #2
    Linux Engineer scrarfussi's Avatar
    Join Date
    Aug 2006
    Posts
    1,029
    I had the same problem you hav to format the drive . I don't know how to do it in mandriva so i used gparted try using mandriva's partition manager to format it

  3. #3
    Just Joined!
    Join Date
    Nov 2006
    Posts
    35
    Thanks for the reply. It is slightly comforting to know that someone else has the same problem,. In my case I am not tryi ng to format the drive. just access and then write to it. Which amounts to the same thing as being able to format the drive.

    What i don't understand is the Mandriva 2007 and 2007.1 had no difficulty in locating the drive. The only thing that I have yet to check is whether or not HotPlugging is installed.

    Tony

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! brokenwings's Avatar
    Join Date
    Nov 2007
    Location
    Finland
    Posts
    26
    Seagate drive most probably is a NTFS drive. Do you have NTFS support installed? I guess the proper packages are "libntfs9" and "ntfsprogs", try
    #urpmi libntfs9 ntfsprogs

  6. #5
    Just Joined!
    Join Date
    Nov 2006
    Posts
    35
    Thanks for that Brokenwings.

    My Seagate External drive is in FAT32 format and was recognised and accessible under Mandriva 2007 and 2007.1.

    When I go to the MCC and choose HARDWARE the Seagate drive shows up. If I click on SDA in the Hardware listing, the drive springs into life. But one I try to access it under Konqueror /media, it is not there; just the Windows and Linux partitions.

    So I am no further along the line of accessing the Seagate drive. It remains a mystery to me.

    Tony Littlejohn

  7. #6
    Just Joined! iorulezz's Avatar
    Join Date
    Dec 2007
    Location
    UK, 70s
    Posts
    4
    I have the same problem with my Transend external drive. I have Mandriva 2007 and the funny thing is that it worked well and suddenly it stopped working. It doesn't automount anymore and I have to do it manually which is really tiring (opening the terminal and writing the same lines every time).
    I also have the same problem with the DVD drive.
    My system mounts at boot all the drives and the Windows(sorry...) ones but it doesn't automount any external device!
    What could that be????

  8. #7
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Post the contents of /etc/fstab file and output of df -h command.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #8
    Just Joined!
    Join Date
    Nov 2006
    Posts
    35
    iorulezz,
    To auto mount your external drive, open a terminal and type
    su
    Enter root password

    Then type either "konqueror" (KDE desktop) or "nuatilus" (Gnome desktop).

    One of the two file managers will open up with root privileges.
    Next navigate your way to the /etc/fstab file.

    Click on fstab and something like this will appear:

    /dev/hda5 / ext3 noatime 1 1
    /dev/hda7 /home ext3 noatime 1 2
    /dev/cdrom /media/cdrom auto umask=0022,users,iocharset=utf8,noauto,ro,exec 0 0
    /dev/hda1 /mnt/windows ntfs umask=0022,nls=utf8,ro 0 0
    none /proc proc defaults 0 0
    /dev/hda6 swap swap defaults 0 0
    /dev/sda1 /media/hd vfat umask=0022,users,iocharset=utf8,sync,noauto,exec 0 0

    I am using Mandriva 2008 and in this version the /dev/sda1 drive (that's my External drive) is in the /media/hd folder. Your External drive will probably be in the /mnt folder.

    Notice the "noauto" remark towards the end of the /dev/sda1 line. This means that it will not mount automatically.

    Change "noauto" to "auto"

    Save the fstab file and it should mount automatically.

    To check everything is OK, close the fstab file and then reopen it. You should see the new version.

    Now simply reboot the system and all should be well.

    This web page helped me out a lot : fstab file format or syntax in linux with fstab manpage link

    It is written well and easy to understand.

    All the best,

    Tony Littlejohn

  10. #9
    Just Joined! iorulezz's Avatar
    Join Date
    Dec 2007
    Location
    UK, 70s
    Posts
    4
    Unfortunately this did not solve my problem. Now my fstab looks like this:

    Code:
    /dev/hda7 / ext3 defaults 1 1
    /dev/hda9 /home ext3 defaults 1 2
    none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=utf8,sync 0 0
    /dev/hda1 /mnt/win_c vfat umask=0,iocharset=utf8 0 0
    /dev/hda5 /mnt/win_d vfat umask=0,iocharset=utf8 0 0
    /dev/hda6 /mnt/win_e vfat umask=0,iocharset=utf8 0 0
    none /proc proc defaults 0 0
    /dev/hda8 swap swap defaults 0 0
    /dev/sda1 /media/removable vfat umask=0022,users,iocharset=utf8,sync,auto,exec 0 0
    At boot the kernel tries to boot the removable showing the message device removable not found. When KDE starts I connect the drive and it doesn't mount. I have to do from the terminal again. The only difference is that now the folder media has a folder named removable in it.

    If I connect my drive and double click on the removable folder I get an error "Feature only available with HAL". I updated the HAL to the last version but nothing new happened... Any ideas?

    EDIT:

    Maybe I could also add an
    Code:
    dev / nodev
    
    Permit any user to mount the filesyste. This automatically implies noexec
    option so it will give me who I don't login as the SuperUser the ability to mount the removable?

    Also I don't understand the umask option.

    Thanks again!

  11. #10
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    /dev/sda1 /media/removable vfat umask=0022,users,iocharset=utf8,sync,auto,exec 0 0
    Replace it with this
    Code:
    /dev/sda1 /media/removable vfat defaults,umask=0 0 0
    umask controls permissions of all regular users and 0 value allows default permissions.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •