Find the answer to your Linux question:
Results 1 to 7 of 7
i've spent over 4 hours trying to figure out how to install things. i have tried searching the internet but i couldnt understand what the hell they were getting at. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Posts
    11

    Omg How The Hell Do I...


    i've spent over 4 hours trying to figure out how to install things.

    i have tried searching the internet but i couldnt understand what the hell they were getting at.

    i would download something and then when i try to open it, it just opens the file up and shows me whats in it. i extract the file. and then i go find it and its the same thing.

    ive been told to

    1. gunzip filename.tar.gz
    2. tar -xvf filename.tar
    3. cd filename/
    4. ./configure
    5. make && make install

    i dont know anything about anything... about that. it makes absolutely no sense. i dont even know where im supposed to go for that or what

    i dont know what he was getting at. where do i put these commands in? then one of the sites told me i needed some file to do it and then downloaded the file and it did help because i dont know how to install it.

    honestly i dont know anything about installing. i dont even know what the directory is, i mean i have an idea of what it is but... still no help at all.

  2. #2
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    You don't need to install from source. It's not a great way of doing things unless you have a reason i.e. new code change, experimental release etc.

    Instead you should use the software management part of the Control Centre. Also take a look at Easy Urpmi to seet up online repositories. You'll be amazed how much better it is than compiling from source every time

  3. #3
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Welcome to the forums, dannye1337!

    The URPMI method suggested above by bigtomrodney is definitely (in my opinion) the easiest way to install software under Mandriva. You can check this HowTo for a number other ways to install software under Linux. The tarball/source method is probably the most difficult method for new Linux users.
    oz

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2008
    Posts
    11
    umm i have read the help posts...

    and

    i still dont get it.

    where do i change the directory or better yet... what is a directory.

    and where do i go for these commands? where do i put them..


    and what is a console!!!

  6. #5
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Ah, if you are interested in learning command line Linux, check out:

    LinuxCommand.org: Learn the Linux command line. Write shell scripts.

    A directory is basically the same thing as a folder. LinuxCommand.Org has good information on learning to use the cd command to change directories and mkdir for creating them.

    As for consoles, you can boot into a console by not allowing the Xserver to start, or you can look for Terminal or Konsole in your start menu to be used while running the graphical user interface.
    oz

  7. #6
    Just Joined!
    Join Date
    Jan 2008
    Posts
    11
    ok i think ive gotten half of the part of how to install things heres what i did

    i opened the terminal and made a new shell

    i typed mkdir /usr/local/src/

    and it gives me this: (ok i know what that means)
    mkdir: cannot create directory `/usr/local/src/': File exists

    then i typed in cd /usr/local/src/ (i understand this)

    it brings me to the folder or directory

    then i typed ls ok so nothings in there...

    so then i typed /home/danny where all my files are in there

    then i typed ls

    and got

    cd/ Documents/ msn/ Pictures/ tcl8.5.0/ Videos/
    Desktop/ Download/ Music/ rar/ tmp/

    and what im trying to do is installing amsn so i type cd msn

    then it brings me inside the folder and then i type

    ./configure and then it gives me

    checking for prefix by checking for wish... no
    which: no tclsh in (/usr/bin:/bin:/usr/local/bin:/usr/X11R6/bin/:/usr/games:/usr/lib/qt3//bin:/home/danny/bin:/usr/lib/qt3//bin)
    expr: syntax error
    ./configure: line 1921: test: too many arguments
    checking for gcc... no
    checking for cc... no
    checking for cl.exe... no
    configure: error: no acceptable C compiler found in $PATH
    See `config.log' for more details.



    then i dont know what to do there...

    ... i think i untarred the files... if i did it was to /home/danny

  8. #7
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Do you have gcc installed? If yes, maybe it's a path problem.

    If no, you should be able to install it by going to a console and with root permissions, entering:

    Code:
    urpmi gcc
    If you don't have urpmi setup, I think you can go probably to the Control Center and install it off of your installation CDs:

    Control Center > Software > Install, Remove & Update Software

    I don't run Mandriva, so I hope I got all that right.
    oz

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •