Find the answer to your Linux question:
Results 1 to 3 of 3
Hey, I have MDK 10. When I originally installed the system, it had several nonsensical names for some of the mounted partitions/drives. I changed the fstab to some more reasonable ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    5

    Mounts reappearing after deleting them


    Hey,
    I have MDK 10. When I originally installed the system, it had several nonsensical names for some of the mounted partitions/drives.

    I changed the fstab to some more reasonable settings/names, but now when it boots, its still somehow trying to mount the same drives/partitions under the old names.

    In fact, when KDE loads, and I look in the filemanager under /mnt, I still see the mount points. If I delete them and refresh the folder view, they come back.

    I tried killing automount (thinking it might be doing it), but even with automount dead, they would still come back.

    I've been grep'ing /etc for the mount point names trying to find out where/how they're being called, with no luck yet.

    Any ideas?

  2. #2
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    u have to change the directory names in /mnt as well (as root)

    mounting a drive just makes its contents accessible in an empty directory. so rename the dirs in /mnt to the same things u put in fstab. then as root unmount from the old places and run rmdir /mnt/old_name

    deleting things in guis sometimes fails if u dont have the priviledges required to do it.

  3. #3
    Just Joined!
    Join Date
    Jul 2004
    Posts
    5

    doh!

    Man... i feel sheepish It was just as you said (I could've sworn though that I tried deleting them su'd as root, and they came back after a reboot).

    In any case, it does appear that the reason it was happening when done via KDE's filemanager was b/c the filemanager wasnt running under root. Even though the items were being sent to the trash apparently they werent really being deleted.

    Thanks again!

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •